Broadcom bcm4312 wireless not detected at all

Bug #203819 reported by Applegeek on 2008-03-19
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Hardy Alpha 6

On HP Pavilion dv2470se laptop, 630M/7150M gpu chipset, kernel 2.6.24-12-generic: Broadcom bcm4312 wireless adapter is never detected at all with b43 or b43legacy drivers. fwcutter used to create firmware as described at linuxwireless.org, placed in lib/firmware for both b43 and b43legacy. Nothing. Acts like chip is never there. Laptop works fine with XP and Broadcom driver.

lilu (kostaki) wrote :

Same problem occurs on HP Pavilion dv9056ea. Unable to get bcm4312 working.

Applegeek (gromitsprinkles) wrote :

What's interesting is the chip on the laptop is bcm4312 (looking at it) but lspic reports finding Broadcom 4310 rev 1. It could be that "unknown pci bridge" is really the problem, that lspci also reports, perhaps.

Jacob (frias90) wrote :

I'm on a Lenovo 3000 N100 laptop, with the same bcm4312 wireless chip. The chip is detected by Ubuntu in the Hardware Drivers utility but it freezes my computer when I enable it. For further explanation, I am using Ubuntu 8.04.

icechen1 (houyuchen66) wrote :

On a Gateway MX6414,the chip is detected and I was able to see networks but I am not able to connect,

Luis Manuel (luismanuel1964) wrote :

I am experiencing the same problem on the HP Pavilion dv2715nr with kernel 2.6.24-15 (Ubuntu 8.04 Beta). I have a Broadcom BCM4310 wireless adapter. I tried using fwcutter it did not work then I tried using ndiswrapper using the Windows Vista driver for the card that did not work either.

Brijam (brian-opensourcery) wrote :

Same problem here.

HP dv9610US, Kubuntu 8.04, Broadcom Corporation BCM4312 802.11a/b/g (rev 02), also not being detected with b43-fwcutter. bcm43xx is blacklisted in /etc/modprobe.d/blacklist, b43 is loaded as a module, but no luck.

Brijam (brian-opensourcery) wrote :

The workaround posted by icechen1 worked for me, after a great deal of fiddling. I'd much rather use native drivers.

I forgot to mention I'm using 64 bit.

Neil Munro (neilmunro) wrote :

Looks like a driver issue.

Craig Barnes (cjbarnes18) wrote :

Same issue on Dell Studio 17
0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

Hi gromitsprinkles,

This bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux-image-`uname -r` 203819

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-kernel-logs
tags: added: needs-upstream-testing
tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete

Architecture: i386
DistroRelease: Ubuntu 9.04
HibernationDevice: RESUME=UUID=67c19d79-9f66-46c1-a411-a23724638114
MachineType: Dell Inc. Latitude E6400
Package: linux-image-2.6.28-15-generic 2.6.28-15.49
PackageArchitecture: i386
ProcCmdLine: root=UUID=ab447e4f-7687-4e23-a55b-38b48e980f3c ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.28-15.49-generic
Uname: Linux 2.6.28-15-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

TraceyC (grrlgeek) wrote :

I'm having the same issue, which started after I did an automatic update in Ubuntu Jaunty 8.04. The wireless card was detected and working fine until this update. Now the network card doesn't show up in the Gnome network-manager or ifconfig. Previously it was assigned eth1.

From lshw:
            *-network
                description: Network controller
                product: BCM4312 802.11b/g
                vendor: Broadcom Corporation
                physical id: 0
                bus info: pci@0000:0c:00.0
                version: 01
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list
                configuration: driver=b43-pci-bridge latency=0 module=ssb

I will try testing with the upstream kernel. I'm not able to test with the latest development release of Ubuntu at the moment as this is my office laptop.

TraceyC (grrlgeek) wrote :

Tested with the upstream kernel that matches my previously installed Ubuntu kernel.
The wireless card is still not showing up in ifconfig.
Ubuntu Kernel Version Mainline Kernel Version
2.6.28-15.52 2.6.28.10

Also tested with kernel dated daily/2009-09-12
This kernel would not boot my system, it hung with a blank screen after the Ubuntu splash screen with the loading bar.
linux-headers-2.6.31-999_2.6.31-999.200909121000_all

Tested with kernel 2.6.28-11-generic
uname -a 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
Wireless card is detected & working with this kernel. I am able to successfully connect to a wireless network.

Can you actually retest with the latest Karmic Beta release? It contains a newer 2.6.31 based kernel. ISO images are available at http://cdimage.ubuntu.com/releases/karmic/ . Please let us know your results. Thanks!

Leslie Viljoen (leslieviljoen) wrote :

Not working at all in Karmic Beta with kernel 2.6.31-11. No sign of the wireless card in iwconfig/ifconfig.
lcpci says BCM4312 rev 01.

The laptop is a Lenovo G530 4446-22G.

The link above for a work-around no longer seems to work.

Leslie Viljoen (leslieviljoen) wrote :

Followed steps here:
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff#Step 2b: sp33008 Driver Download/Extraction
They did not seem to work - the still no device in ifconfig/iwconfig, even though the modules seem to be loaded.

lshw -C network says:
configuration: driver=b43-pci-bridge latency=0

Is there a work-around I can use? Is there anything I can do to help get this working in Karmic before the release?!

Leslie Viljoen (leslieviljoen) wrote :

Woohoooo! I got the wireless working! I used Kernel 2.6.32-999-generic and had to download firmware.

Here are the steps:

1. First connect the computer to the Internet with a cable (this is the easiest way)
2. Go here: https://wiki.ubuntu.com/KernelMainlineBuilds
3. You will likely be pointed here: http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current
4. Get the current kernel (I used http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/linux-image-2.6.32-999-generic_2.6.32-999.200910141000_i386.deb)
5. Install it: sudo dpkg -i linux-image-2.6.32-999-generic_2.6.32-999.200910141000_i386.deb

Now reboot and after startup, if you run dmesg you'll probably see "Cannot find firmware file b43/ucode15.fw"
1. The message will point you to http://wireless.kernel.org/en/users/Drivers/b43#device_firmware
2. Scroll down to "You are using the b43 driver with an LP-PHY card (e.g. BCM4312)"
3. Before you follow the instructions you'll need git: sudo apt-get install git-core
4. Now become root: sudo -i
5. Paste in the two sets of instructions - they will "git clone" the fwcutter and then download and install the firmware

After that, reboot and you should be all set!

tags: removed: needs-upstream-testing
tags: removed: needs-kernel-logs
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Leslie Viljoen (leslieviljoen) wrote :

FYI: Rolling back to Ubuntu 9.04 and applying all the latest updates leaves me with kernel 2.6.28-16 and working wireless - firmware completely taken care of by jockey. Nice :-)

TraceyC (grrlgeek) wrote :

Updated the kernel to 2.6.28-16 thru Ubuntu system updater. After reboot into the new kernel, the wireless card is still not detected.

Leslie Viljoen (leslieviljoen) wrote :

Tracey: is this with Ubuntu 9.04? Does "Hardware Drivers" show anything?
I will attach lshw -C network, in case that helps.

My steps were:
1. Install Ubuntu 9.04 i386 Desktop
(even the live CD had working wireless, Hardware Drivers indicating"Broadcom STA wireless driver")
2. Apply all upgrades

I then rebooted into kernel 2.6.28-16 without any change to working wireless.

TraceyC (grrlgeek) wrote :

Leslie, did you see my apport-collect data above? The system has not changed, I'm still running 9.04.
"Hardware Drivers" shows "Broadcom STA wireless driver" being in use. I am currently booted into 2.6.28-11.
Comparing your lshw and mine, the only real difference is the bus id. I'm attaching mine in case it's helpful.

Rafał Miłecki (zajec5) wrote :

There is experimental support for BCM4312 in Ubuntu 10.04 and even should-be-stable in Ubuntu 10.10. Of couse newer versions (11.04, and later) will work as well.

For Ubuntu 9.10 and older you need to do one of:
1) install compat-wireless
2) update kernel to 2.6.33 or later
3) install sta AKA wl

Ah and if you can see your network device in lspci, it means it *IS* detected.

Can this be closed?

I am running on natty beta1. I installed the driver for Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01) using the Additional Drivers tool. the driver is installed, and the link works. However, after a minute or so connection drops. Network manager keeps retrying without any luck. If I disable wireless from network manager, and enable it back. the connection again works for about a minute. Then, the whole cycle repeats.

Is there anything I can do to fix it?

Mir Tanvir: Can you reproduce this bug in Ubuntu 12.04 LTS? Thank you for telling us.

All the others: Have you still got a laptop where your Broadcom BCM4312 is not detected?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers