atyfb regression - screen blank except for blinking cursor after fbcon vtswitch

Bug #201591 reported by Jeremy Jackson on 2008-03-12
70
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Tim Gardner
Hardy
Medium
Tim Gardner

Bug Description

In Gutsy it's working, 2.6.22 kernel. In linux-image-2.6 2.6.24-12.20 it starts up, with "modprobe fbcon; modprobe atyfb", but the first time you switch VTs with Alt-F2, all VTs are blank except for blinking cursor. The position seems to correspond with output, and it moves when you type, but there's no text.

I noticed that 3 CONFIG_FB_ options are changed from "m" in Gutsy, to "y" in Hardy:

CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_IMAGEBLIT=y

I am recompiling now with them set back to "m" and see what happens.

Hardware is ATI Technologies Inc Rage XL (rev 27), integrated on Tyan S2865 motherboard Athlon64 CPU.

Jeremy Jackson (jerj) wrote :

Testing modules compiled with the above config options "m" makes no difference. I tried compiling and insmod-ing them when booted from the precompiled kernel of exact same Ubuntu version.

I now belive this is a regression in 2.6.24 kernels.

Hi Jeremy,

This sounds a bit similar to https://bugs.edge.launchpad.net/ubuntu/+source/linux/+bug/129910 .

Per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Changed in linux:
status: New → Incomplete
Jeremy Jackson (jerj) wrote :

I read the other bug, it's not the same. In my case, Gutsy is working, Hardy kernel is not, and it's also working, *until* the first vtswitch with alt-f2.

I also tried on ia32 (first test was amd64), and also with radeonfb instead of atyfb. I also removed vga= line in lilo.conf (it was vga=extended)

Jeremy Jackson (jerj) wrote :
Jeremy Jackson (jerj) wrote :

I also have a problem that wasn't there a few weeks ago in hardy. In the vt I see nothing but the blinking cursor. It does work though, I can use it blindly, log in, kill some process or start something, but no text is showing up. For me it's also a radeon card but I'm running on iBook G4 so powerpc.

Changed in linux:
status: Incomplete → Confirmed
Jeremy Jackson (jerj) wrote :

I've tried on radeonfb, same problem. I also tried kernel.org 2.6.23.17 and 2.6.24.3, and *both worked*. It must be something special to Ubuntu kernel in recent Hardy series. I will investigate that furthur.

Chris Radek (chris-timeguy) wrote :

I narrowed this breakage down to one commit. See Bug #204319

Peter Garrett (peter-garrett) wrote :

Confirmed also using vesafb with the 386 version of 2.6.24-12.22

Matthew Garrett (mjg59) wrote :

This ought to fix it - it limits the font saving/restoring to vgacon. The FB layer does its own reference counting, which confuses things.

Chris Radek (chris-timeguy) wrote :

The fix_fb_fonts.diff patch fixes this bug for me.

Changed in linux:
assignee: nobody → ben-collins
importance: Undecided → Medium
milestone: none → ubuntu-8.04
status: Confirmed → In Progress
Nikolaus Filus (nfilus) wrote :

Thanks. The patch fixes two problems for me:
 - changing between console ttys
 - starting X with loaded radeonfb (otherwise I get a reboot or freeze)

Steve Langasek (vorlon) on 2008-03-26
Changed in linux:
milestone: ubuntu-8.04 → none
Jeremy Jackson (jerj) wrote :

the fix_fb_fonts.diff patch works for me. (AMD64 + Rage XL)

i compiled linux-source pkg from hardy, it had the same vtswitch bug, and also crashed the machine when staring X with atyfb loaded, serial console showed endless "CPU0: double fault" messages.

applying the patch and recompiling, the resulting kernel doesn't have either problem.

I noticed the target was changed from 8.04 to undefined, perhaps it could go into 8.04, it's a simple patch. Hardy is supposed to be an LTS release with a focus on reliability, so I'm wondering if the ubuntu feature that's causing this should be considered LTS worthy?

Tim Gardner (timg-tpi) wrote :
Changed in linux:
assignee: ben-collins → timg-tpi
milestone: none → ubuntu-8.04
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 2.6.24-13.23

---------------
linux (2.6.24-13.23) hardy; urgency=low

  [Alessio Igor Bogani]

  * rt: Updated configuration files

  [Ben Collins]

  * openvz: New custom flavour for OpenVZ
  * config: Disable IDE AMD driver in favor of PATA version
    - LP: #181561
  * config: Disable IDE VIA driver in favor of PATA version
    - LP: #181561
  * drivers/video: Restore gutsy backlight dimming behavior
    - LP: #205261
  * build/config: Enable CONFIG_CIFS_WEAK_PW_HASH
    - LP: #202445

  [Colin Ian King]

  * SAUCE: Add support for version 4 of Chelsio NICs in cxgb3 driver
    - LP: #201893

  [Kees Cook]

  * AppArmor: re-add missing "type" field in syslog reports.
    - LP: #202888
  * kvm: reset TSS on x86_64 to avoid ioperm bitmap corruption
    - LP: #144900

  [Stefan Bader]

  * USB: EHCI: add separate IAA watchdog timer
    - LP: #198619
  * SAUCE: Always use SCO protocol (disable eSCO support)
    - LP: #39414
  * PM: Introduce PM_EVENT_HIBERNATE callback state
    - LP: #201086

  [Tim Gardner]

  * Disable DRM suspend/resume on pre-915 Intel chips
    - LP: #207496
  * frame buffer regression - screen blank except for blinking cursor after fbcon
    vtswitch
    - LP: #201591

 -- Tim Gardner <email address hidden> Wed, 19 Mar 2008 10:05:05 -0400

Changed in linux:
status: Fix Committed → Fix Released
Taupter (taupter) wrote :

The 2.6.24-13.23 kernel seems to fix the framebuffer issue, but my Creative Audigy soundcard doesn't work with this kernel. As the following linux-restricted-drivers package was not put in the repos, closed-source NVIDIA video driver doesn't work either. Another machine here doesn't get its MCP51 High Definition Audio recognized.

I'd like to thank all people involved in fixing this bug and 129910. Seeing things being sorted out is wonderful, and I hope the final fix without regression cases will appear soon.

Saivann Carignan (oxmosys) wrote :

I confirm that this bug is fixed, thanks for your great work!

Taupter : The restricted modules will get into repositories, it's normal that sometime the kernel is updated before the restricted modules. You will get into the problems you described only if you install and use the new ubuntu kernel by yourself. Just use the old kernel until the restricted modules come in the repositories ;), thanks for your participation in launchpad.

unfortunately i think this kernel did not build correctly on all archs, for me powerpc - there's no change.

Jeremy Jackson (jerj) wrote :

not sure this belongs in this bug report, but the font switching code needs to be inside an #ifdef CONFIG_VGA_CONSOLE since vgacon.c is built conditionally on that Kconfig option

otherwise kernel build fails:

  LD .tmp_vmlinux1
drivers/built-in.o: In function `complete_change_console':
/home/jjackson/build/linux/linux-source-2.6.24/drivers/char/vt_ioctl.c:1182: undefined reference to `vga_con'
/home/jjackson/build/linux/linux-source-2.6.24/drivers/char/vt_ioctl.c:1194: undefined reference to `vga_con'
/home/jjackson/build/linux/linux-source-2.6.24/drivers/char/vt_ioctl.c:1182: undefined reference to `vga_con'
/home/jjackson/build/linux/linux-source-2.6.24/drivers/char/vt_ioctl.c:1194: undefined reference to `vga_con'
make: *** [.tmp_vmlinux1] Error 1

Taupter (taupter) wrote :

I believe both my sound cards not being recognized is not related at all to the -restricted modules, as ALSA is free and included by default in Kernel.
The released fix introduced a grave regression. It manifests with linux-2.6.24-13.23 (amd64) ,but not with 2.6.24-12.
Not being able to play sound is imo a showstopper, so please don't consider this bug closed yet.
Thanks for the ongoing effort on this yet-to-be-fixed bug. ;)

Saivann Carignan (oxmosys) wrote :

Please wait for the ubuntu-modules and restricted-modules to become available for your kernel since there is a high probability of chances that your sound card drivers are in these packages. Alsa is installed but won't magically make your sound card work without drivers, which are sometime in the ubuntu-modules and restricted-modules. If it still does not work once the packages become available, please open another bug report to help this problem getting fixed correctly. Thanks

Harri (harald-dunkel) wrote :

AFAICS the patch for problem #201591 doesn't seem to be responsible for breaking Alsa or the proprietary NVidia drivers. Would it be possible to get this fix onto the CD image, before Hardy is released?

Many thanx

Harri

On Fri, 04 Apr 2008 18:48:21 -0000
Harri <email address hidden> wrote:

> Would it be possible to
> get this fix onto the CD image, before Hardy is released?

The fix is already in the repositories, so I assume that it will be on the
final CD as well.

--
"INX Is Not X" Live CD based on Ubuntu 7.04 : http://inx.maincontent.net
Screenshots slideshow: http://inx.maincontent.net/album/1.png.html

Peter Garrett wrote:
>
> The fix is already in the repositories, so I assume that it will be on the
> final CD as well.
>

I'm not that optimistic here. The fix did not show on the daily live
CDs by now (04/03). The feature has been switched off (i.e. you get the
default 25 lines display), but if you try "vga=0x318" on the kernel
command line then you will still get just the blinking cursor.

On Sat, 05 Apr 2008 06:11:41 -0000
Harri <email address hidden> wrote:

> I'm not that optimistic here. The fix did not show on the daily live
> CDs by now (04/03). The feature has been switched off (i.e. you get the
> default 25 lines display), but if you try "vga=0x318" on the kernel
> command line then you will still get just the blinking cursor.

Here I have the 2.6.24-15 kernel, which was included in a recent update,
and it appears to be working fine with vga=791. The console switching
works, and the framebuffer seems to be as expected. Do you have
linux-generic and/or linux-image-generic installed? You need the modules
as well as the kernel itself, and those metapackages will pull in what is
needed.

For example:
http://packages.ubuntu.com/hardy/linux-image-2.6.24-15-generic
http://packages.ubuntu.com/hardy/linux-ubuntu-modules-2.6.24-15-generic

On Sat, 05 Apr 2008 11:06:35 -0000
Harri <email address hidden> wrote:

> I just tried the live cd. AFAICS it is 2.6.24-12-generic.

I think you may be missing my point. I'll try again:

If the newer kernel is in the repositories, then, barring regressions and
bugs, it is likely to be there in the final release, with the necessary
modules etc.

--
"INX Is Not X" Live CD based on Ubuntu 7.04 : http://inx.maincontent.net
Screenshots slideshow: http://inx.maincontent.net/album/1.png.html

Michael (miiichael) wrote :

This bug might be related to #200113 and #129910.

deathtech (jameshall937) wrote :

This is happening on the newest kernel 2.6.27 , in Intrepid, using the latest nvidia drivers . This is the same for my Hardy install running the same kernel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers