Poor quality sound on Aluminium iMac

Bug #199047 reported by David Chart on 2008-03-06
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Wishlist
Unassigned

Bug Description

With the fix described in bug 147087, sound works on an Aluminium iMac, but the sound quality is poor, rather like an old, mono radio. This is in 7.10; sound does not work at all on the live CDs of Hardy Heron Alpha (see bug 199044). All the hardware details are available in bug 147087.

Ian Weisser (ian-weisser) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the information requested from the "Reporting Sound Bugs" section of https://wiki.ubuntu.com/DebuggingSoundProblems as separate attachments.

Changed in linux:
status: New → Incomplete
David Chart (ubuntu-davidchart) wrote :

See bug 147087, noted above as having all the hardware details in.

Changed in linux:
status: Incomplete → New
Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 or 9.04?

Changed in linux:
importance: Undecided → Wishlist
status: New → Incomplete
David Chart (ubuntu-davidchart) wrote :

Yes, in 8.10. (I've not done anything with 9.04 yet.) The sound is better than it was in 7.10, but still noticeably low quality.

Hi David,

Care to give the latest pre-release of Jaunty a test and see if the sound quality if any better - http://cdimage.ubuntu.com/releases/jaunty/alpha-2/ . You should be able to test via a LiveCD. Please let us know your results. Thanks.

David Chart (ubuntu-davidchart) wrote :

Sound still appears to be completely non-functional when starting from a Live CD. (This is not, to the best of my knowledge, a regression; I don't think it has ever worked.) I don't have time to make a full install to test just at the moment, I'm afraid.

Hi David, could you please download and run http://alsa-project.org/alsa-info.sh with the --no-upload option:

./alsa-info.sh --no-upload

Then attach the resulting alsa-info.txt file to this bug report. Thanks.

David Chart (ubuntu-davidchart) wrote :

Here's the output file. Note that I'm still running this on Intrepid.

Changed in linux:
status: Incomplete → Triaged
Russ Brown (macmanui) wrote :

I also have this problem, and it is still an issue in the Alpha-5 release of Jaunty.

Jeremy Foshee (jeremyfoshee) wrote :

This bug report was marked as Triaged a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Triaged → Incomplete

The problem persists in 9.10. As before, I think there are marginal improvements in the sound, but it is still poor.

Changed in linux (Ubuntu):
status: Incomplete → New
Jeremy Foshee (jeremyfoshee) wrote :

Hi David,
      Would you be willing to test against the latest daily live image of Lucid?

Thanks!

~JFo

Changed in linux (Ubuntu):
status: New → Incomplete

I'll test it, but sound has previously not worked at all on the live CDs. If you could tell me where to get the live image, that would save me time.

Thanks.

Jeremy Foshee (jeremyfoshee) wrote :

David,
    You can find it here: http://cdimage.ubuntu.com/daily-live/current/

Thanks!

~JFo

OK, tried it. (Is that the new theme? I like it.) I'm afraid that, as before, sound appears to be completely nonfunctional on the live CD.

nnutter (nnutter) wrote :

I was able to get the sound to function by adding 'options snd-hda-intel model=mbp3' to /etc/modprobe.d/alsa-base but it still sounded like garbage. I don't know if it is mono or stereo but it definitely is lacking any bass. I know in past experiences and prior to PulseAudio being so integrated there used to be a component muted on MacBooks that when unmuted would provide the bass. Using alsamixer I was not able to achieve a similar result.

It really bothers me that things like this are still not working and I don't know if it is because it's Apple or because of Linux. I would love to switch to Linux for reasons of principle but I will not give up multimedia to do so. I wish I could help fix problems like this and I wish I could entice someone who knows how to fix this kind of thing. I have been trying Ubuntu every release hoping that one day my hardware would just work. I'll stop now because this isn't relevant to the bug report.

Christian Kujau (christiank) wrote :

If the bug is still about "poor sound quality" (and not about "sound not working at all", that's a different issue):

I managed to get sound working with "options snd-hda-intel model=imac24" (for this iMac8,1) but it's lacking any bass. Switching through the different hardware-profiles ("gnome-volume-control") did not do any good. FWIW, I've uploaded my ALSA information:
http://www.alsa-project.org/db/?f=cd54f33bc07a2b573e3ab1cdcbe4946653bc93ad

I'm running Lucid (just upgraded to 2.6.32-19-generic); running vanilla 2.6.34-rc3 with the Ubuntu .config applied did not help.

Has this one been forwarded upstream (ALSA? snd-hda-intel maintainer?) already?

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Christian Kujau (christiank) wrote :

Btw, why is this tagged "wishlist"? It's clearly a serious bug - it's like having no sound at all. It's "sound coming out of the speaker" but it's not really usable. So, no multimedia for all the iMac users out there :-\

Just to confirm that the problem still exists with a full install of 10.4 LTS. There's been no progress in the last two years, as far as I can tell.

Xhacker Liu (xhacker) wrote :

I'm affected by this bug too. My sound is garbage, both 10.04 and 10.10 daily.

Please raise the importance, it is a serious bug!

Xhacker Liu (xhacker) wrote :

Still exist in Maverick beta, please fix it, thanks.
There is no any progress in such a long time.

Nowawnelr8xdaqcmbqjys mabyxfapny he2jaa2vmnhlth orgaju2elnibj45zasq084g8ti0ielvons waxxkmelnarn pea74ople4cv9 thaiy59c6t ordep7r meg0cdij4tnmaelcaelnjt769oti9zniel6fons to bey6kg1 cas4j51ufreayuhjful whi9opleh6b33 choosiupng onlim4f9nevyi32mk drugstorem9z78mw8s. Carelelel5kmona2j3991rfdiodvz02ryak0un �Cadwnaguivfvelydigutf5wajxelb9pnPhadzqy6rmad73vcy� drugstorefx41khq offenthrs thezmz1xgixor custome8jadvrs ivyntexvrna144zelqarti1wafelonaxyumktlly cesvau1g7rtim31gsfi5ne6b9d qua13hdaxs9lir6ty gei4rnetv71ri77k03wc menixwbdieltud3cas043bcrtisxdzelons produceggu4s5bd from thewdg50 be16oast rax4w majj4syztebvrio7qnykaiat3rr5ls.

 aar5mel8ll thes43 meq6mvo0gdinrfcpv9zcac3s9n3jxtik04ga6ons az1yvjreelnnmna 100% gew213g5nesaw9y8riqtc, provi0mde6mf4c6xd by thepsur world lexdjaelcaomw1fu4di75zhng ma8rv85xnufav3ujp2fctureru8d8jrs.

 Thak2nks for purcha43zrfrjsicnd0dj2ung wiq41svth �Ca2elt311na1atidipqghhv2hafsnPhajszprmrmah3omgjkscy�!
-------
    Viaawg0gra
 Our prrdtdelaiice$1.85

 Viawelmfgra Super Actzc740hd0ive+
 Our prtud538mice$2.79

 Lev6nc1itra Profesg83ndsional
 Our pry4ice$4.97

 Ciad9tv2htlis
 Our prelrgj8ice$1.95

 Levh7og8witra
 Our prmhelgxdnice$2.50

 Viau1xc9pygra + Ciag3lis + Levj1j1rnitra
 Our pryrdice$119.98 Ciac33mg95lis Super Acivtive+
 Our prs3mice$3.65

 Female Vian5c2gra
 Our prjicwice$1.35

 Via8r1gra Profe9kissional
 Our prvf9ice$1.57

 Via9elfcs4kgra Sofkibbot Ta5dxab8bs
 Our prpypkice$1.64

 Levod6ygh2vitra Super Act51k9rqj3ive+
 Our pr3pap6gice$2.78

 Ciad84i1ms6lis Profe30qmqwssional
 Our praudf05ice$4.17

David Chart, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? Can you try with the latest development release of Ubuntu? ISO CD images are available from http://cdimage.ubuntu.com/releases/ .

If it remains an issue, could you run the following command in the development release from a Terminal (Applications->Accessories->Terminal). It will automatically gather and attach updated debug information to this report.

apport-collect -p linux <replace-with-bug-number>

Also, if you could test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please do not test the kernel in the daily folder, but the one all the way at the bottom. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. As well, please comment on which kernel version specifically you tested.

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

If you are unable to test the mainline kernel, for example it will not boot, please add the tag: 'kernel-unable-to-test-upstream', and comment as to why specifically you were unable to test it.

Please let us know your results. Thanks in advance.

tags: added: needs-upstream-testing
tags: added: kernel-sound
Changed in linux (Ubuntu):
status: Confirmed → Incomplete

It is basically fixed now, in my experience. I think it was fixed in one of last year's releases.

Sorry, it was so long after the bug had been filed that I had forgotten.

David Chart, this bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers