flickering and black screen from boot time, no more display after 22.04 upgrade

Bug #1973676 reported by David Bellot
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

On an HP x360 Spectre (i7-8565U WhiskeyLake-U GT2 [UHD Graphics 620]), after upgrading to 22.04 from 21.10, the display goes to some flickering lines in black and grey or colors (remember the artifacts on Amstrad CPC or C64 when loading from a tape? Same here...).

After the initial grub menu, the kernel loads and boots. There are a few lines of log when the screen is in text mode. As soon as the plymouth screen comes in, the screen starts flickering massively. Nothing appeared on the screen except horizontal lines. I have an encrypted partition, so I type in the password and then the screen goes to flickering lines in color when Wayland starts.

I tried different kernels:
- 5.17.8: failed
- 5.15.x: all failed (from Ubuntu 22.04)
- 5.13.19: works and back to normal

I found the following errors in the logs:
* i915 0000:00:02.0: [drm] *ERROR* Atomic update failure on pipe A (start=43426 end=43427) time 300 us, min 2146, max 2159, scanline start 2131, end 2171
* i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
* i915 0000:00:02.0: [drm] [ENCODER:102:DDI B/PHY B] is disabled/in DSI mode with an ungated DDI clock, gate it
* i915 0000:00:02.0: [drm] [ENCODER:113:DDI C/PHY C] is disabled/in DSI mode with an ungated DDI clock, gate it
* i915 0000:00:02.0: [drm] *ERROR* CPU pipe A FIFO underrun

So the problem is > 5.13.x series

I temporarily solved it by downgrading to 5.13.19 from ubuntu mainline on a newly updated ubuntu 22.04! But it seems the bug affects all the kernels.

It might be related to https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1958191

Info:
Description: Ubuntu 22.04 LTS
Release: 22.04

linux-image-5.15.0-30-generic:
  Installed: 5.15.0-30.31
  Candidate: 5.15.0-30.31
  Version table:
 *** 5.15.0-30.31 500
        500 http://au.archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages
        100 /var/lib/dpkg/status

Revision history for this message
David Bellot (david-bellot) wrote :
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1973676

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Please try adding this kernel parameter: i915.enable_psr=0

tags: added: jammy
tags: added: flicker i915
tags: added: regression-release
Revision history for this message
David Bellot (david-bellot) wrote :

It works with the kernel 5.15.0-30-generic now.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Nicholas Stolley (nstolley) wrote :

This is the exact issue I've been having on my Dell XPS 15 9575 with Intel HD Graphics 630 with an encrypted partition. I have had the issue since upgrading to Ubuntu 22.04 from 21.10. This issue has been present on every 5.15 kernel since I installed 22.10. My workaround up to this point has been to boot into 5.13.0-41-generic.

Adding "i915.enable_dc=0 intel_idle.max_cstate=2" from [1] did not work for me.

Adding "i915.enable_psr=0" from [2] did not work for me.

What finally worked was uncommenting "GRUB_GFXMODE=" and adding "1920x1440" from [3].

[1] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1958191
[2] https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1970426
[3] https://askubuntu.com/questions/1405737/screen-flickers-on-boot-up-on-dell-xps-15-with-ubuntu-22-04

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

This bug is closed. Please open a new bug of your own by running:

  ubuntu-bug linux

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments