Ubuntu

getting "ACPI Invalid PBLK Length 5" - message on Hardy Alpha 5

Reported by wpshooter on 2008-03-01
38
This bug affects 3 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Colin King

Bug Description

I am getting an error message on the Hardy Alpha 5 Alternate CD version 32 bit.

The error message is: ACPI Invalid PBLK length 5

This message occurs both during the integrity check function of the CD and also during the very initial stages of the actual installation process of installing from the CD to the hard drive.

Let me know if you need any further information.

Thanks.

Dereck Wonnacott (dereck) wrote :

A quick Google of this obscure error message leads me to believe that you are not that first to be confused by it and it should really be worded into something that makes sense to normal people like you and me at least.

Alessio Igor Bogani (abogani) wrote :

Hi wpshooter,

Do you already checked if exist a BIOS upgrade for your computer?

Thank you!

Colin King (colin-king) wrote :

I suggest looking at https://wiki.ubuntu.com/DebuggingACPI, starting with:

Try booting with the "acpi=off" kernel parameter

    * This will disable ACPI support. If the error is the same with acpi enabled and disabled, this may not be an ACPI issue.

Changed in linux:
status: New → Incomplete
wpshooter (joverstreet1) wrote :

Alessio:

This is an ASUS P4G8x deluxe motherboard. The BIOS is already at the latest version. Board is no longer supported, so there will be no more BIOS updates.

If this is a problem related to ACPI, why would I get this very same message when running the CD integrity check from the Ubuntu initial boot menu ?? Is the running of that integrity check dependent on ACPI settings, etc. ?

Thanks.

wpshooter (joverstreet1) wrote :

P. S. - I don't get this message when using the Gutsy version on this same computer.

Therefore, that sort of leads me to believe that the problem is with Hardy, not the computer.

Thanks.

wpshooter (joverstreet1) wrote :

I am still getting the "ACPI Invald PBLK Length 5" message on the Hardy BETA version Alternate CD.

I only get this message on a computer that I built that is using an ASUS P4G8X motherboard.

I have tried the same CD on 2 other computers that I built using other ASUS model motherboards and also on some older IBM Netvista computers that I have and I do NOT get the message on any of those computers.

What needs to be fixed in the Hardy O/S so that this message is not displayed on the ASUS P4G8X computer ? Like I said in a previous posting, I don't think there is anything wrong with this computer because I do NOT get this message when using the Gutsy version of Ubuntu.

Thanks.

Changed in linux:
importance: Undecided → Medium
status: Incomplete → Triaged

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

wpshooter (joverstreet1) wrote :

I downloaded Intrepid Alpha 5 ALTERNATE CD version and I still get this same message both when I run the CD integrity check function from the Ubuntu initial boot menu screen and also when I go into the INSTALL menu option.

Thanks.

robocoder (apang) wrote :

Google search suggests that it's predominantly users with Asus motherboards/systems who see this message. (But not all Asus motherboards/systems are problematic.) I'm seeing this error with an older Asus A7A266 running Intrepid (2.6.27-9).

wpshooter (joverstreet1) wrote :

I recently installed the release version of Intrepid on the P4G8X ASUS motherboard computer and I still get the same error message.

If I can run Gutsy on this motherboard without getting this message, then the integrity of Hardy and Intrepid is very doubtful in my mind. This leads me to think that someone is changing things in this O/S without taking into account ALL of the consequences.

Thanks.

mangwills (mangwills) wrote :

I also get this error sometimes when booting up Acer 4530 laptop running Ubuntu Intrepid AMD64. It doesn't always occur, though. I haven't tried putting acpi=off because it doesn't occur often.

Moneta Funzionata (djmonkey1) wrote :

I am seeing this error at boot with Ubuntu 9.04.

Amroth (oscar-th) wrote :

I get the same error on my Kubuntu 9.04 with ASUS P4S8X-X in a clean install.

Moneta Funzionata (djmonkey1) wrote :

I am seeing this error at boot with Ubuntu 9.04. I have followed the instructions at https://wiki.ubuntu.com/DebuggingACPI with the following results:

acpi=off results in different errors appearing at boot as well as no response from my ethernet controller.
acpi=ht same as above
pci=noacpi results in above as well as seeing the error "Invalid PBLK length [5]"
acpi=noirq same as above
pnpacpi=off results in just the Invalid PBLK length error (ethernet works fine)
noapic same as above
nolapic same as above

My motherboard: ASUS P4S800 ACPI BIOS Revision 1011beta

wpshooter (joverstreet1) wrote :

I just noticed that my original report of this bug was over a year ago now (in March 2008).

And this still has not been fixed ???

pretmet (pretmet) wrote :

Hi,
I'm a Ubuntu newbie. I noticed this error for the first time. Last week I moved to 9.04 on my old Asus laptop. So indeed it has not been fixed.
Don't know if it hurts, don't know if there is really something wrong (I don't see a problem...)

Joe Caputo (jcaputo1) wrote :

I'm seeing this problem as well ("Invalid PBLK length [5]").

Stats:

Mobo: Asus A7A266
Ubuntu 9.04
kernel 2.6.28-13

Recently (possibly after last kernel package update?) started getting random kernel panics. I suppose it could be aging hardware... and I never really noticed whether I was getting this error message before, since I only reboot this box for distro & kernel upgrades :-)

Fodox (fodox) wrote :

Same problem, followed by:

[3.445580] IO APIC resources could bet not allocated

I can login to desktop, but after few seconds the monitor became black and then the system return in the graphic login prompt, again, infinitely.

System: Pentium 3 1Ghz, 512Mb RAM, M.B. Asus CUSL2-C with latest BIOS, hard disk 200Gb, DVD drive.
I tried a clean installation with Ubuntu 9.04 from original CD desktop version. I made a manual partitioning to prevent Grub error 18:
sda1 1gb ext3 mounted with /boot
sda5 rest_of_space ext3 mounted with /

Colin King (colin-king) wrote :

Can you supply me a copy of the ACPI dsdt from your machine. To do so, please do the following:

sudo cat /proc/acpi/dsdt > dsdt.dat

and attach this binary file to the bug report. I will disassemble it and see why the BIOS is making ACPI complain about the PBLK. Thanks!

Changed in linux (Ubuntu):
status: Triaged → Incomplete
assignee: Ubuntu Kernel ACPI Team (ubuntu-kernel-acpi) → Colin King (colin-king)
Anton Kraus (done) wrote :

I'm also seeing this Invalid PBLK Length error on an ASUS board, a P4PE to be exact.

I have attached my dsdt.dat.

chico (chico1602) wrote :

Hello Colin

Here is the file you requested sent correctly.

Thank you once again for all the help and time your putting into to this problem I'm having.

Regards,

chico

Colin King (colin-king) wrote :

@chico,

I require just a little more information now, can you please run the following command:

sudo acpidump > acpi.dat

and attach the acpi.dat to the bug report. Thanks!

chico (chico1602) wrote :
Colin King (colin-king) wrote :

The warning is because of a problem with the Processor declaration in the _PR root namespace of your ACPI DSDT:

    Scope (\_PR)
    {
        Processor (\_PR.CPU0, 0x00, 0x0000E410, 0x05) {}
        Processor (\_PR.CPU1, 0x01, 0x00000000, 0x00) {}
    }

The syntax of the Processor declaration is as follows:

Processor (ProcessorName, ProcessorID, PBlockAddress, PblockLength)

Section 18.5.93 of the ACPI specification states that the PBlockLength is the length of the processor register block, in bytes and is either 0 (for no P_BLK) or 6. In your case, the it's been set to 0x05 in the first Processor declaration which is definetly not compliant with the specification, hence the kernel warning message. The ACPI specification can be downloaded from http://www.acpi.info/DOWNLOADS/ACPIspec40.pdf if your are interested in the details.

As it is, this is not a kernel bug, but a warning from the kernel that your BIOS is buggy and needs fixing. I suggest informing the manufacturer so that they can fix the BIOS.

I shall therefore mark this as "Won't Fix".

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
wpshooter (joverstreet1) wrote :

Since most of the motherboards that are exhibiting this error/warning message are fairly old and it is HIGHLY unlikely that the M/B manufacturer is going to fix this BIOS problem, is there any actual negative consequences to installing and running Ubuntu on a computer that is using one of these motherboards ?

Thanks.

Colin King (colin-king) wrote :

@wpshooter, from my understanding, if the kernel detects a problem with the PBLK length then it will not configure up the ACPI CPU throttling. So, basically, you lose the ability to do CPU throttling. Since this is under ACPI control and the BIOS has been found to contain errors in this configuration, the kernel chooses to disable this functionality rather than risk using incorrect configuration, which seems to me like the least risky option for the kernel to make.

hh (hh-iliessa) wrote :

I think the user has to change their display card to agp from pci in the bios, and then install again the system. I think. I got that error too, but I dont get errors from other dists incl ubuntu and knoppix, i.e. mythbuntu and LinHES.
I am not sure where I stand here in this regard, and this is a year on from the last comment.
Install of MythDora, 12.23 mythtv

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers