No Bluetooth Found on QCA9565 (but replacing the ar3k firmware works)

Bug #1969853 reported by Diego Aparecido de Souza Pereira
84
This bug affects 11 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Invalid
Undecided
Unassigned
Jammy
Confirmed
Undecided
Unassigned
linux-firmware (Ubuntu)
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Juerg Haefliger

Bug Description

[Impact]

No bluetooth found on QCA9565.

[Test Case]

See below.

[Fix]

Provide ar3k/* firmware blobs.

[Where Problems Could Occur]

None expected, this is a regression from Impish.

[Original Description]

After updating to version 22.04, with kernel 5.15.0-25, Bluettoth stopped working via menu. Before I used versions 20.04 and 21.10, the latter with kernel 5.13, and Bluetooth was recognized normally. The bluetooth status in the terminal is this:

diego@diego-Inspiron:~$ sudo systemctl status bluetooth.service
● bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
     Active: active (running) since Thu 2022-04-21 18:16:17 -03; 16min ago
       Docs: man:bluetoothd(8)
   Main PID: 1100 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 18808)
     Memory: 1.8M
        CPU: 66ms
     CGroup: /system.slice/bluetooth.service
             └─1100 /usr/lib/bluetooth/bluetoothd

abr 21 18:16:16 diego-Inspiron systemd[1]: Starting Bluetooth service...
abr 21 18:16:17 diego-Inspiron bluetoothd[1100]: Bluetooth daemon 5.64
abr 21 18:16:17 diego-Inspiron systemd[1]: Started Bluetooth service.
abr 21 18:16:17 diego-Inspiron bluetoothd[1100]: Starting SDP server
abr 21 18:16:17 diego-Inspiron bluetoothd[1100]: Bluetooth management interface 1.21 initialized
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu82
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: diego 2220 F.... pulseaudio
 /dev/snd/pcmC0D0p: diego 2220 F...m pulseaudio
CRDA: N/A
CasperMD5CheckResult: pass
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 22.04
InstallationDate: Installed on 2022-04-23 (2 days ago)
InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - Release amd64 (20220419)
MachineType: Dell Inc. Inspiron 15-3567
Package: linux (not installed)
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.15.0-27-generic root=UUID=bf1a2827-c8db-4042-aa45-5db6ad9d1449 ro quiet splash
ProcVersionSignature: Ubuntu 5.15.0-27.28-generic 5.15.30
RelatedPackageVersions:
 linux-restricted-modules-5.15.0-27-generic N/A
 linux-backports-modules-5.15.0-27-generic N/A
 linux-firmware 20220329.git681281e4-0ubuntu1
Tags: wayland-session jammy
Uname: Linux 5.15.0-27-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/15/2021
dmi.bios.release: 2.18
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.18.0
dmi.board.name: 0MM5K1
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.18.0:bd12/15/2021:br2.18:svnDellInc.:pnInspiron15-3567:pvr:rvnDellInc.:rn0MM5K1:rvrA00:cvnDellInc.:ct9:cvr:sku078B:
dmi.product.family: Inspiron
dmi.product.name: Inspiron 15-3567
dmi.product.sku: 078B
dmi.sys.vendor: Dell Inc.

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote :
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Libera.chat.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1969853/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → bluez (Ubuntu)
Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: No Bluetooth Found

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1969853

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

affects: bluez (Ubuntu) → linux (Ubuntu)
summary: - Bluetooth doesn't work but seems active
+ No Bluetooth Found
tags: added: jammy
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : AlsaInfo.txt

apport information

tags: added: apport-collected wayland-session
description: updated
Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : CurrentDmesg.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : IwConfig.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : Lspci.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : Lspci-vt.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : Lsusb.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : Lsusb-t.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : Lsusb-v.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : PaInfo.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : ProcCpuinfo.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : ProcEnviron.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : ProcInterrupts.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : ProcModules.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : PulseList.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : RfKill.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : UdevDb.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : WifiSyslog.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : acpidump.txt

apport information

Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote : Re: No Bluetooth Found

Hi! I'll add some information that might help. As using bluetooth was very important to me (and I had this same problem on 3 different installs of that Ubuntu version), I searched forums and found a solution. Basically I manually downloaded the linux firmware and copied the ar3k folder to /lib/firmware. I followed the following steps from the forum below.

- Download linux-firmware_1.201.tar.xz at [http://archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.201.tar.xz](http://archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.201.tar.xz) (you can visit [https://packages.ubuntu.com/impish/linux-firmware](https://packages.ubuntu.com/impish/linux-firmware) for more details)
- Extract linux-firmware_1.201.tar.xz, copy folder ar3k into /lib/firmware
- Restart your computer

https://askubuntu.com/questions/1403934/patch-file-not-found-ar3k-athrbt-0x31010000-dfu

summary: - No Bluetooth Found
+ No Bluetooth Found on QCA9565 (but replacing the ar3k works)
Changed in linux (Ubuntu):
status: Incomplete → New
summary: - No Bluetooth Found on QCA9565 (but replacing the ar3k works)
+ No Bluetooth Found on QCA9565 (but replacing the ar3k firmware works)
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Juerg Haefliger (juergh)
Changed in linux-firmware (Ubuntu):
status: New → In Progress
assignee: nobody → Juerg Haefliger (juergh)
description: updated
Revision history for this message
Juerg Haefliger (juergh) wrote :

Note to self, the kernel should reference ar3k/* firmware blobs.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
no longer affects: linux (Ubuntu Jammy)
no longer affects: linux-firmware (Ubuntu Jammy)
Changed in linux (Ubuntu):
status: Invalid → New
Changed in linux-firmware (Ubuntu Jammy):
status: New → In Progress
Changed in linux-firmware (Ubuntu):
status: In Progress → Invalid
Changed in linux (Ubuntu):
status: New → Invalid
Changed in linux-firmware (Ubuntu Jammy):
assignee: nobody → Juerg Haefliger (juergh)
Changed in linux-firmware (Ubuntu):
assignee: Juerg Haefliger (juergh) → nobody
Juerg Haefliger (juergh)
tags: added: kern-3128
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Jammy):
status: New → Confirmed
Juerg Haefliger (juergh)
Changed in linux-firmware (Ubuntu Jammy):
status: In Progress → Fix Committed
Revision history for this message
Timo Aaltonen (tjaalton) wrote : Please test proposed package

Hello Diego, or anyone else affected,

Accepted linux-firmware into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/linux-firmware/20220329.git681281e4-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-jammy to verification-done-jammy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-jammy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Anderson Luiz Alves (alacn1) wrote :

Bluetooth worked with linux-firmware 20220329.git681281e4-0ubuntu3.

tags: added: verification-done-jammy
Revision history for this message
Diego Aparecido de Souza Pereira (dieggpereira) wrote :

Bluetooth working well with `linux-firmware/jammy-proposed,now 20220329.git681281e4-0ubuntu3 all [installed]`. Thank you so much!

Revision history for this message
Dan Wood (dan-wood) wrote :

Thank you. The proposed firmware linux-firmware 20220329.git681281e4-0ubuntu3 has fixed Bluetooth (and also WiFi) on my Dell XPS 13 L322X machine.

I haven't noticed any new problems, so I think the proposed fix is good to go.

Revision history for this message
Joseph Markham (markhamjoseph) wrote :

Followed what dieggpereira did and installed linux-firmware_1.201.tar.xz, copied folder ar3k into /lib/firmware

bluetooth found and seems to work

wifi still does not work ( 02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01) ) on Dell Inspiron 3521

Revision history for this message
Amir (amirzolal) wrote : Re: [Bug 1969853] Re: No Bluetooth Found on QCA9565 (but replacing the ar3k firmware works)
Download full text (4.3 KiB)

Enable the proposed repository, for me, on an old G580, both bluetooth AND
wifi work again on the -28 kernel.

Am Fr., 6. Mai 2022 um 18:15 Uhr schrieb Joseph Markham <
<email address hidden>>:

> Followed what dieggpereira did and installed linux-
> firmware_1.201.tar.xz, copied folder ar3k into /lib/firmware
>
> bluetooth found and seems to work
>
> wifi still does not work ( 02:00.0 Network controller: Qualcomm Atheros
> QCA9565 / AR9565 Wireless Network Adapter (rev 01) ) on Dell Inspiron
> 3521
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1970456).
> https://bugs.launchpad.net/bugs/1969853
>
> Title:
> No Bluetooth Found on QCA9565 (but replacing the ar3k firmware works)
>
> Status in linux package in Ubuntu:
> Invalid
> Status in linux-firmware package in Ubuntu:
> Invalid
> Status in linux source package in Jammy:
> Confirmed
> Status in linux-firmware source package in Jammy:
> Fix Committed
>
> Bug description:
> [Impact]
>
> No bluetooth found on QCA9565.
>
> [Test Case]
>
> See below.
>
> [Fix]
>
> Provide ar3k/* firmware blobs.
>
> [Where Problems Could Occur]
>
> None expected, this is a regression from Impish.
>
> [Original Description]
>
> After updating to version 22.04, with kernel 5.15.0-25, Bluettoth
> stopped working via menu. Before I used versions 20.04 and 21.10, the
> latter with kernel 5.13, and Bluetooth was recognized normally. The
> bluetooth status in the terminal is this:
>
> diego@diego-Inspiron:~$ sudo systemctl status bluetooth.service
> ● bluetooth.service - Bluetooth service
> Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled;
> vendor preset: enabled)
> Active: active (running) since Thu 2022-04-21 18:16:17 -03; 16min
> ago
> Docs: man:bluetoothd(8)
> Main PID: 1100 (bluetoothd)
> Status: "Running"
> Tasks: 1 (limit: 18808)
> Memory: 1.8M
> CPU: 66ms
> CGroup: /system.slice/bluetooth.service
> └─1100 /usr/lib/bluetooth/bluetoothd
>
> abr 21 18:16:16 diego-Inspiron systemd[1]: Starting Bluetooth service...
> abr 21 18:16:17 diego-Inspiron bluetoothd[1100]: Bluetooth daemon 5.64
> abr 21 18:16:17 diego-Inspiron systemd[1]: Started Bluetooth service.
> abr 21 18:16:17 diego-Inspiron bluetoothd[1100]: Starting SDP server
> abr 21 18:16:17 diego-Inspiron bluetoothd[1100]: Bluetooth management
> interface 1.21 initialized
> ---
> ProblemType: Bug
> ApportVersion: 2.20.11-0ubuntu82
> Architecture: amd64
> AudioDevicesInUse:
> USER PID ACCESS COMMAND
> /dev/snd/controlC0: diego 2220 F.... pulseaudio
> /dev/snd/pcmC0D0p: diego 2220 F...m pulseaudio
> CRDA: N/A
> CasperMD5CheckResult: pass
> CurrentDesktop: ubuntu:GNOME
> DistroRelease: Ubuntu 22.04
> InstallationDate: Installed on 2022-04-23 (2 days ago)
> InstallationMedia: Ubuntu 22.04 LTS "Jammy Jellyfish" - Release amd64
> (20220419)
> MachineType: Dell Inc. Inspiron 15-3567
> Package: linux (not installed)
> ProcFB: 0 i915drmfb
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.15.0-27-generic
> root=UUID=...

Read more...

Revision history for this message
SoundVM (soundvm) wrote :

Thank you, the proposed firmware has fixed Bluetooth on my Dell XPS 8700 machine powered by Qualcomm Atheros AR9485 Wireless Network Adapter - ID 0cf3:e004 (WiFi works ever fine).

I should notice, I had to recompile the kernel modules (btusb.ko and ath3k.ko) to gain bluetooth stability (before, BT unhooking every 30 seconds... now steady connection).

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for linux-firmware has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 20220329.git681281e4-0ubuntu3

---------------
linux-firmware (20220329.git681281e4-0ubuntu3) jammy; urgency=medium

  * Miscellaneous Ubuntu changes
    - [Packaging] Drop rsync from Build-Depends
    - [Packaging] Move obsolete scripts
    - [Packaging] Put symlink checking into its own script
  * Add missing inside-secure firmware (LP: #1970543)
    - [Packaging] Include inside-secure firmware
  * The system hangs when HDMI external monitor involved on AMD Yellow Carp platforms (LP: #1970293)
    - amdgpu: update yellow carp DMCUB firmware
  * No Bluetooth Found on QCA9565 (but replacing the ar3k firmware works) (LP: #1969853)
    - [Packaging] Include ar3k firmware

 -- Juerg Haefliger <email address hidden> Fri, 29 Apr 2022 07:30:37 +0200

Changed in linux-firmware (Ubuntu Jammy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-firmware - 20220429.gitac21ab5d-0ubuntu1

---------------
linux-firmware (20220429.gitac21ab5d-0ubuntu1) kinetic; urgency=medium

  * Miscellaneous Ubuntu changes
    - [Packaging] Drop rsync from Build-Depends
    - [Packaging] Move obsolete scripts
    - [Packaging] Put symlink checking into its own script
    - Rebase to upstream commit ac21ab5d1de0de34201c90d32eee436f873d1e5b
      Rebase against git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
      - ice: update ice DDP comms package to 1.3.31.0
      - ice: Add wireless edge file for Intel E800 series driver
      - rtw88: 8821c: Update normal firmware to v24.11.00
      - i915: Add GuC v70.1.1 for all platforms
      - linux-firmware: update firmware for mediatek bluetooth chip (MT7921)
      - linux-firmware: update firmware for MT7921 WiFi device
      - amdgpu: update navi10 VCN firmware
      - amdgpu: update navi12 VCN firmware
      - amdgpu: update navi14 VCN firmware
      - amdgpu: update renoir VCN firmware
      - amdgpu: update green sardine VCN firmware
      - linux-firmware: Update firmware file for Intel Bluetooth 9260
      - linux-firmware: Update firmware file for Intel Bluetooth 9560
      - linux-firmware: Update firmware file for Intel Bluetooth AX201
      - linux-firmware: Update firmware file for Intel Bluetooth AX200
      - linux-firmware: Update firmware file for Intel Bluetooth AX210
      - linux-firmware: Update firmware file for Intel Bluetooth AX211
      - linux-firmware: Update firmware file for Intel Bluetooth AX211
      - linux-firmware: Update firmware file for Intel Bluetooth AX201
      - linux-firmware: Update firmware file for Intel Bluetooth AX201
      - linux-firmware: Update firmware file for Intel Bluetooth 9560
      - linux-firmware: Update firmware file for Intel Bluetooth 9560
      - linux-firmware: Update firmware file for Intel Bluetooth 9462
      - linux-firmware: Update firmware file for Intel Bluetooth 9462
      - brcm: rename Rock960 NVRAM to AP6356S and link devices to it
      - nvidia: add GA102/GA103/GA104/GA106/GA107 signed firmware
      - linux-firmware: Update AMD cpu microcode
      - mediatek: Add mt8192 SCP firmware
      - rtl_bt: Add firmware and config files for RTL8852C
      - qcom: apq8096: add aDSP firmware
      - qcom: apq8096: add modem firmware
      - mediatek: Add mt8195 SCP firmware
      - linux-firmware: update firmware for MT7922 WiFi device
      - linux-firmware: update firmware for mediatek bluetooth chip (MT7922)
      - amdgpu: update yellow carp DMCUB firmware
      - Mellanox: Add new mlxsw_spectrum firmware xx.2010.1502
      - Mellanox: xx.2010.1502: Distribute non-xz-compressed lc_ini_bundle
      - Mellanox: Add lc_ini_bundle for xx.2010.1006
  * Add missing inside-secure firmware (LP: #1970543)
    - [Packaging] Include inside-secure firmware
  * No Bluetooth Found on QCA9565 (but replacing the ar3k firmware works) (LP: #1969853)
    - [Packaging] Include ar3k firmware

 -- Juerg Haefliger <email address hidden> Fri, 29 Apr 2022 08:06:54 +0200

Changed in linux-firmware (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers