crash on start in xen 3.2

Bug #196571 reported by Pavel Mlčoch on 2008-02-28
26
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Declined for Intrepid by Steve Langasek

Bug Description

When Ill try run system on xen, ive a lot of errors.

Pavel Mlčoch (pavkamlc) wrote :
Pavel Mlčoch (pavkamlc) wrote :
Pavel Mlčoch (pavkamlc) wrote :
Pavel Mlčoch (pavkamlc) wrote :

Hi Pavel,

Care to post a comment with the specific kernel version you are running? Also, from the digital photo you attached it looks like it might be a kernel Oops that is being triggered. Would it be possible for you to capture the top part of the error message? Thanks.

Changed in linux:
status: New → Incomplete
Pavel Mlčoch (pavkamlc) wrote :

Used actualy hardy kernel

pavka@ubuntu:~$ dpkg -l | grep linux-image
pi linux-image-2.6.20-krg2.1.1-686 2.6.20~krg2.1.1-1 Linux 2.6.20-krg2.1.1 image on PPro/Celeron/PII/PIII/P4
ii linux-image-2.6.24-11-generic 2.6.24-11.17 Linux kernel image for version 2.6.24 on x86/x86_64
ii linux-image-2.6.24-11-xen 2.6.24-11.17 Linux kernel image for version 2.6.24 on This kernel can be used
ii linux-image-generic 2.6.24.11.11 Generic Linux kernel image
ii linux-image-xen 2.6.24.11.11 Real time Linux kernel image

Pavel Mlčoch (pavkamlc) wrote :

Is the way to get paused error output, or send it to other device, etc. pendrive? Ive HW serial console, but it will be available maybe next week.

Pavel Mlčoch (pavkamlc) wrote :
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → High
status: Incomplete → Triaged
William Grant (wgrant) wrote :

I'm getting this too, running 2.6.24-12.22. On my laptop, it's starting hal that kills it; everything up to then works fine. I've reproduced this by booting with init=/bin/bash, starting dbus, then starting hal. Unfortunately, I can never scroll back far enough to get the initial error.

The earliest errors I can scroll back to go something like this: (transcribed from photo)

---
kernel BUG at /build/buildd/linux-2.6.24/debian/build/custom-source-xen/arch/x86/mm/highmem_32-xen.c:42!
invalid opcode: 0000 [#9] SMP
Modules linked in: [...]
---

We then get into lots of this:

---
Fixing recursive fault but reboot is needed!
BUG: scheduling while atomic: hald/5345/0x00000002
Pid: 5345, comm: hald Tainted: G D 2.6.24-12-xen #1
 [<c030e3b8>] schedule+0x318/0x640
 [<c01291c0>] do_exit+0x770/0x8b0
 [<c0125e8b>] printk+0x1b/0x20
 [<c0106397>] die+0x287/0x290
[... see attached photos for rest of the trace ...]
---

I have 5 photos which together show that trace in its entirety, if needed.

Bryan York (bryan-york) wrote :

As a tip...I believe this is caused by the integrated Intel video card. I had the same problem, and installed a nvidia card, and had no problems. Now I just have to wait for this other bug to be fixed:

https://bugs.launchpad.net/ubuntu/+bug/216854

GeorgeB (georgeav) wrote :

I have the same problem and it seems to be caused by the video card (i915). I changed the driver to vesa in xorg.conf and it booted just fine. I added the kern.log of the crash.

GeorgeB (georgeav) wrote :

It's a Thinkpad T61 laptop; xen kernel version is:
Linux galaptoc 2.6.24-16-xen #1 SMP Thu Apr 10 15:51:04 UTC 2008 i686 GNU/Linux

ultrabit (ultrabit) wrote :

I have the same problem on 2.6.24-17-xen.
I tried to restart in single user mode, and the kernel boot well !
It crashes after doing:

$>/etc/init.d/hal start (it requires dbus to start before)

maybe hal conflict with xen in any way ?

Paul McEnery (pmcenery) wrote :

I also have this problem on a Dell Inspiron 9300. It has the ATI Mobility Radeon X300 graphics card. Obviously on a laptop there is no choice when it comes to trying an alternative graphics card! I have also tried the 2.6.24-18-xen kernel, but this doesn't seem to make any difference. In a last-ditch effort I even tried going back to the xorg driver instead of fglrx, but this made no difference.

Jorge Peixoto (jrglz) wrote :

The same problem.

I have a Dell Inspiron 9300 with a Nvidia GeForce Go 6800.

Alvaro del Castillo (acs) wrote :

The same problem for me. The process that fires up the kernel problem is "hald-runner". hald is the daemon for hardware abstraction layer (HAL) so it is not strange that the problem is related to it.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Alvaro del Castillo (acs) wrote :

Great news! If the upgrade for a hardy system it is not very intrusive in the system packages I could test it. What are the package source lines I should add to my sources.list file to install this new kernel?

Hi Alvaro,

You'll just need to enable the Intrepid repository in your sources.list file. Should look something like:

deb http://archive.ubuntu.com/ubuntu/ intrepid main
deb-src http://archive.ubuntu.com/ubuntu/ intrepid main

Thanks.

Steve Langasek (vorlon) wrote :

Hi Álvaro,

Have you had a chance to test whether intrepid fixes this problem?

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

Manoj Iyer (manjo) wrote :

This bug was reported a while ago but there hasn't been any recent comments or updates. Is this still an issue with the latest pre-release of Jaunty 9.04? Refer to http://www.ubuntu.com/testing/jaunty/beta . Please let us know.

Changed in linux (Ubuntu):
status: Triaged → Incomplete
Stefan Bader (smb) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - http://www.ubuntu.com/getubuntu/download. To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers