[hardy alpha-5] LSI Logic SAS1064 not detected on install

Bug #196097 reported by Alex Muntada on 2008-02-27
4
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Alex Muntada

Bug Description

Binary package hint: linux-source-2.6.24

The server has 2 SAS drives in RAID 1 attached to the LSI Logic SAS 1064e, but the installer says that no disk is detected and shows a list of modules to try.

Since the SAS1046 is Fusion-MPT based, I tried to load several of the mpt* modules, but no luck.

LSI has some drivers available online, but I have to boot first the server from a different controller before compiling and testing them:
http://www.lsi.com/storage_home/products_home/standard_product_ics/sas_ics/lsisas1064/

Being hardy the next LTS release, I guess this is somehow an important issue.

Alex Muntada (alex.muntada) wrote :

This is the output of lspci -v:

08:00.0 SCSI storage controller: LSI Logic / Symbios Logic M1064E MegaRAID SAS (rev 04)
        Subsystem: Intel Corporation Unknown device 3486
        Flags: bus master, fast devsel, latency 0, IRQ 10
        I/O ports at 2000 [size=256]
        Memory at b8b10000 (64-bit, non-prefetchable) [size=16K]
        Memory at b8b00000 (64-bit, non-prefetchable) [size=64K]
        Expansion ROM at b8e00000 [disabled] [size=2M]
        Capabilities: [50] Power Management version 2
        Capabilities: [68] Express Endpoint IRQ 0
        Capabilities: [98] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
        Capabilities: [b0] MSI-X: Enable- Mask- TabSize=1

Hi Alex,

Can you actually attach the output of 'sudo lspci -vvnn'. For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies. Thanks.

Changed in linux:
status: New → Incomplete
Alex Muntada (alex.muntada) wrote :

Attached requested information, plus this:

# cat /proc/version
Linux version 2.6.24-8-generic (buildd@yellow) (gcc version 4.2.3 (Ubuntu 4.2.3-1ubuntu2)) #1 SMP Thu Feb 14 20:13:27 UTC 2008
# uname -a
Linux thos 2.6.24-8-generic #1 SMP Thu Feb 14 20:13:27 UTC 2008 x86_64 unknown

If you need me to try to load the mpt* modules and send you the dmesg, let me know.

BTW, I forgot to mention that the LSI Logic controller is embedded in the Intel motherboard, though I'm not sure it'd make a difference.

Alex Muntada (alex.muntada) wrote :

The problem seems to be this:

  Subsystem: Intel Corporation Unknown device [8086:3486]

Which should be identified as:

  Intel Embedded Server RAID Technology II [Intel Corporation]

See the PCI listings on this page:

  http://listing.driveragent.com/pci/1000/0057

Please, let me know if I should perform any tests or provide more information.

Alex Muntada (alex.muntada) wrote :

While playing with some BIOS options, I disabled the Intel's SAS embedded software RAID, and now hardy find the controller and the 2 disks without trouble. I also tried latest CentOS 5 and got the same results (w/soft-raid enabled on BIOS nothing is detected, disabled soft-raid on BIOS and everything works just fine). Therefore, it seems that the problem is the Intel embedded software RAID, not the motherboard nor its embedded SAS controller.

Sorry for the burden. You can close this bug.

Thanks Alex. I'm closing this per your last request and comment. Thanks.

Changed in linux:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments