Wrong UDMA mode due to error in 40/80 wire cable detection

Bug #195221 reported by jap1968 on 2008-02-24
50
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Hardy by Brett Sealey
Nominated for Intrepid by Matt Austin
linux (Ubuntu)
Medium
Unassigned
Nominated for Hardy by Brett Sealey
Nominated for Intrepid by Matt Austin
linux-source-2.6.22 (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by Brett Sealey
Nominated for Intrepid by Matt Austin

Bug Description

I have an Asus Eee PC 4GB laptop, and I am testing Ubuntu Hardy 8.04 (kernel 2.6.24-8) on it.

The computer has a 4GB SSD soldered to the motherboard. The disk is reported as UDMA66 capable, but is installed as UDMA33 because the system does not detect a 80 pin conductor.

I have tried adding kernel parameters (ide0=ata66 ide1=ata66) but these seems to be ignored. I have read that these parameters are just to instruct the kernel not to do the 40/80 wire test.

I have written a blog entry [http://ospatia.blogspot.com/2008/02/eee-pc-optimizar-el-disco-ssd.html] (in Spanish) with additional information (dmesg output, some tests with hdparm, ...) and I have found additioal people having same problem with fast (300x) Compact Flash cards.

dmesg output extract:

[ 26.700245] ata2.00: ATA-4: SILICONMOTION SM223AC, , max UDMA/66
[ 26.700256] ata2.00: 7815024 sectors, multi 0: LBA
[ 26.700297] ata2.00: limited to UDMA/33 due to 40-wire cable
[ 26.716208] ata2.00: configured for UDMA/33

jap1968 (jap1968) wrote :

This bug seems to be related to this one:
https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.22/+bug/110636

...since I obtain the same error message when I try to change to UDMA66 by meadns of hdparm:

$ sudo hdparm -X68 /dev/sda

/dev/sda:
 setting xfermode to 68 (UltraDMA mode4)
SG_IO: bad/missing ATA_16 sense data:: ....

jap1968 (jap1968) wrote :

Detected in Ubuntu 8.04 alfa 4 + all currently available updates

Hi,

Care to test the latest 2.6.24-10 kernel and verify this still an issue? If it still is an issue, per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies .

Also note that we will keep this open against the actively developed kernel bug against 2.6.22 this will be closed. Thanks again and we appreciate your help and feedback.

Changed in linux:
status: New → Incomplete
Changed in linux-source-2.6.22:
status: New → Won't Fix
jap1968 (jap1968) wrote :
jap1968 (jap1968) wrote :
jap1968 (jap1968) wrote :
jap1968 (jap1968) wrote :
pad (wtantisiriroj) wrote :

I fixed this problem in my laptop using technique from "limited to UDMA/33 due to 40-wire cable", http://pixca.net/2008/02/03/limited-to-udma33-due-to-40-wire-cable/. For those of you who are using Gusty, I have create a deb file for my patch.

Usage:
sudo dpkg -i --force-overwrite libata-80wire_2.6.22-14.52_i386.deb

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in linux-source-2.6.24:
status: New → Invalid
Kyle M Weller (kylew) wrote :

I confirm this issue with latest hardy

Anders Kvist (akv) wrote :

I can confirm this on Hardy too on my Dell D430 with a Sandisk SSD UATA 5000.

Hdparm -i shows udma2 mode while debian uses udma5 - and read speeds are the twice.

Will the fix from pad's post be in Hardy?

/Anders

Anders Kvist (akv) wrote :

I just installed a 2.6.18 kernel from Debian Etch - this gives me udma5 and full speed.

your able to install debian kernels in ubuntu? How? What repo's and
is there any performance difference?

jap1968 (jap1968) wrote :

Just updated to the latest kernel available for Hardy (2.6.24-14) a couple of hours ago.
No changes. The problem remains the same:

[ 27.823382] ata2.00: ATA-4: SILICONMOTION SM223AC, , max UDMA/66
[ 27.823394] ata2.00: 7815024 sectors, multi 0: LBA
[ 27.823436] ata2.00: limited to UDMA/33 due to 40-wire cable
[ 27.839329] ata2.00: configured for UDMA/33

Anders Kvist (akv) wrote :

Kyle, I just found the .deb on packages.debian.org.

It boots, but no wireless and probably other things that doesn't work too...but performance on disk is GREAT :)

f3a97 (f3a97) wrote :

Hi,
      I have the same problem, even with the latest Hardy updates:

Linux ste-ubuntu 2.6.24-15-generic #1 SMP Fri Apr 4 03:48:31 UTC 2008 i686 GNU/Linux

With hdparm -t, I have about half throughput with respect to the Gutsy kernel! Now I'm at 26 MB/s, with Gutsy I had 56MB/s.

Let me know if you want any other detail.

f3a97 (f3a97) wrote :

One note that I find interesting to add.

My disks are PATA. With the Gutsy kernel, I had the correct performance - they were recognized ad hda and hdb.

Now, with Hardy, they are recognized as sda and sdb. This could mean that the problem lie into the libata kernel part (IMHO).

Furthermore, in dmesg I have the same output as presented by jap1968:

limited to UDMA/33 due to 40-wire cable

jaymz168 (mercury168) wrote :
Download full text (5.3 KiB)

>>One note that I find interesting to add.
>>
>>My disks are PATA. With the Gutsy kernel, I had the correct performance - they were recognized ad hda and hdb.
>>
>>Now, with Hardy, they are recognized as sda and sdb. This could mean that the problem lie into the libata kernel part (IMHO).
>>
>>Furthermore, in dmesg I have the same output as presented by jap1968:
>>
>>limited to UDMA/33 due to 40-wire cable

I can report I have the same problem:

s0l0ne@solzero:~$ sudo hdparm -tT /dev/sda

/dev/sda:
 Timing cached reads: 424 MB in 2.00 seconds = 211.95 MB/sec
 Timing buffered disk reads: 38 MB in 3.01 seconds = 12.61 MB/sec

s0l0ne@solzero:~$ sudo hdparm /dev/sda

/dev/sda:
 IO_support = 0 (default)
16-bit)
 HDIO_GET_UNMASKINTR failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_KEEPSETTINGS failed: Inappropriate ioctl for device
 readonly = 0 (off)
 readahead = 256 (on)
 geometry = 4864/255/63, sectors = 78140160, start = 0

s0l0ne@solzero:~$ lsmod
Module Size Used by
snd_rtctimer 4640 0
xfs 571288 1
nls_cp437 6656 0
wlan_wep 8064 1
isofs 36388 0
af_packet 23812 4
udf 88612 0
i915 32512 2
drm 82580 3 i915
ppdev 10372 0
speedstep_lib 6532 0
cpufreq_conservative 8712 0
cpufreq_powersave 2688 0
cpufreq_ondemand 9740 0
cpufreq_userspace 5284 0
cpufreq_stats 7104 0
freq_table 5536 2 cpufreq_ondemand,cpufreq_stats
sbs 15112 0
sbshc 7680 1 sbs
dock 11280 0
iptable_filter 3840 0
ip_tables 14820 1 iptable_filter
x_tables 16132 1 ip_tables
lp 12324 0
wlan_scan_sta 14720 1
ath_rate_sample 14336 1
joydev 13120 0
ath_pci 101024 0
wlan 207728 5 wlan_wep,wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal 192592 3 ath_rate_sample,ath_pci
pcmcia 40876 0
parport_pc 36260 1
parport 37832 3 ppdev,lp,parport_pc
snd_intel8x0 35356 3
evdev 13056 6
snd_ac97_codec 101028 1 snd_intel8x0
snd_usb_audio 83936 1
snd_pcm_oss 42144 0
snd_mixer_oss 17920 1 snd_pcm_oss
ac97_bus 3072 1 snd_ac97_codec
psmouse 40336 0
serio_raw 7940 0
snd_pcm 78596 5 snd_intel8x0,snd_ac97_codec,snd_usb_audio,snd_pcm_oss
snd_usb_lib 18432 1 snd_usb_audio
snd_hwdep 10500 1 snd_usb_audio
snd_seq_dummy 4868 0
pcspkr 4224 0
yenta_socket 27276 2
rsrc_nonstatic 13696 1 yenta_socket
pcmcia_core 40596 3 pcmcia,yenta_socket,rsrc_nonstatic
snd_seq_oss 35584 0
snd_seq_midi 9376 0
snd_rawmidi 25760 2 snd_usb_lib,snd_seq_midi
snd_seq_midi_event 8320 2 snd...

Read more...

Dan McGee (dpmcgee) wrote :

I submitted this patch upstream for this issue, thought I'd point it out here:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=01ce2601e4ba354fe1e25bb940817570d0c8ed4f;hp=a6116c9e60978a6deaa20691c67ffed727e50df1

Should be in your 2.6.26 kernel release, or you can easily apply this to any older kernel.

Anders Kvist (akv) wrote :

I still only have half the speed with my Dell D430 with a SanDisk SSD UATA 5000 1.8, 1.27, max UDMA/100

JayBee (jonathan-bourne) wrote :

How can I establish the devid, subvendor, subdev values for my own laptop so that I can apply a similar patch to that suggested by Dan McGee? Is it output from a command line utility of some sort?

tlu (thomas-ludwig-gmx) wrote :

I'm having the same problem using Hardy. Any chance to write a patch like pad's one for Gutsy mentioned in comment #8 above?

Hi Guys,

Dan, you mentioned submitting a patch upstream. . . thanks for doing that, it's much appreciated. For those interested, the upcoming Intrepid Ibex 8.10 kernel was most recently rebased with the upstream 2.6.25 kernel and is available for testing. It contains the patch Dan submitted and is available in the following PPA:

https://edge.launchpad.net/~kernel-ppa/+archive

If you are not familiar with how to install packages from a PPA basically do the following:

Create the file /etc/apt/sources.list.d/kernel-ppa.list to include the following two lines:

deb http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main
deb-src http://ppa.launchpad.net/kernel-ppa/ubuntu hardy main

Then run the command:

sudo apt-get update

You should then be able to install the linux-image-2.6.25 kernel package. After you've finished testing you can remove the kernel-ppa.list file and run 'sudo apt-get update' once more. Please let us know your results. Thanks.

tlu (thomas-ludwig-gmx) wrote :

Leann,

I installed kernel 2.6.25.1 as advised. Didn't solve the problem, though. My harddisks are still addressed as UDMA2 and performance is as bad as with 2.6.24.

BTW: KDE wouldn't start with the new kernel (I'm using Kubuntu). All I got was the console.

tlu (thomas-ludwig-gmx) wrote :

Sorry - I forgot to add that I have a MSI 915P/G Neo2 motherboard with a VIA6410 IDE Raid Controller.

tlu (thomas-ludwig-gmx) wrote :
tlu (thomas-ludwig-gmx) wrote :
tlu (thomas-ludwig-gmx) wrote :
tlu (thomas-ludwig-gmx) wrote :
wanjie.info (wanjie) wrote :

thanks "Leann Ogasawara "
it's works.
after i installed linux-image-2.6.25.1
here is my hdparm result.

before------
/dev/sdb:
 Timing cached reads: 2 MB in 2.08 seconds = 984.59 kB/sec
 Timing buffered disk reads: 4 MB in 4.19 seconds = 978.71 kB/sec

/dev/sda:
 Timing cached reads: 1220 MB in 2.00 seconds = 609.37 MB/sec
 Timing buffered disk reads: 56 MB in 3.07 seconds = 18.24 MB/sec

after-----------------------------
/dev/sdb:
 Timing cached reads: 1574 MB in 2.00 seconds = 786.84 MB/sec
 Timing buffered disk reads: 174 MB in 3.03 seconds = 57.50 MB/sec

/dev/sda:
 Timing cached reads: 1492 MB in 2.00 seconds = 746.06 MB/sec
 Timing buffered disk reads: 80 MB in 3.03 seconds = 26.39 MB/sec

what a big bug with linux-image-2.6.24.16.

Matt Austin (mattaustin) wrote :

Using Intrepid Alpha 3 (with latest updates) on the EeePC 701:

dmesg output extract:
[ 9.484446] ata2.00: ATA-4: SILICONMOTION SM223AC, , max UDMA/66
[ 9.484455] ata2.00: 7815024 sectors, multi 0: LBA
[ 9.500401] ata2.00: configured for UDMA/66

Does this mean that this bug has been resolved in Intrepid?

Matt Austin (mattaustin) wrote :

Forgot mention that the kernel version is 2.6.26-5-generic.

jap1968 (jap1968) wrote :

I am using a modified kernel:

http://www.array.org/ubuntu/features.html

Which includes the 40-wire UDMA patch. I do not know if this same patch is going to be included in the official kernel, but it seems to work flawlessly.

Anyway, the speed improvement (Eee PC 701, 4GB) is much less than what I expected.

Adam McDaniel (adamrmcd) wrote :

Yes, that 40-wire UDMA patch is already committed to ubuntu-intrepid.git

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Tested my EeePC 701 (4G) with Intrepid Alpha 5. The issue appears to be solved:

[ 10.324470] ata2.00: ATA-4: SILICONMOTION SM223AC, , max UDMA/66
[ 10.324481] ata2.00: 7815024 sectors, multi 0: LBA
[ 10.340394] ata2.00: configured for UDMA/66
[ 10.340825] scsi 2:0:0:0: Direct-Access ATA SILICONMOTION SM n/a PQ: 0 ANSI: 5

Alessio Igor Bogani (abogani) wrote :

This bug report is being closed due to your last comment regarding this being fixed. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in linux:
status: Triaged → Fix Released
jap1968 (jap1968) wrote :

I also upgraded from Ubuntu 8.04 to 8.10 alfa 5

I can confirm that the bug has been solved, just as Paulo commented before.

Unfortunately, the SSD of this computer (Eee PC 701, 512MB + 4GB SSD) does not seem to improve on UDMA66 mode:

$ sudo hdparm -t /dev/sda1

/dev/sda1:
Timing buffered disk reads: 66 MB in 3.02 seconds = 21.83 MB/sec

pad (wtantisiriroj) wrote :

I just updated my laptop to Hardy and I still got the same problem. As the same as last time, I fixed this problem in my laptop using technique from "limited to UDMA/33 due to 40-wire cable", http://pixca.net/2008/02/03/limited-to-udma33-due-to-40-wire-cable/. For those of you who are using Hardy, I have created a deb file for my patch.

Usage:
sudo dpkg -i --force-overwrite libata-80wire_2.6.24-19.41_i386.deb

what_if (jonathan-a-phelps) wrote :

**Hack/workaround alert**

I had a similar problem with my computer.

I simply forced UDMA Mode 4 and ATAPI-5 in the BIOS instead of "Auto".
This fixed my problem and may fix yours as linux then is forced to use that speed irregardless of the 80-wire cable being detected.

Jullian Gafar (jullian) wrote :

I have just upgraded to 8.10 beta and can report that this bug still exists. I also tried the .deb package named libata-80wire (from http://launchpadlibrarian.net/17612513/libata-80wire_2.6.24-19.41_i386.deb) but up to now it's only available for kernel 2.6.24-19. It correctly sets my sda to UDMA/100, but my sound stops working (because I tested that kernel on Ibex - AFAIK that kernel is for Hardy).

Could anybody make that package for 8.10 please, without it my laptop works at a snail's pace - even slower that Windows. When I', on 2.6.24 (patched) it works great, but I want everything else to work too...

My Laptop: NEC Versa E400.

root@zelda:~# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 650/M650 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS961 [MuTIOL Media IO]
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:08.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 65x/M650/740 PCI/AGP VGA Display Adapter

root@zelda:~# lsmod | grep -i ata
ata_generic 8324 0
pata_acpi 8320 0
pata_sis 15236 5
libata 159472 3 ata_generic,pata_acpi,pata_sis
scsi_mod 151436 5 sbp2,sg,sd_mod,sr_mod,libata

f3a97 (f3a97) wrote :
Download full text (3.5 KiB)

I can confirm this in Intrepid, I've opened a new bug:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/285595

Perhaps it is better to signal here that the situation is not improved.

2008/10/22 Jullian Gafar <email address hidden>

> I have just upgraded to 8.10 beta and can report that this bug still
> exists. I also tried the .deb package named libata-80wire (from
> http://launchpadlibrarian.net/17612513/libata-
> 80wire_2.6.24-19.41_i386.deb) but up to now it's only available for
> kernel 2.6.24-19. It correctly sets my sda to UDMA/100, but my sound
> stops working (because I tested that kernel on Ibex - AFAIK that kernel
> is for Hardy).
>
> Could anybody make that package for 8.10 please, without it my laptop
> works at a snail's pace - even slower that Windows. When I', on 2.6.24
> (patched) it works great, but I want everything else to work too...
>
> My Laptop: NEC Versa E400.
>
> root@zelda:~# lspci
> 00:00.0 Host bridge: Silicon Integrated Systems [SiS] 650/M650 Host (rev
> 01)
> 00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI
> bridge (AGP)
> 00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS961 [MuTIOL Media
> IO]
> 00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
> 00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller
> (rev 07)
> 00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller
> (rev 07)
> 00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
> 00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev
> a0)
> 00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97
> Sound Controller (rev a0)
> 00:08.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller
> 01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS]
> 65x/M650/740 PCI/AGP VGA Display Adapter
>
> root@zelda:~# lsmod | grep -i ata
> ata_generic 8324 0
> pata_acpi 8320 0
> pata_sis 15236 5
> libata 159472 3 ata_generic,pata_acpi,pata_sis
> scsi_mod 151436 5 sbp2,sg,sd_mod,sr_mod,libata
>
> --
> Wrong UDMA mode due to error in 40/80 wire cable detection
> https://bugs.launchpad.net/bugs/195221
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu: Invalid
> Status in "linux" source package in Ubuntu: Fix Released
> Status in "linux-source-2.6.22" source package in Ubuntu: Won't Fix
>
> Bug description:
> I have an Asus Eee PC 4GB laptop, and I am testing Ubuntu Hardy 8.04
> (kernel 2.6.24-8) on it.
>
> The computer has a 4GB SSD soldered to the motherboard. The disk is
> reported as UDMA66 capable, but is installed as UDMA33 because the system
> does not detect a 80 pin conductor.
>
> I have tried adding kernel parameters (ide0=ata66 ide1=ata66) but these
> seems to be ignored. I have read that these parameters are just to instruct
> the kernel not to do the 40/80 wire test.
>
> I have written a blog entry [
> http://ospatia.blogspot.com/2008/02/eee-pc-optimizar-el-disco-ssd.html]
> (in Spanish) with additional information (dmesg output, some tests with
> hdp...

Read more...

^rooker (rooker) wrote :

Seem to be suffering from the same problem (Kubuntu Hardy).

Furthermore, this is probably causing slow (4x max.) DVD burn speeds complaints:
https://bugs.launchpad.net/ubuntu/+source/k3b/+bug/31709

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

glotz (glotz) wrote :

Opened a new bug because of the kernel team bailout announced above...

https://bugs.launchpad.net/ubuntu/+bug/323302

TEN (launchpad-20-ten) wrote :

Seeing this too on Hardy (hasn't the fix ever been backported?); a sudden flurry of coasters from a DVD recorder (still writing CDs without issue) that had worked well under Feisty (and XP, sigh) took me here.

To my surprise (as for everyone else in this thread, contrary to the dmesg output below), what I found inside the box was an 80-pin connection for both adapters.

In my understanding, the legacy LS-120 (high-capacity floppy disk drive) should not cause the whole bus to be slowed down either - nor should the DVD recorder have any problems even at UDMA/33 even if this actually were "just" a 40-pin cable.

[ 82.591146] scsi1 : ata_piix
[ 82.591267] scsi2 : ata_piix
[ 82.592197] ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0x2c00 irq 14
[ 82.592204] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0x2c08 irq 15
[ 82.754084] ata1.00: ATA-6: WDC WD400BB-55JKA0, 05.01C05, max UDMA/100
[ 82.754092] ata1.00: 78165360 sectors, multi 16: LBA
[ 82.760982] ata1.00: configured for UDMA/100
[ 83.244108] ata2.00: ATAPI: HL-DT-STDVD-RAM GSA-H58N, 1.02, max UDMA/66
[ 83.244136] ata2.01: ATAPI: LS-120 COSM 04 UHD Floppy, 0270M09T, max PIO2
[ 83.244153] ata2.00: limited to UDMA/33 due to 40-wire cable
[ 83.416773] ata2.00: configured for UDMA/33

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers