[Hardy] ndiswrapper does not function with 2.6.24, causes lockup and instability

Bug #194714 reported by amicitas on 2008-02-23
78
Affects Status Importance Assigned to Milestone
ndiswrapper
Invalid
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
ndiswrapper (Ubuntu)
Undecided
Unassigned

Bug Description

ndiswrapper 1.50-1ubuntu1
I cannot get ndiswrapper to work with Ubuntu 8.04 Alpha 5.

I did an upgrade from 7.10 to 8.04.

Using kernel 2.6.24-8 386.

If I enter the command
ndiswrapper -v
I get the following output:

------------------------------------------------------
antoniuk@xibuntu:~$ ndiswrapper -v
modinfo: could not find module ndiswrapper
module version is too old!
utils version: '1.9', utils version needed by module: '0'
module details:
modinfo: could not find module ndiswrapper

You may need to upgrade driver and/or utils to latest versions available at
http://ndiswrapper.sourceforge.net
------------------------------------------------------

If I try to compile from source (ndiswrapper_1.50.orig.tar.gz) I get an error that the kernal version information cannot be found.

If I instead use the 2.6.22 kernel I can get ndiswrapper to work just fine.

amicitas (mir-amicitas) wrote :

Here is the error I get when I try to compile from source.

------------------------------------------------------
antoniuk@xibuntu:~/linux/ndiswrapper/ndiswrapper-1.50$ make
make -C driver
make[1]: Entering directory `/home/antoniuk/linux/ndiswrapper/ndiswrapper-1.50/driver'
Makefile:35: *** Cannot find kernel version in /lib/modules/2.6.24-8-386/build, is it configured?. Stop.
make[1]: Leaving directory `/home/antoniuk/linux/ndiswrapper/ndiswrapper-1.50/driver'
make: *** [all] Error 2
antoniuk@xibuntu:~/linux/ndiswrapper/ndiswrapper-1.50$
------------------------------------------------------

amicitas (mir-amicitas) wrote :

I just installed the 2.6.24-10-generic kernel (and 2.6.24-10-386).

I still cannot compile ndiswrapper, but I get a different error now.

(see attached file.)

description: updated
amicitas (mir-amicitas) wrote :

Update. I could not compile because I did not have the correct dependencies. With linux-headers and build-essentials I can compile and install ok.

Linux now recognizes my wireless card and can see available networks. It starts the process of connecting, however I am still unable to connect.

LordMephisto (lordmephisto86) wrote :

Hi,

have you found any solution for the problem, that you can not connect to any network? Here I have exactly the same problem. I use a wireless card from asus with a marvell W8300 chip. The network-manager (0.6.6) finds my wireless network but the connection will not set up. At the moment I use the 2.6.24-12-generic kernel!

greetings

amicitas (mir-amicitas) wrote :

No I not found any solution. My card connects fine if i load with the 2.6.22 kernel. But not with 2.6.24-12 (or any other 2.6.24).

My router is set up with WPA2.
I have not tried connecting to an unencrypted network.

LordMephisto (lordmephisto86) wrote :

Hi,

thanks for the advice with an older kernel. I loaded a 2.6.22 kernel and everything went fine.... I also use WPA2...

greetings

Greetings!

I use the standard hardy 2.6.24 kernel, and Ndiswrapper sort of works. But only sort of. Same problem as amiticas and LordMephisto.

My card is an Inprocomm IPN 2220 with the correct driver (neti2220) in the latest version available, worked just fine with gutsy (2.6.22).

Happy easter! And find some bugs, rather than eggs! ;)

Hi
 I read a couple of week ago this article

http://kerneltrap.org/Linux/NDISwrapper_and_the_GPL

"A change after 2.6.24 broke ndiswrapper by accidentally removing its access to GPL-only symbols," And thought at the time that Hardy would have supply the patched kernel version. From what i understand Linus feels that using windows drivers taints the kernel, an violates the symbols that had been marked for GPL-only use.

LordMephisto (lordmephisto86) wrote :

I thought "after 2.6.24" meant or means the following once, e.g. 2.6.25 and not a special version of 2.6.24....
Perhaps I am wrong with this...

Happe easter!

LordMephisto (lordmephisto86) wrote :

Another entry was started... Here you go:
https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/194714

greetings

k3lt01 (keltoiboy) wrote :

I have a similar setup to wildwaldbiberhirte but I am getting a different response from ndiswrapper than anyone here has posted as yet.

I installed Hardy, installed the Ubuntu version of ndiswrapper supplied in Hardy, installed the driver that I use with Gutsy, check for errors and get a message saying that the driver is not a Windows 32 bit driver.

Did another clean install of Hardy instead this time I used the latest ndiswrapper version from the website and still get the same message.

Did a clean install of Gutsy, after trying various drivers that have also worked in Feisty, with no problems.

lanzen (lanzen) wrote :

Hi, same problem here. I'm using ndiswrapper and the neti2220 driver as wildwaldbiberhirte.

Might it be WPA related? Hardy connects fine to any not-encrypted network, but fails otherwise.

It was working beautifully in Gutsy.

BTW, I 've also tried 2 different external usb wireless sticks and they failed, too. Of course they both worked in 7.10.

michele (mikj) wrote :

Hi, same problem here too ...
See the bug https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/205000
My acer 1524wlmi with gutsy worked fine without any problems.
When I upgraded from 7.10 to 8.04 alpha6, wlan0 did not worked anymore.
I don't belive it depends from wpa, but maybe from network-manager, or dhcp ... or maybe the new kernel ...
On my last log I can see only a dhcp problem ... NM try to get an ip address but NM goes on timeout (kde 3.5.9)
.... I have tried on wpa, with o without encrypt, disabling all the firewall flushing the rules, etc. etc. ...
eth0 works fine ...
We need of a true linux guru ... or a shining upgrade ... :)

mikj

lanzen (lanzen) wrote :

Hi Michele, I've just added a comment to the thread you started.

lanzen (lanzen) wrote :

With this morning updates bringing in the new kernel, hal and a big bunch of new packets I've had the pleasure to see that this bug has been solved: ndiswrapper works again with my neti driver.

Nice work guys/gals, thanks!

I think, unless somebody advises otherwise, that all these ndiswrapper related issues could be closed.

Josh Smith (saxsux) wrote :

I've installed all the updates, but I'm still having problems - when I try to connect to a WPA network, network manager keeps asking me for the network key, and doesn't connect.

lanzen (lanzen) wrote :

Yep, I talked too soon.

I've just tried now, and it goes into the same routine.

It _did_ work this morning. I did the updating while the usb stick was connected. All went well and I decided to have a go at my internal ndiwsrapper supported Inprocomm card and it worked at once so I took out the stick, just in case, and it went on until I turned the portable off. I have it in the log so I'm planning to have a look at it and see what has changed since this morning, but the funny thing is I've seen it working three times (though not sure about the second) and the first time and this time were just after a kernel change.

michele (mikj) wrote :

Ciao :)

me too ... always the same routine ... :(

mikj

amicitas (mir-amicitas) wrote :

No change for me either.
Same thing as before, it starts to connect but never finishes.

amicitas

Andreas Gnau (rondom) wrote :

Please try connecting from commandline instead of connecting via network-manager in order to see if this related to network-manager or ndiswrapper.

Changed in ndiswrapper:
status: New → Incomplete
lanzen (lanzen) wrote :

I did try trough "manual configuration" and did not succeed.

I've spent a few hours this morning in different tests while taking notes of what was going on in syslog and this line appeared only when I tried to connect through ndiswrapper and my internal card a Inprocomm IPN 2220 with neti2220 driver:

NetworkManager: <WARN> request_and_convert_scan_results(): card took too much time scanning. Get a better one.

So I think this card and/or its driver has something to do with it. On the other hand this card still works nicely in Gutsy.

However, in Hardy, when I succeed in connecting, is always after I've been connected either via cable or an external usb dongle and it drops after about 15/20 minutes.

Connecting to an encrypted network always works, but I've not tested how long it will stay connected yet.

Testing the way I did produces side effects eventually. In the end I was not able to connect to the encrypted network in any ways.

Typical warnings while trying to connect with Inprocomm:

NetworkManager: <WARN> nm_device_802_11_wireless_set_essid(): error setting ESSID to '' for device wlan0: Invalid argument
kernel: [ 4743.943573] ndiswrapper (iw_set_freq:334): setting configuration failed (C0010015)

Struggeling with that same problem here.
Cards: RTL8180L and NetGearWG511v2.
None of those cards are working with kernel 2.6.25-16, when WAP is enable. Connection is possible when wifi is not protected. What makes me wonder is the fact that I could connect to WPA-wifis with the latest beta-live-cd 8.04.

That bug needs to be fixed. (The Priority of that bug must be high/higher, right?

k3lt01 (keltoiboy) wrote :

FIXED IT, Clean Install of Hardy, Install ndiswrapper common and utilities off my old Gutsy CD and instant success. reboot it connects automatically. The problem is how the new ndiswrapper works with Hardy nothing else.

lanzen (lanzen) wrote :

I've tried force installing the two packages from gutsy

ndiswrapper-utils-1.9_1.43-1ubuntu2_amd64.deb
ndiswrapper-common_1.43-1ubuntu2_all.deb

but they didn't make any difference and ubuntu does behave as before: sometimes it does connect, but then connection drops after 15/20 mins. while network-manager continues to display all the blue bars.

Also it seems to me that there's no real difference as 1.43 and the new 1.5 ubuntu packages both contain the same ndiswrapper 1.9. Maybe the bug is more likely related to wpasupplicant or the interaction between ndiswrapper and wpasupplicant. A fact is that it always connects fine if the wifi is not encrypted.

Also, as stated before, Gutsy has no problem whatsoever and even Hardy connects in encrypted mode if the old gusty kernel 2.6.24-12-generic is used. So, kernel bug? Wpasupplicant? Wpasupplivant driver? Feature? I don't know...

Anyway, I haven't tried an a clean install/live cd, but I'm afraid it won't make any difference.

k3lt01, which packages have you installed? Are they older than the those I've tried?
And, above all, is it still working for you?

k3lt01 (keltoiboy) wrote :

I installed the basic Hardy Beta1 i386 CD, then installed ndiswrapper from the corresponding Gutsy CD. The only issue I have had today is blackouts and I can't blame Ubuntu or ndiswrapper for that.

I have been able to use the laptop with no problem while i have had power and that has been most of the afternoon, it is now 11.50 pm and I am going to turn it off now. I will test it tomorrow and if anything untoward happens I will post the details here.

lanzen (lanzen) wrote :

Good night and thank you.
Just one more thing for tomorrow. Your network is encrypted, isn't it?

k3lt01 (keltoiboy) wrote :

The laptop has been on since 5am this morning and it is now 11.31 am and no problems.

No my network isn't encrypted, but that, for me at least, is beside the fact because I couldn't get it to work at all before with Hardy's version of ndiswrapper and now it is working flawlessly with Gutsy's version.

Even though I don't need to, cause I'm to far away from anyone to worry, I will encrypt my network and report back with what happens.

k3lt01 (keltoiboy) wrote :

Since my last post I reset my network with WEP encryption. Rebooted the modem, rebooted the laptop, signed in and it worked, have not had an issue all afternoon (6 hours nearly). Will try WPA tomorrow and see how that goes and report what happens.

lanzen (lanzen) wrote :

Good (for you) so far. :)

I've tried WEP soon after this bug came about when I upgraded to Hardy beta and was not successful. I'll have a go at it again later on this evening when I'll be back home.

WEP was working in Feisty (no WPA). Gutsty had all types and was the best so far as far as I go.

khaefner (kyle-haefner) wrote :

I went back to the 2.6.22 kernel and ndiswrapper 1.51 worked just like it always did. With the 2.6.24 kernel after rmmodding ssb and b43legacy ndiswrapper would take back over the card and I could see the available networks, but WPA kept popping up and asking for my password. dmesg said that authentication was timing out. So for now I am booting only the 2.6.22.

Shaji N V (nvshaji) wrote :

I have a similar problem - my laptop does not connect on reboot. It asks for the keys. On removing the ndiswrapper module a few times (rmmod ndiswrapper), it connects fine :-)

Gustavo Puche (gustavo-puche) wrote :

I had problem trying to work ndiswrapper with the driver neti2220.inf in my laptop Acer Aspire 1524wlmi Amd64 with the Ubuntu Hardy Heron installed and kernel 2.6.24. Ndiswraper had install the driver fine but it wasn't able to work the network manager with wep encryption. In my job i had configure the wifi fine, because it doesn't have encryption. Finally i have configured the network fine. The solution is simple. I had uninstall network manager and configured wifi radar and all works perfect. There is a problem in the way network manager manages the wifi with ndiswrapper. This problem is solved in wifi radar aplication.

I hope this would be usefull to someone.

Bye.

Drahcir (richard-den-adel) wrote :

Hi Gustavo,

I have a similar problem with my Acer Aspire 1520. Without encryption everything works fine, but as soon as I enable WEP or WPA the connection is broken.

Could you please be so kind to explain exactly what you have done? Is it something like :
apt-get remove network-manager
apt-get install wifi-radar

Or do I miss something.

cheers,

k3lt01 (keltoiboy) wrote :

All you need to do is to use Gutsy's version of ndiswrapper Utils and Common instead of Hardy's. Your system will work like that, mine does and has been since my post above where I say I fixed it which was a week ago today.

Gustavo Puche (gustavo-puche) wrote :

 Hi Drahcir,

 This is just you must do. With Synaptic or whatever you wish unistall network-manager and install wifi-radar. You must configure wifi-radar. Be carefull if you have WEP ASCII encryption you must write in the key fiel s:WEP_ASCII_KEY because if you do not put s: it asumes that the key is hexadecimal. Another thing in the wifi-radar front-end you should see the wifi networks available. If you do not see wifi network is because the ndiswrapper driver do not work properly. You must have to try to configure wifi-radar and i think it will work.

Bye...

:)

k3lt01 (keltoiboy) wrote :

Gustavo and Drahcir, have you tried doing as I suggested? If not I suggest you try it as it does work and does not require and fussing about with writing files etc. It simply works.

amicitas (mir-amicitas) wrote :

k3lt01 -
I have tried doing as you suggested and installing the Gusty versions of ndiswrapper and ndiswrapper-utils.
This does not make any change for me. I am still unable to connect.
I did tried this on a clean install and with the live CD.

  • unnamed Edit (1.1 KiB, text/html; charset=ISO-8859-1)

Same problem with me, perhaps changing to a Gutsy kernel will do the trick.
More hastle than I want right now, I'll stick with my desktop for the time
being and fingers crossed for an update soon!

On Tue, Apr 29, 2008 at 7:58 PM, amicitas <email address hidden> wrote:

> k3lt01 -
> I have tried doing as you suggested and installing the Gusty versions of
> ndiswrapper and ndiswrapper-utils.
> This does not make any change for me. I am still unable to connect.
> I did tried this on a clean install and with the live CD.
>
> --
> [Hardy] ndiswrapper does not function with 2.6.24
> https://bugs.launchpad.net/bugs/194714
> You received this bug notification because you are a direct subscriber
> of the bug.
>

same problem for me... i've a presario C700 laptop with broadcom 4311.
i've tried to use fwcutter or ndiswrapper (in gutsy version, hardy version or compiled from sources), but nothing...
i can connect to network without encryption only, so i can't connect to my router.

p.s. with fwcutter my laptop can not even identify my wireless network controller, neither in hardy or in gutsy version, but in gutsy ndiswrapper works fine!

Drahcir (richard-den-adel) wrote :

I've tried the following:
- removed driver from ndiswrapper (ndiswrapper -l for the list of drivers, ndswrapper -r with the driver name)
- unload ndiswrapper (rmmod ndiswrapper)
- used package manager to remove ndiswrapper (search for ndiswrapper, mark the two found ndiswrapper ones for removal)
- reboot
- insert gutsy cd, went to the two install packages from ndiswrapper and double clicked them.
- insert driver to ndiswrapper (ndiswrapper -i)
- modprobe ndiswrapper
- reboot
- can see the wireless networks again, no luck in WPA mode.

Did I do something wrong? ( I still use the latest hardy kernel...)

k3lt01 (keltoiboy) wrote :

Drahcir, just from what you have written it looks like you have done it as I did. I don't understand why it works for me but not for you.

If you use it in unencrypted or WEP mode does it work? If yes does it bring up that it wants to update the ndiswrapper components? If it does then everything seems to be the same, if it doesn't then I think something else is wrong.

lanzen (lanzen) wrote :

I haven't had much time recently, but I've still managed to do some more testing on the hardy live cd (64bit only, so far). Gutsy drivers didn't help, but then again I haven't tried wep. I need wpa because there's too many other APs around here.

What it did work is wpa using... feisty ndiswrapper. I did the test twice in different days, but I haven't had enough time to check for how long the connection would stay alive. However force installing the two feisty packages on my HD didn't produce the success I'd hoped for. To see how it really works I'll have to try again on a clean install .

I've used ndiswrapper-common_1.38-1ubuntu1_all.deb and ndiswrapper-utils-1.9_1.38-1ubuntu1_amd64.deb.

I'm afraid soon I'll be giving up and use my usb dongle that works nicely and even better than ndiswrapper was in gutsy as it always keep itself alive. But there are two good reasons for wanting my internal card to be connected: firstly to have one more free usb plug and secondly not to risk forgetting the usb dongle home when I'm away.

I've attached a resume of my tests. Fell free to comment and add.

dsobiera (dsobiera) wrote :

Same problem here. I am trying to use wmp54gs. In both Feisty and Gutsy ndiswrapper was rock solid with weeks uptime. This uptime was pushing 100's of GBs to my HTPC from my machine. It just worked. I re-installed Gutsy until this is resolved. I read the reason for the problems (Linux and GPL symbols in the kernel) but sadly one of the reasons I went with Ubuntu over Debian was its less zealous attitude towards proprietary drivers. It may be an evil but it is a necessary evil right now. So killing ndiswrapper really has hurt Linux desktop adoption among wireless users (historically a long standing problem group). A pity, really.

dsobiera (dsobiera) wrote :

Sorry. I didn't mean to imply upstream Debian was a problem. I realize Debian is why Ubuntu is what they are so Debian gets nothing but my upmost respect! I just meant that sometimes being pragmatic about drivers needs to take precedence over ideals (especially when there isn't a viable alternative).

Josh Smith (saxsux) wrote :

I agree with you dsobiera. I really hope they sort the kernel out soon.

Does anybody have any near-foolproof instructions for installing the older kernel? I'd really like to get my wifi working again, but don't know how.

lanzen (lanzen) wrote :

As for the issue related to ndiswrapper and the gpl, it had been already reported here and I, as LordMephisto, would have thought it was connected to 2.6.25 and all the others from that onwards. Also,if that's the case, why does it work with open connections?

paul v johnson (p-johno) wrote :

After upgrading from gutsy to hardy WPA stopped working with the new kernel. I can connect if I setup the router with no security, which is obviously not an option. Luckily I can still boot into the old kernel, so I can get wifi working again. When is this problem going to be fixed??

mugginz (mugginz1) wrote :

I also found that a new install of hardy with its ndiswrapper only worked with open and not WEP or WPA networks.

I tried rolling back ndiswrapper-common and ndiswrapper-utils first to 1.43 and then to 1.38 and it didnt work.

However, then while still at ndiswrapper 1.38 I rolled back the kernel to the 2.6.22-14-generic kernel and hey, presto, ndiswrapper started working with a WPA access point.

So it would seem, it is indeed something in the new kernel that is the problem.

lanzen (lanzen) wrote :

Yes, it only works on open networks.

I've done all the testing I could think of and yes, even ndiswrapper 1.38 + wpa doesn't work contrary to what I've said some time ago. It did work then, a couple of times, but then never again.

Very rarely it does connect, no matter which ndiswrapper gets used, but the connection dies after not more than 15-20 min.

So, I've given up, and upgraded to hardy my last gutsy while keeping the old 2.6.22-14 just in case I needed. Whenever I will, I'll have to sort out the resolution problem that I have when I boot into this kernel, but that's another kettle of fish...

Josh Smith (saxsux) wrote :

I think it's about time somebody marked this bug as confirmed...

Changed in linux-ubuntu-modules-2.6.24:
status: Incomplete → Confirmed
Kyle M Weller (kylew) wrote :

I confirm this bug as well while running the latest Hardy Heron, is this going to be fixed?

Roel1963 (roelhendriksen) wrote :

I'm glad this has been reported and confirmed.

I have the same troubles on my Netgear WG311 (Marvell 88w8335 chip) and couldn't find a workaround so I'm back to Gutsy...

Yomamen (yomamen) wrote :

I confirm this bug on this device :
02:02.0 Network controller: Texas Instruments ACX 111 54Mbps Wireless Interface
I use ndiswrapper with tnet1130 driver connected on wpa network.
With gusty kernel on hardy all works fine.

I've also been having instability problems and lockups related to ndiswrapper starting with Hardy. I have to remove the ssb module and modprobe ndiswrapper to begin with just to get my wireless card (Linksys WMP54GS) working. From there, it's very random how long the system can go without locking up. The "lockups" are unusual as well and seem to be related to high network activity (torrents, streaming music / video, downloading, online gaming, etc.). Usually, I have Firefox open when it happens and the app freezes completely when the network goes down. I can launch new applications, but can't do anything related to the wireless card (e.g. remove / reinsert the module, make NetworkManager go offline or disable wireless, start the Restricted Hardware manager or networking manager in System Settings, etc.). At that point my only resolution is to shut down / reboot. When the system comes back up, everything that I tried to do while the system was "locked up" happens at login, as if it was in a queue. Also, when I do shut down I often have to hit the power button once to force a shut down (related to my ATI card's driver) and see numerous messages on the screen relating to NetworkManager and the forced deactivation of my wireless card because it wouldn't deactivate properly during shutdown, at which point I have to hold the button in to do a forced power off.

japie (japie-deserver) wrote :

A bit of the same over here, on my laptop with bcm4315 no WPA connection but unencrypted works, if I use my usb (siemens 108) the same issue.
If I plug the siemens in my desktop machine WPA works without a problem, both machines have a clean Hardy install so it looks like it's hardware related... (maybe some other module is disturbing ndiswrapper encryption)

dsobiera (dsobiera) wrote :

It is my understanding that the GPL symbols issue was "fixed" in the 2.6.25 kernel. So, in theory, ndiswrapper will work like it did in Gutsy with 2.6.25. YAY!!! My question is - I just pulled a new kernel through Ubuntu update last week. It was 2.6.24-17. Does anyone know when we'll get 2.6.25 though an update? It is also my understanding that this "revert of GPL symbols" will not be backported so 2.6.24 we'll never see ndiswrapper working. And since I seem to recall that odd number kernel versions are considired "unstable" (please correct me if I am in error here) plus Hardy being a LTS....... I guess the more important question for me is does the Ubuntu processes allow one day to even get 2.6.25 through an update for Hardy?

dsobiera (dsobiera) wrote :

Re: my last post, has anyone used kernelcheck? And if so, what was your experience?

http://www.ubuntugeek.com/automatically-compile-and-install-the-latest-kernel-using-kernelcheck-in-ubuntu.html

Aaron Peromsik (aperomsik) wrote :

I'm a bit confused about the GPL-symbol kernel thing. ndiswrapper has been working fine for me on Hardy since I followed the directions here:

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff#head-cbc75fcb762da2057fa8dbe904358e4b611353c0

Why is it working, if the GPL-symbol problem is the issue? Is it a matter of using WEP vs WPA? I use WEP... (along with secure protocols of course). Or does it vary by hardware? I'm using an M6805 with built-in Broadcom 4306.

I have compiled and installed 2.6.25 with kernelcheck.
Had major issues with 2.6.24x. similar to this bug + hard lockups daily.

My card is a d-link 520+ with axc100 chip. With 2.6.25 everything works fine connecting to WEP-encrypted network via ndiswrapper - wicd.
Haven't tried WPA yet though.

blackfoxt (blackfoxt) wrote :

Can confirm this bug on my

02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Running Hardy with ndiswrapper + all updates (Kernel 2.6.24-17). Can connect to open wireless networks, but not to encrypted ones. The reason I am running ndiswrapper is because the madwifi-driver has some troubles with my specific model (ar5006eg rev 1 I believe).

I hope this gets fixed. I've become addicted to Ubuntu and really don't feel like switching distros. Unfortunately, encrypted wireless has become one of the essential features these days.

I used kernelcheck to install the latest 2.6.25-4 kernel. WPA now works for me. Kernelcheck asks many configuration questions - must have answered at least one wrong as my sound does not work. On to the next problem ...

Although I have WPA working after generating the 2.6.25 kernel, connecting and authenticating takes up to 3 minutes. All the sources and generated modules also doubled the usage of my system partition . I've reverted back to Gutsy on my notebook, where everything works and authentication takes 1 to 2 seconds. I'm disappointed by Hardy for its WiFi step backward but its great on my wired desktop.

dsobiera (dsobiera) wrote :

Re: Ralph

 Yeah, it's a shame. I know this is complicated but Ubuntu was making a real dent in the commercials sector (as far as getting laptops that could install it and magazines reviewing Ubuntu). But this WiFi thing is a deal killer. I tried Hardy again and went the fwcutter route. And I did indeed get wireless to work. But it was horribly slow. It kept wanting to connect at 1Mb and there was a huge latency as well as dropping.

 So NDISwrapper is the only solution for my wireless card. And it's not like I picked an Uncle Bob's made it in his back room wireless card. It's a name brand and found at a big brand store. I tried to look for an EXACT recommendation for a new wireless card known to work out of the box "as is" with Hardy (no ndiswrapper, no fwcutter) but the best I could find was general chipsets to look for. Strangely enough, on buy.com I cannot search on chipsets.

 So I'm willing to chuck the linksys and get another "G" card (PCI desktop). Can anyone give me an EXACT brand and model of card that is known 100% to work in Hardy stock?

Roel1963 (roelhendriksen) wrote :

In the Netherlands there's a company where you can order Hardy pre-installed computers. As an extra, you can have it delivered with a wireless card installed.

These are the selected wireless cards for this purpose:

ASUS 54Mbps PCMCIA WL-107G
ASUS WL138G V2 PCI
TRUST Bluetooth 2 adapter USB (BT-2400p)

These cards should do the thing, they should have native drivers.

dsobiera (dsobiera) wrote :

Thanks Roel. I just bought a $21 ASUS WL138G V2 PCI from new egg. So it's worth a shot and cheap enough that if it doesn't work - eh...at least I tried. If this does work out of the box (or even if it doesn't) I really hope Ubuntu decides to update their nearly worthless https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported page. I understand it is a community based one but it doesn't have Ubuntu releases (that I could find) as columns. I understand the "free" folks would say to "support vendors that do opensource or friendly hardware". Hey, I'm all for that. But where in the heck do we find an easily found and readable list to do just that? One cannot take a stand to do the right thing and then not give someone the means to do just that. Very poor marketing done here with an LTS release. Which surprises me as one of Ubuntu's strength has been solid marketing on other areas. *shrug*

 Assuming this ticket is still open, when I get my ASUS card I'll install it and Hardy and post my results.

blackfoxt (blackfoxt) wrote :

Great to see that this bug has been confirmed, but what now? Please don't tell me that it's gonna stay this way until Intrebid Ibex comes out. How are things gonna go from here? If more data is needed, I'll be happy to help out...

I hope that this is going to be fixed soon! I think it is a real step backwards for the marketing of the platform to laptop users.

Carl

lionel47 (lionel-laratte) wrote :

Any word on this? My main production machine has this chipset for wireless. Better to just get a new USB wireless card?

Yes. :(

Mikj
------Messaggio originale------
Da: lionel47
Mittente: <email address hidden>
A: <email address hidden>
Rispondi a: Bug 194714
Inviato: 27 Giu 2008 05:04
Oggetto: [Bug 194714] Re: [Hardy] ndiswrapper does not function with 2.6.24,causes lockup and instability

Any word on this? My main production machine has this chipset for
wireless. Better to just get a new USB wireless card?

--
[Hardy] ndiswrapper does not function with 2.6.24, causes lockup and instability
https://bugs.launchpad.net/bugs/194714
You received this bug notification because you are a direct subscriber
of a duplicate bug.

mikj
-----
Sent from my BlackBerry® wireless device

I have just seen that a new update for the 8.04 release has been published. Has this issue been taken care of in the new download? I want to try another upgrade of My laptop from 7.10, (But do not want this to show up again).

Carl

Is this item going to be addressed in a update?

Carl

Ross Bearman (rossbearman) wrote :

I'm also suffering from this, fresh Hardy install Acer Aspire 1360, neti2220 card.

NDISWrapper reports a working device and driver, nm-applet doesn't detect any networks to connect to. My other laptop running Hardy has no problems connecting to the network and this laptop connects fine under XP. Only stopped working on the update to Hardy so I did a fresh install and was met with the same problem.

I'm going to try unencrypting the network as a temporary fix, I live in the middle of no where so it's not really a problem. I'll also upgrade the kernel on one of my test machines to check it all works okay, then do it on this. I'll post up my results.

Ross Bearman (rossbearman) wrote :

Disabling encryption didn't help. I even tried to connect directly by entering the ESSID, of course it still couldn't find it. Going to try .25 now, but I don't hold our much hope for it. Not sure if this is a different bug yet.

I went back and re-installed 7.10 on my think pad t-23 with a blitz card. I then upgraded to 8.04. was unable to get wireless on first boot after upgrade. I then re-booted and hit escape, picked .15 option, and let it run thru to desktop. I was then able to click on the network icon and select my home, (un-protected/open), network. I am going to try the .25 recompile. I hope it does not throw the working .15 option for a loop.

Carl

No go on .25 recompile. I will keep booting .15, (Still working). Hope this gets fixed soon.

Carl

I just upgraded to 8.10. I have full wireless access with the new kernel. I don't know if this will ever be fixed in 8.04, (but the new unstable 8.10 seems to be fine for me).

Have a great day,

Carl

lanzen (lanzen) wrote :

I've started testing 8.10, but ndiswrapper and neti2220 don't work. It looks even worse as in 8.04. Gutsy was the last working so far.

Hi Everyone,

This bug was reported a while ago and hasn't had any recent activity. Is this still an issue with the most recent Intrepid Ibex 8.10 release? Please let us know your results. For now I'm going to retarget this bug to the actively developed linux kernel package. During the Intrepid development cycle the linux-ubuntu-modules package was merged with the linux kernel package. Thanks.

Changed in linux-ubuntu-modules-2.6.24:
status: Confirmed → Incomplete
japie (japie-deserver) wrote :

As far as I can tell in Intrepid all trouble with ndiswrapper/WPA is solved.

paul v johnson (p-johno) wrote :

I can now use the open source driver rtl8187 in intrepid. My wireless card is a USB WG111v3. There is a problem with connection drops but I found the solution in this thread works for me - http://ph.ubuntuforums.com/showthread.php?t=792092&highlight=rtl8187.

As a consequence I've not tried ndiswrapper.

Thanks for the updates. I'm going to go ahead and close this out since we haven't had any negative feedback.

Changed in linux:
status: Incomplete → Fix Released
Daniel T Chen (crimsun) on 2008-12-14
Changed in ndiswrapper:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers