armhf build failure

Bug #1939308 reported by Juerg Haefliger
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Critical
Juerg Haefliger
Impish
Critical
Juerg Haefliger

Bug Description

Building an armhf kernel with gcc 11 fails like this:

 DTC arch/arm/boot/dts/rk3066a-bqcurie2.dtb
  AS [M] arch/arm/crypto/nh-neon-core.o
  CC arch/arm/mach-imx/mach-imx6sx.o
  DTC arch/arm/boot/dts/rk3066a-marsboard.dtb
  CC arch/arm/kernel/hw_breakpoint.o
  DTC arch/arm/boot/dts/rk3066a-mk808.dtb
  CC arch/arm/mach-imx/mach-imx6ul.o
  DTC arch/arm/boot/dts/rk3066a-rayeager.dtb
  CC [M] arch/arm/crypto/nhpoly1305-neon-glue.o
  CC arch/arm/kernel/pj4-cp0.o
  AS [M] arch/arm/crypto/curve25519-core.o
  CC arch/arm/mach-imx/mach-imx7d.o
  DTC arch/arm/boot/dts/rk3188-bqedison2qc.dtb
  AS arch/arm/kernel/iwmmxt.o
  CC arch/arm/mach-imx/mach-imx7ulp.o
  DTC arch/arm/boot/dts/rk3188-px3-evb.dtb
  CC arch/arm/kernel/perf_regs.o
/tmp/ccV0AdoQ.s: Assembler messages:
/tmp/ccV0AdoQ.s:95: Error: selected processor does not support `isb ' in ARM mode
/tmp/ccV0AdoQ.s:103: Error: selected processor does not support `isb ' in ARM mode
  CC [M] arch/arm/crypto/curve25519-glue.o
/tmp/ccV0AdoQ.s:178: Error: selected processor does not support `isb ' in ARM mode
  CC arch/arm/mach-imx/pm-imx7ulp.o
  DTC arch/arm/boot/dts/rk3188-radxarock.dtb
  AS arch/arm/mach-imx/suspend-imx6.o
make[4]: *** [/tmp/kernel-juergh-254d24c-kP9S/build/scripts/Makefile.build:281: arch/arm/common/krait-l2-accessors.o] Error 1
make[4]: *** Waiting for unfinished jobs....
  AS [M] arch/arm/crypto/aes-ce-core.o DTC arch/arm/boot/dts/rk3066a-bqcurie2.dtb
  AS [M] arch/arm/crypto/nh-neon-core.o
  CC arch/arm/mach-imx/mach-imx6sx.o
  DTC arch/arm/boot/dts/rk3066a-marsboard.dtb
  CC arch/arm/kernel/hw_breakpoint.o
  DTC arch/arm/boot/dts/rk3066a-mk808.dtb
  CC arch/arm/mach-imx/mach-imx6ul.o
  DTC arch/arm/boot/dts/rk3066a-rayeager.dtb
  CC [M] arch/arm/crypto/nhpoly1305-neon-glue.o
  CC arch/arm/kernel/pj4-cp0.o
  AS [M] arch/arm/crypto/curve25519-core.o
  CC arch/arm/mach-imx/mach-imx7d.o
  DTC arch/arm/boot/dts/rk3188-bqedison2qc.dtb
  AS arch/arm/kernel/iwmmxt.o
  CC arch/arm/mach-imx/mach-imx7ulp.o
  DTC arch/arm/boot/dts/rk3188-px3-evb.dtb
  CC arch/arm/kernel/perf_regs.o
/tmp/ccV0AdoQ.s: Assembler messages:
/tmp/ccV0AdoQ.s:95: Error: selected processor does not support `isb ' in ARM mode
/tmp/ccV0AdoQ.s:103: Error: selected processor does not support `isb ' in ARM mode
  CC [M] arch/arm/crypto/curve25519-glue.o
/tmp/ccV0AdoQ.s:178: Error: selected processor does not support `isb ' in ARM mode
  CC arch/arm/mach-imx/pm-imx7ulp.o
  DTC arch/arm/boot/dts/rk3188-radxarock.dtb
  AS arch/arm/mach-imx/suspend-imx6.o
make[4]: *** [/tmp/kernel-juergh-254d24c-kP9S/build/scripts/Makefile.build:281: arch/arm/common/krait-l2-accessors.o] Error 1
make[4]: *** Waiting for unfinished jobs....
  AS [M] arch/arm/crypto/aes-ce-core.o
  CC arch/arm/mach-omap2/id.o
  CC arch/arm/kernel/perf_callchain.o
  DTC arch/arm/boot/dts/rk3228-evb.dtb
  AS arch/arm/mach-imx/resume-imx6.o
  CC arch/arm/mach-qcom/platsmp.o

  CC arch/arm/mach-omap2/id.o
  CC arch/arm/kernel/perf_callchain.o
  DTC arch/arm/boot/dts/rk3228-evb.dtb
  AS arch/arm/mach-imx/resume-imx6.o
  CC arch/arm/mach-qcom/platsmp.o

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Impish):
importance: Undecided → Critical
assignee: nobody → Juerg Haefliger (juergh)
status: Confirmed → Fix Committed
Revision history for this message
Matthias Klose (doko) wrote :

please provide verbose build logs, showing all arguments passed to the compiler.

Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
Andy Whitcroft (apw) wrote (last edit ):

Though this is not at all clear, this focal verification request is for focal:linux-oem-5.13. As we do not use gcc11 there this should be simply marked -done.

Juerg Haefliger (juergh)
tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.13.0-16.16

---------------
linux (5.13.0-16.16) impish; urgency=medium

  * impish/linux: 5.13.0-16.16 -proposed tracker (LP: #1942611)

  * Miscellaneous Ubuntu changes
    - [Config] update toolchain in configs

  * Miscellaneous upstream changes
    - Revert "UBUNTU: [Config] Enable CONFIG_UBSAN_BOUNDS"

 -- Andrea Righi <email address hidden> Fri, 03 Sep 2021 16:21:14 +0200

Changed in linux (Ubuntu Impish):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers