[21.10 FEAT] zcrypt DD: AP bus and zcrypt device driver uevent extensions - Kernel

Bug #1933496 reported by bugproxy
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Skipper Bug Screeners
linux (Ubuntu)
Fix Released
Undecided
Canonical Kernel Team

Bug Description

Provide uevents for the following AP bus events:
online state change
config state change

add crypto mode all uevents

Feature will be made available with kernel 5.14.

Git-commit or backport will be provided on top of 5.13.

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-193339 severity-high targetmilestone-inin2110
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
importance: Undecided → High
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2021-08-12 16:53 EDT-------
Fix available upstream in kerner 5.14

Commit ID: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=df6f508c68dbc65def0098cbdf8de7683ae551d2

upstream: df6f508c68db s390/ap/zcrypt: notify userspace with online, config and mode info

Revision history for this message
Frank Heimes (fheimes) wrote :

A patched impish kernel 5.13 is being build here for further testing:
https://launchpad.net/~fheimes/+archive/ubuntu/lp1933496

Revision history for this message
Frank Heimes (fheimes) wrote :

Patch request submitted:
https://lists.ubuntu.com/archives/kernel-team/2021-August/thread.html#123217
changing status to 'In Progress'.

Changed in linux (Ubuntu):
status: Incomplete → In Progress
Changed in ubuntu-z-systems:
status: Incomplete → In Progress
Changed in linux (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Canonical Kernel Team (canonical-kernel-team)
information type: Private → Public
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Frank Heimes (fheimes)
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Revision history for this message
Andy Whitcroft (apw) wrote :

Though this is not at all clear, this focal verification request is for focal:linux-oem-5.13.

Revision history for this message
Frank Heimes (fheimes) wrote :

Ok, since there is no linux-oem-5.13 for s390x, I'm setting the tags to "verification done on focal", to unblock this ticket. (Thx for the clarification apw.)

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-09-14 08:11 EDT-------
Nice try ... but I have nothing to verify. I'd at least need a git to clone from and build my own kernel or a kernel package or whatever to verify this.
Btw. I also do not have any 21.10 ubuntu but I think a 21.04 would work also.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.13.0-16.16

---------------
linux (5.13.0-16.16) impish; urgency=medium

  * impish/linux: 5.13.0-16.16 -proposed tracker (LP: #1942611)

  * Miscellaneous Ubuntu changes
    - [Config] update toolchain in configs

  * Miscellaneous upstream changes
    - Revert "UBUNTU: [Config] Enable CONFIG_UBSAN_BOUNDS"

 -- Andrea Righi <email address hidden> Fri, 03 Sep 2021 16:21:14 +0200

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-09-16 03:52 EDT-------
downloaded and installed the kernel packages. Here is the uname output:

uname -a
Linux t8314009.lnxne.boe 5.13.0-14-generic #14~lp1933496-Ubuntu SMP Mon Aug 16 10:53:26 UTC 2021 s390x s390x s390x GNU/Linux

Verified with some hand-triggered tests that the feature is there and works as expected. All good.

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-09-17 05:08 EDT-------
Fix verified. Landed in impish / 21.10, hence closing the bug.
IBM BZ status:->CLOSED

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers