AMDGPU: Support to load new MC firmware for Polaris12 32bit ASIC

Bug #1932993 reported by koba
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
Groovy
Undecided
koba
linux-oem-5.10 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
koba
Groovy
Undecided
Unassigned

Bug Description

[Impact]
AMD introduce a new firmware and has been SRUed in this public bug.
https://bugs.launchpad.net/ubuntu/focal/+source/linux-firmware/+bug/1929147

For the kernel(oem-5.10/groovy), also need other patches to load this firmware.

[Fix]
Support to load polaris12_32_mc.bin

[Test]
1. Check by modinfo and cnofirm polaris12_32_mc.bin is loaded by amdgpu.ko

#modinfo amdgpu | grep polaris12_32_mc.bin
firmware: amdgpu/polaris12_32_mc.bin

2. Equipped the rx540(PD5001) that would trigger issue and system would bootup successfully into desktop.
*some rx540(PD5000) can't trigger the issue.

[Regression Potential]
Medium, introduce a brand new firmware may cause regression.

koba (kobako)
Changed in linux-oem-5.10 (Ubuntu Focal):
assignee: nobody → koba (kobako)
status: New → In Progress
Changed in linux (Ubuntu Groovy):
assignee: nobody → koba (kobako)
status: New → In Progress
description: updated
koba (kobako)
tags: added: originate-from-1908483 somerville
tags: added: oem-priority
koba (kobako)
description: updated
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.10 (Ubuntu Groovy):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu):
status: New → Invalid
Changed in linux-oem-5.10 (Ubuntu Focal):
status: In Progress → Fix Committed
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

1034 is in proposed now, please test

tags: added: verification-needed-focal
Revision history for this message
koba (kobako) wrote (last edit ):

Verification procedure,
1. apt update
2. apt install linux-image-5.10.0-1034-oem linux-headers-5.10.0-1034-oem
3. reboot
4. can login to desktop.
#uname -a
Linux CRBU-MTE-C7 5.10.0-1034-oem #35-Ubuntu SMP Wed Jun 23 09:55:56 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

5. check polaris12_32_mc.bin
#modinfo amdgpu | grep 32_mc
firmware: amdgpu/polaris12_32_mc.bin

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-5.10 - 5.10.0-1034.35

---------------
linux-oem-5.10 (5.10.0-1034.35) focal; urgency=medium

  * focal/linux-oem-5.10: 5.10.0-1034.35 -proposed tracker (LP: #1933308)

  * AMDGPU: Support to load new MC firmware for Polaris12 32bit ASIC
    (LP: #1932993)
    - drm/amd/pm: correct the checks for polaris kickers
    - drm/amdgpu: add new MC firmware for Polaris12 32bit ASIC

 -- Timo Aaltonen <email address hidden> Wed, 23 Jun 2021 12:24:04 +0300

Changed in linux-oem-5.10 (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1932993

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Focal):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers