[21.10 FEAT] KVM: Use interpretation of specification exceptions

Bug #1932157 reported by bugproxy
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Skipper Bug Screeners
linux (Ubuntu)
Fix Released
Undecided
Canonical Kernel Team

Bug Description

This allows KVM to let SIE interpret specification exceptions instead of doing this itself, leading to performance improvements.

This feature will be made available with kernel >=5.15

A backport will be provided once available.

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-193251 severity-high targetmilestone-inin2110
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Revision history for this message
Frank Heimes (fheimes) wrote :

With "kernel >=5.15" this might come very late (maybe even too late) for 21.10 ...

Changed in ubuntu-z-systems:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
importance: Undecided → High
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2021-09-09 08:50 EDT-------
Current status of the fix: commit is in the maintainer tree. Waiting for merge in mainline

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-09-13 08:57 EDT-------
Upstream commit:

commit 7119decf47d9867266459615be502e5d2cecedba
Author: Janis Schoetterl-Glausch <email address hidden>
Date: Tue Jun 29 10:55:30 2021 +0200

KVM: s390: Enable specification exception interpretation

When this feature is enabled the hardware is free to interpret
specification exceptions generated by the guest, instead of causing
program interruption interceptions.

This benefits (test) programs that generate a lot of specification
exceptions (roughly 4x increase in exceptions/sec).

Interceptions will occur as before if ICTL_PINT is set,
i.e. if guest debug is enabled.

There is no indication if this feature is available or not and the
hardware is free to interpret or not. So we can simply set this bit and
if the hardware ignores it we fall back to intercept 8 handling.

Signed-off-by: Janis Schoetterl-Glausch <email address hidden>
Link: https://<email address hidden>/
Reviewed-by: David Hildenbrand <email address hidden>
Reviewed-by: Christian Borntraeger <email address hidden>
Signed-off-by: Christian Borntraeger <email address hidden>

Revision history for this message
Frank Heimes (fheimes) wrote :

Looks like commit 7119decf47d9 got just upstream accepted and landed in 5.15-rc1 in 'linux':
$ git log --oneline --grep "KVM: s390: Enable specification exception interpretation"
192ad3c27a48 Merge tag 'for-linus' of git://git.kernel.org/pub/scm/virt/kvm/kvm
7119decf47d9 KVM: s390: Enable specification exception interpretation
$ git tag --contains 7119decf47d9
v5.15-rc1

Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Incomplete → Triaged
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Revision history for this message
Frank Heimes (fheimes) wrote (last edit ):

A patched impish kernel 5.13 is currently build at PPA:
https://launchpad.net/~fheimes/+archive/ubuntu/lp1932157
and is soon available for additional testing.

Revision history for this message
Frank Heimes (fheimes) wrote (last edit ):

Patch request submitted:
https://lists.ubuntu.com/archives/kernel-team/2021-September/thread.html#124043
Updating status to 'In Progress'.

Changed in ubuntu-z-systems:
status: Triaged → In Progress
Changed in linux (Ubuntu):
status: Triaged → In Progress
information type: Private → Public
tags: added: impish
Changed in linux (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Canonical Kernel Team (canonical-kernel-team)
Revision history for this message
Frank Heimes (fheimes) wrote :

Upstream commit 7119decf47d9 "KVM: s390: Enable specification exception interpretation" landed in impish master-next as 14ba5a8c6744 and is part of Ubuntu-5.13.0-18.18:
https://launchpad.net/ubuntu/+source/linux/5.13.0-18.18
And since 5.13.0-18.18 just landed in -proposed:
linux | 5.13.0-18.18 | impish-proposed | source
I'm updating this ticket to Fix Committed.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.13.0-19.19

---------------
linux (5.13.0-19.19) impish; urgency=medium

  * impish/linux: 5.13.0-19.19 -proposed tracker (LP: #1946337)

  * impish:linux-aws 5.13 panic during systemd autotest (LP: #1946001)
    - [Config] disable KFENCE

 -- Andrea Righi <email address hidden> Thu, 07 Oct 2021 11:09:51 +0200

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-hwe-5.13/5.13.0-19.19~20.04.1 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Revision history for this message
Frank Heimes (fheimes) wrote :

I'm updating the tags to verification-done-focal,
since this ticket was marked as affecting impish only.
(This focal verification request is probably due to the hwe kernel).

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-10-25 05:51 EDT-------
Fix has landed in impish (U21.10), hence closing the bug.
IBM BZ status change:->CLOSED

Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the linux-raspi/5.13.0-1010.11 kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-impish' to 'verification-done-impish'. If the problem still exists, change the tag 'verification-needed-impish' to 'verification-failed-impish'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-impish
Revision history for this message
Frank Heimes (fheimes) wrote (last edit ):

I'm updating the tags to verification-done-impish,
since this ticket was marked as affecting impish on s390x only (not raspi).
And it was already Fix Released for Impish (s390x) according to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1932157/comments/8

tags: added: verification-done-impish
removed: verification-needed-impish
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers