[Lenovo Ideapad S145 82DJ0001BR] touchpad not working - does not appear on "cat /proc/bus/input/devices"

Bug #1931715 reported by Thiago Flaulhabe Xavier Gomes
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Laptop model: Lenovo Ideapad S145 82DJ0001BR
Manufacturer of the Touchpad: Elan, Synaptics
When the symptom first appeared: At the time I installed Ubuntu on my notebook (dual-boot) - it works fine on Windows.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: linux-image-5.8.0-55-generic 5.8.0-55.62~20.04.1
ProcVersionSignature: Ubuntu 5.8.0-55.62~20.04.1-generic 5.8.18
Uname: Linux 5.8.0-55-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.18
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Fri Jun 11 11:58:39 2021
InstallationDate: Installed on 2021-06-09 (1 days ago)
InstallationMedia: Ubuntu 20.04.2.0 LTS "Focal Fossa" - Release amd64 (20210209.1)
SourcePackage: linux-signed-hwe-5.8
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Thiago Flaulhabe Xavier Gomes (flaulhabe) wrote :
Po-Hsu Lin (cypressyew)
summary: - Notebook touchpad not working - does not appear on "cat
- /proc/bus/input/devices"
+ [Lenovo Ideapad S145 82DJ0001BR] touchpad not working - does not appear
+ on "cat /proc/bus/input/devices"
affects: linux-signed-hwe-5.8 (Ubuntu) → linux (Ubuntu)
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Hi,
Can you give the latest mainline kernel a try to see if this issue exists in the upstream?
https://kernel.ubuntu.com/~kernel-ppa/mainline/v5.13-rc7/

Please download and install amd64/build generic deb files (files marked A, see section "How do I install an upstream kernel?" in https://wiki.ubuntu.com/Kernel/MainlineBuilds) and reboot, let us know if it works and paste your "uname -a" command output in a terminal (ctrl+alt+t) here.
Thanks

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Hui Wang (hui.wang) wrote :

Please test this kernel and upload the dmesg ($dmesg > dmesg.txt): https://people.canonical.com/~hwang4/lp1921649/

thx.

Revision history for this message
Thiago Flaulhabe Xavier Gomes (flaulhabe) wrote (last edit ):

Hey, I've tested the kernel as suggested by Hui Wang (5.8.0-60-generic) and now my touchpad is working normally. Thanks!

I couldn't install the latest kernel as suggested by Po-Hsu Lin because I was getting errors with unmet dependecies in one of the .deb files, even after installing the other two.

As requested, I'm uploading the dmesg.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Revision history for this message
Hui Wang (hui.wang) wrote :

Thanks for testing, and the fixing patch is only in the test kernel currently.

Changed in linux (Ubuntu):
status: Fix Released → Fix Committed
Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu):
status: Fix Committed → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers