[i915] [Comet Lake] Ubuntu only stable in safe graphics mode

Bug #1931475 reported by welefort on 2021-06-09

This bug report will be marked for expiration in 47 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
linux-oem-5.10 (Ubuntu)
Undecided
Unassigned

Bug Description

Brand new machine, Intel i5, Brand new install of 20.04 ubuntu using 5.11.0-18 kernel. BIOS updated to recent firmware. (5/11/2021 date)

Machine will only stay running in safe graphics mode. When booting normal, GUI loads for about 5 seconds then reboots.

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: xorg 1:7.7+22ubuntu1
ProcVersionSignature: Ubuntu 5.11.0-18.19-generic 5.11.17
Uname: Linux 5.11.0-18-generic x86_64
ApportVersion: 2.20.11-0ubuntu65.1
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: pass
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Wed Jun 9 14:04:22 2021
DistUpgraded: Fresh install
DistroCodename: hirsute
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation CometLake-S GT2 [UHD Graphics 630] [8086:9bc5] (rev 05) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8694]
InstallationDate: Installed on 2021-06-09 (0 days ago)
InstallationMedia: Ubuntu 21.04 "Hirsute Hippo" - Release amd64 (20210420)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 413c:2003 Dell Computer Corp. Keyboard SK-8115
 Bus 001 Device 002: ID 046d:c408 Logitech, Inc. Marble Mouse (4-button)
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Lsusb-t:
 /: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/8p, 5000M
 /: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/12p, 480M
     |__ Port 7: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
     |__ Port 8: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
MachineType: ASUS System Product Name
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.11.0-18-generic root=UUID=5e92baa8-faf7-43e0-ab03-c43a1ec8a549 ro recovery nomodeset dis_ucode_ldr text
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/07/2021
dmi.bios.release: 16.5
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1605
dmi.board.asset.tag: Default string
dmi.board.name: PRIME B460-PLUS
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1605:bd04/07/2021:br16.5:svnASUS:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnPRIMEB460-PLUS:rvrRev1.xx:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: ASUS
mtime.conffile..etc.apport.crashdb.conf: 2021-06-09T13:25:26.012453
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.104-1build1
version.libgl1-mesa-dri: libgl1-mesa-dri 21.0.1-2
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.11-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200714-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.17-1

Revision history for this message
welefort (welefort) wrote :
Revision history for this message
welefort (welefort) wrote :
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thanks for the bug report. Please reproduce the bug (unwanted reboot) again, then boot in safe mode and run:

 journalctl -b-1 > prevboot1.txt
 journalctl -b-2 > prevboot2.txt

and attach the resulting text files here.

affects: xorg (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
welefort (welefort) wrote :

This may not be accurate. To get a working computer, I ended up putting an old Nvidia gt630 card in. That works fine.

However in an effort to get this logs, Ubuntu no longer even boots into the GUI if i remove that card. I can get to the Grub Menu, but it reboots at that point if I try and load Ubuntu normally . Safe Graphics mode still works though.

Revision history for this message
welefort (welefort) wrote :
Revision history for this message
welefort (welefort) wrote :

I've been working with someone at the ubuntu forums also: https://ubuntuforums.org/showthread.php?t=2463365&page=2&p=14042724#post14042724

If I add "i915.aplha_support=1" and "nomodeset" to the line. Ubuntu will boot normally, but in a lower resolution (1024x768). it does remain stable. Im unable to change the resolution.

Revision history for this message
Daniel Letzeisen (dtl131) wrote :

So what happens when you use i915.alpha_support=1 without nomodeset?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Those logs are from kernel 5.10.0-1029-oem so reassigning...

affects: linux (Ubuntu) → linux-oem-5.10 (Ubuntu)
summary: - Ubuntu only stable in safe graphics mode
+ [i915] [Comet Lake] Ubuntu only stable in safe graphics mode
Changed in linux (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers