Upgrade fails to boot with kernel 5.4

Bug #1930610 reported by Joachim Lindenberg
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I tried to upgrade an Ubuntu 18.04 to 20.04 two weeks ago. The system is a server type installation running as a virtual machine on Hyper-V, primarily running letsencrypt and nginx.

Actually I tried twice, both upgrades left me with a system that doesn´t boot by default. The first iteration was I tried to accept maintainer version for the boot/grub menu, and as that didn´t restart properly, I tried another time, this time keeping my own version. Both upgrades left me with a system that was not booting.

With the second upgrade, I experimented a little more. When the system restarts, I am stuck with it doesn´t boot. When I then power off and power on again, I get a boot menu with the options Ubuntu, Advanced options for Ubuntu, and UEFI Firmware Settings. With Advanced I get Ubuntu with various kernel options, with Linux 5.4.0-73-generic w/o recovery mode, and Linux 4.15.0-143-generic w/o recovery mode. The variants with 4.15.0-143 actually work, whereas 5.4.0-73 doesn´t work.

I do have some VMs that run 20.04 with kernel 5.4.0-something, thus I assume it is an issue caused by the upgrade or previous installation.

Any idea what to look for?

I asked this already at https://askubuntu.com/questions/1338236/ubuntu-fails-to-start-by-default-after-upgrade-18-04-to-20-04 and then https://answers.launchpad.net/ubuntu/+question/697332, but didn´t get a response that helped me to resolve the issue.

Thanks, Joachim

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1930610/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers