[21.10 FEAT] RoCE: Predictable Interface Names (kernel)

Bug #1929185 reported by bugproxy
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Skipper Bug Screeners
linux (Ubuntu)
Fix Released
Undecided
Frank Heimes

Bug Description

Feature Description:
- Interface names for RoCE Express adapters are currently very hard to predict, causing problems with the installer which requires knowledge of the interface name
- Interface names can change between re-boots, invalidating any previously stored network card configuration
To fix this requires changes in the Linux kernel to indicate whether UIDs are unique (and therefore usable), and in systemd to generate an interface name based on UIDs all the time.

Business Case:
Increase usability, lower service efforts.

Available with kernel 5.13

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-192840 severity-high targetmilestone-inin2110
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Revision history for this message
Frank Heimes (fheimes) wrote :

I'm updating the status to Confirmed, since 5.13 is the target kernel for impish.

Changed in linux (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
importance: Undecided → High
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Changed in ubuntu-z-systems:
status: Incomplete → Confirmed
Revision history for this message
Frank Heimes (fheimes) wrote :

Since kernel 5.13 is in impish proposed:
linux-generic | 5.13.0.12.23 | impish-proposed
I'll update this ticket to Fix Committed.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-z-systems:
status: Confirmed → Fix Committed
Revision history for this message
Frank Heimes (fheimes) wrote :

Since kernel 5.13 landed in -release:
linux-generic | 5.13.0.14.25 | impish
I'm closing this ticket as Fix Released.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Frank Heimes (fheimes)
information type: Private → Public
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2021-10-25 05:39 EDT-------
Fix landed in impish, hence closing the bug.
IBM BZ status change:->CLOSED

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers