[21.04 FEAT] s390/Kconfig: default PCI_NR_FUNCTIONS to 512

Bug #1908414 reported by bugproxy
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Unassigned
linux (Ubuntu)
Fix Released
High
Unassigned

Bug Description

Summary: s390/Kconfig: default PCI_NR_FUNCTIONS to 512

Description: On machines with a large number of PCI devices, including
             Virtual Functions and NVMe devices it is quite common that an
             LPAR can see over 100 PCI functions in Standby or even wants
             to use as many.
             For affected distributions this poses a problem as any PCI
             function probed after the limit has been reached is simply
             inaccessible and invisible for older kernels this is even silent.
             This is solved by increasing the PCI_NR_FUNCTIONS Kconfig option
             to 512 matching the recommended setting in the upstream defconfig.
             In testing and through code study it was determined that this has
             only neglibile memory use overhead of a handful of 4k pages when
             devices are only visible in Standby.

Upstream-ID: 10e59217479d733ff50b6e8c6316ecffe8b857cb

kernel 5.11

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-190384 severity-high targetmilestone-inin2104
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Revision history for this message
Frank Heimes (fheimes) wrote :

WHile checking the current Ubuntu kernel configuration of Ubuntu UNSTABLE (which will eventually land in hirsute) I found that the the CONFIG_PCI_NR_FUNCTIONS option is already set to 512:
$ grep CONFIG_PCI_NR_FUNCTIONS ~/ubuntu-unstable/debian.master/config/annotations
CONFIG_PCI_NR_FUNCTIONS policy<{'s390x': '512'}>
CONFIG_PCI_NR_FUNCTIONS mark<ENFORCED> note<LP:1866056>
And it was set based on LP 1866056 for focal/20.04 and is with that also set for all Ubuntu kernels newer than focaks 5.4.
Hence I mark this ticket as duplicate of LP 1866056.

Changed in linux (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → nobody
status: New → Fix Released
Changed in ubuntu-z-systems:
status: New → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2021-01-18 06:40 EDT-------
IBM Bugzilla status->closed, Fix Released by Canonical

Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
importance: Undecided → High
Changed in linux (Ubuntu):
importance: Undecided → High
Frank Heimes (fheimes)
information type: Private → Public
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers