Kernel 5.4.0-56 Wi-Fi does not connect

Bug #1906770 reported by Ted R Marcus on 2020-12-04
28
This bug affects 7 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Focal
High
Shrirang Bagul

Bug Description

After updating to 5.4.0-56 (generic) on Mint 19.3, Wi-Fi cannot complete connection to network with Netgear A6210 USB adapter (Mediatek MT7612U chipset). Network manager can see available networks, but attempting to connect to a network stalls on "connecting" and does not complete connection. Reverting to 5.4.0-54 solves problem. I did not see this problem after updating to 5.4.0-56 on a 10-year-old Toshiba Satellite laptop (also Mint 19.3), so it appears related to the Netgear/Mediatek hardware.

CVE References

Ted R Marcus (trmarcus983) wrote :

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1906770

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
J.B. (brngr) wrote :

I can confirm the exact behaviour on Ubuntu 18.04. I use a FRITZ!WLAN USB Stick AC 860 with a Ralink mt7662u Chipset.

Kai-Heng Feng (kaihengfeng) wrote :
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Ted R Marcus (trmarcus983) wrote :

I installed 5.4.0-58 and had the same connection problem. Reverting to 5.4.0-54 resolved it.

I have attached the required log files collected under 5.4.0-58.

Ted R Marcus (trmarcus983) wrote :
Ted R Marcus (trmarcus983) wrote :
Ted R Marcus (trmarcus983) wrote :
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Ted R Marcus (trmarcus983) wrote :

I tried two other Wi-Fi adapters with 5.4.0-58. Both are made by TPLINK but use different chipsets: Realtek RTL8192EU and Atheros AR9271. Both were able to connect successfully to a 2.4GHz 802.11n network.

When I tried the Netgear A6210 adapter (Mediatek MT7612U chipset) again, it would not complete a connection as I described earlier. Since the default connection with this adapter is a 5GHz 802.11ac network, I tried switching to the 2.4GHz 802.11n network to which two TPLINK adapters successfully connected. That froze the desktop, requiring a restart. A second attempt after restart also froze the desktop. Reverting to 5.4.0-54 with the Netgear adapter successfully connected to the 5GHz 802.11ac network.

This behavior suggests that the problem is with the kernel driver for the Mediatek MT7612U chipset, and possibly others per J.B. (brngr)'s comment.

Kai-Heng Feng (kaihengfeng) wrote :

Well, can we first make sure if mainline kernel exhibits the same bug?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Jeremy (wa113y3s) wrote :

Kai-Heng Feng I also have the same Netgear device with ID 0846:9053 NetGear, Inc. A6210
It performs as expected in the 5.10-rc6 kernel and 5.4.0-54, fails in 5.4.0-58

Jeremy (wa113y3s) wrote :

It seems that this causes the issue https://git.launchpad.net/~ubuntu-kernel/ubuntu/+source/linux/+git/focal/commit/drivers/net/wireless/mediatek/mt76?id=03db30eca2ae095e035943305f332e2d44d3b4a4
As removing the additions to the mt76x02_util.c file and using the change in the mt76x02-lib.ko allows the device to work in 5.4.0-58
I suspect that commit might be involved in https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1907984

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Jeremy (wa113y3s) wrote :

The correct fix may be to use https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers?h=v5.10&id=05d6c8cfdbd6cefac6b373bad72775fcc4193c80
This allows the previous commit listed to be left in place for this device to function

A test kernel compiled with the patch in comment#13 is uploaded to:
https://people.canonical.com/~shrirang-bagul/lp1906770/

Give it a try and verify if this fixes the issue

Jeremy (wa113y3s) wrote :

Thanks Shrirang, this might also help on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1908478
https://launchpad.net/bugs/1907764
https://launchpad.net/bugs/1907984

I can confirm it works with 0846:9053 NetGear, Inc. A6210

If Ted Marcus needs help installing this kernel, he knows what forum to visit

Changed in linux (Ubuntu):
importance: Undecided → High
assignee: nobody → Shrirang Bagul (shrirang-bagul)
status: Confirmed → In Progress
Changed in linux (Ubuntu Focal):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Shrirang Bagul (shrirang-bagul)
Changed in linux (Ubuntu):
assignee: Shrirang Bagul (shrirang-bagul) → nobody
Ian (ian-may) on 2020-12-18
Changed in linux (Ubuntu Focal):
status: In Progress → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal

I reported bug 1907764, deemed a duplicate of this.
I've installed the latest proposed Ubuntu kernel, 5.4.0-61-generic, under AMD64 and the system is stable with my TP-Link AC-600 adapter installed. It even works!

Jeremy (wa113y3s) wrote :

The 5.4.0-61 kernel in proposed works with ID 0846:9053 NetGear, Inc. A6210

tags: added: verification-done-focal
removed: verification-needed-focal

Problem is back in 5.4.0-62-generic. That version was recently released by Ubuntu and installed on my system during a regular update. However, when I run it and with that TP-Link AC-600 installed, I am again seeing the symptoms I observed in my original bug https://bugs.launchpad.net/bugs/1907764 .
- Networking won't start. Network Settings shows "NetManager not running"
- "ip addr" just hangs
- Firefox never displays a window
Rebooted under the developer version 5.4.0-61-generic, and things are working again (my AC-600 is still enabled and connected).

Zsolt Zsiros (zs-zsiros) wrote :

The problem still exists with kernel 5.4.0-64-generic.
The last working kernel version for me is 5.4.0-54-generic
In case I remove the wifi adapter (ASUSTek Computer, Inc. AC51), then the system is stable again without network.
The attached dmesg output has been collected with kernel version: 5.4.0-54-generic

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.4.0-65.73

---------------
linux (5.4.0-65.73) focal; urgency=medium

  * focal/linux: 5.4.0-65.73 -proposed tracker (LP: #1912220)

  * initramfs unpacking failed (LP: #1835660)
    - SAUCE: lib/decompress_unlz4.c: correctly handle zero-padding around initrds.

  * overlay: permission regression in 5.4.0-51.56 due to patches related to
    CVE-2020-16120 (LP: #1900141)
    - ovl: do not fail because of O_NOATIME

  * Focal update: v5.4.79 upstream stable release (LP: #1907151)
    - net/mlx5: Use async EQ setup cleanup helpers for multiple EQs
    - net/mlx5: poll cmd EQ in case of command timeout
    - net/mlx5: Fix a race when moving command interface to events mode
    - net/mlx5: Add retry mechanism to the command entry index allocation

  * Kernel 5.4.0-56 Wi-Fi does not connect (LP: #1906770)
    - mt76: fix fix ampdu locking

  * [Ubuntu 21.04 FEAT] mpt3sas: Request to include the patch set which supports
    topology where zoning is enabled in expander (LP: #1899802)
    - scsi: mpt3sas: Define hba_port structure
    - scsi: mpt3sas: Allocate memory for hba_port objects
    - scsi: mpt3sas: Rearrange _scsih_mark_responding_sas_device()
    - scsi: mpt3sas: Update hba_port's sas_address & phy_mask
    - scsi: mpt3sas: Get device objects using sas_address & portID
    - scsi: mpt3sas: Rename transport_del_phy_from_an_existing_port()
    - scsi: mpt3sas: Get sas_device objects using device's rphy
    - scsi: mpt3sas: Update hba_port objects after host reset
    - scsi: mpt3sas: Set valid PhysicalPort in SMPPassThrough
    - scsi: mpt3sas: Handling HBA vSES device
    - scsi: mpt3sas: Add bypass_dirty_port_flag parameter
    - scsi: mpt3sas: Handle vSES vphy object during HBA reset
    - scsi: mpt3sas: Add module parameter multipath_on_hba
    - scsi: mpt3sas: Bump driver version to 35.101.00.00

 -- Kleber Sacilotto de Souza <email address hidden> Mon, 18 Jan 2021 17:31:23 +0100

Changed in linux (Ubuntu Focal):
status: Fix Committed → Fix Released
J.B. (brngr) wrote :

The bug seems to be fixed, however I am having massive upload speed issues with said wifi hardware. With the same hardware under Windows, the problem does not occur. Maybe someone can help me to investigate the problem further. I have summarized the question here:

https://askubuntu.com/questions/1292772/slow-upload-speed-via-wifi-on-ubuntu-18-04-with-fritzwlan-usb-stick-ac-860-ral

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers