upgrade to 20.10 broke haswell laptop (no regular boot, no /dev/dri/card0)

Bug #1901505 reported by Sergio Callegari on 2020-10-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Laptop installed with kubuntu focal is not booting after upgrade to 20.10 (that apparently went smooth without any error).

- laptop hangs on boot
- no splash screen is displayed
- laptop can boot in recovery mode
- in this case you do not get /dev/dri/card0 - if X is started it starts on llvmpipe
- i915 driver is loaded, no error about it in journal or dmesg

Jouni Mettala (jouni-mettala) wrote :

Does it boot previous kernel? Then this is bug in package linux.

Sergio Callegari (callegar) wrote :

It is not the kernel. Before doing the upgrade, I tested 20.10 (and its kernel) using the live image as I usually do and everything went fine, while now I have a system that does not work right regardless of the kernel. Hence, my hypothesis is that something went wrong with the upgrade either wrt the initial initrd or with the grub kernel parameters, or with some configuration file.

The problem is that I am finding trouble in trying to identify what is wrong in my system right now.

I have tried a few things like re-installing the kernel, but with no result.

I am not even 100% sure that the hang that I see when attempting a regular boot, the lack of the splash screen and the lack of /dev/dri both originate from the same issue.

Before I try reinstalling the system from scratch with 20.10, I'd like to spend some more time in attempting a rescue, but I do not have many ideas about where to look.

Sergio Callegari (callegar) wrote :

Maybe getting closer to it...

issue is with the gfxmode line in the grub boot entry. If I remove it, or if I force a gfxmode text, then the system boots regularly.

affects: ubuntu → grub2 (Ubuntu)
Julian Andres Klode (juliank) wrote :

Given that it boots to the kernel, but the kernel can't setup the drm device, I'm inclined to believe this is a kernel bug.

affects: grub2 (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1901505

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: groovy
Sergio Callegari (callegar) wrote :

Unable to provide the logs, because when the bug hits, I cannot get to a login prompt.
If there is a way to get some logs, I'd like to try to help, but I need further instructions.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Goro (ggoro) wrote :

I have similar or same problem and I have haswell too... I will explain my problem at large in next post but first try these things.

First when boot and it hangs, try go switch to different VT - ctrl+alt + F3 or F4 then enter

sudo dmesg

at the bottom you will ikely find this...

i915 0000:00:02.0: [drm] GPU HANG

Then try another one - boot kernel with "nomodeset" parameter (without quotes) - for me it produce a working system but only with 1024x768 resolution

And third one - can you specify what Haswell processor you have?

Goro (ggoro) wrote :

As I said in previous post i'm not sure that this is the same problem as with me, but look very similar because of the Haswell Processor and I'm unable to get a working Desktop environment.

Same computer works just fine with Ubuntu 20.04, which have older kernel.

My experience with Ubuntu 20.10 live is that it cannot boot every time and its locks up, but it boots fine in safe gfx mode.
In safe gfx mode I installed it on clean disk, and when try boot it - sometimes just log into gnome shell and it locks up.
Error in dmesg is i915 GPU hang.
In wayland it works better so I can click on menus but sometimes it freeze for few seconds and continue( GPU reset) and when you run program that use xwayland it got a total lock up.
I installed cinnamon desktop and it locks immediately after login, Cinnamon with software rendering works just fine. I tried Xubuntu it hang as well. With "nomodeset" kernel parameter it works fine but only in 1024x768, tested it with Ubuntu, Cinnamon and Xubuntu.

So I search for solution and find this thread over FDO, with a lot of people with Haswell GT1 video having the same problem since kernel 5.6 I think.

https://gitlab.freedesktop.org/drm/intel/-/issues/2024

Other peoples with same problem, also there are several threads over Arch linux forums

https://bugzilla.redhat.com/show_bug.cgi?id=1843274
https://bugzilla.redhat.com/show_bug.cgi?id=1886438

My Processor is Intel Pentium G3258 AE and is Desktop CPU.
Other components I think doesn't really matter in this case.

and my errors from DMESG

[ 31.037041] i915 0000:00:02.0: [drm] GPU HANG: ecode 7:1:8edcfc79, in gnome-shell [1441]
[ 31.037044] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 31.037045] Please file a _new_ bug report at https://gitlab.freedesktop.org/drm/intel/issues/new.
[ 31.037047] Please see https://gitlab.freedesktop.org/drm/intel/-/wikis/How-to-file-i915-bugs for details.
[ 31.037048] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 31.037049] The GPU crash dump is required to analyze GPU hangs, so please always attach it.
[ 31.037050] GPU crash dump saved to /sys/class/drm/card0/error
[ 31.037859] i915 0000:00:02.0: [drm] Resetting chip for stopped heartbeat on rcs0
[ 31.140859] i915 0000:00:02.0: [drm] gnome-shell[1441] context reset due to GPU hang
[ 34.080734] i915 0000:00:02.0: [drm] GPU HANG: ecode 7:1:8edcfc79, in Xorg [1290]
[ 34.080924] i915 0000:00:02.0: [drm] Resetting chip for stopped heartbeat on rcs0
[ 34.183350] i915 0000:00:02.0: [drm] Xorg[1290] context reset due to GPU hang
[ 39.819821] i915 0000:00:02.0: [drm] GPU HANG: ecode 7:1:8edcfc79, in gnome-shell [1441]
[ 39.821530] i915 0000:00:02.0: [drm] Resetting chip for stopped heartbeat on rcs0
[ 39.924378] i915 0000:00:02.0: [drm] gnome-shell[1441] context reset due to GPU hang
[ 45.912749] i915 0000:00:02.0: [drm] GPU HANG: ecode 7:1:8edcfc79, in gnome-shell [1441]
[ 45.912822] i915 0000:00:02.0: [drm] Resetting chip for stopped heartbeat on rcs0
[ 46.014840] i915 0000:00:02.0: [drm] gnome-shell[1441] context reset due to GPU hang

I can attach crash dump ass well.

Kai-Heng Feng (kaihengfeng) wrote :
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Goro (ggoro) wrote :

It result in hang and freeze of graphic system during animation in gnome shell when I click on icon to launch an application from left side menu, but I can switch to VT.

switching to VT and when looking at dmesg I see i915 GPU HANG...

I will try to apply patch to the current ubuntu 5.8 kernel from Chris Wilson(@ickle) at intel for 5.7+ Kernels form this bug report https://gitlab.freedesktop.org/drm/intel/-/issues/2024

This is the patch https://patchwork.freedesktop.org/patch/395580/?series=82783&rev=1

And will report back.

Goro (ggoro) wrote :

I was able to build 5.8.0-25-generic with this patch and is working excellent with Ubuntu (Gnome-shell)

For some reason i can't get the source of latest Ubuntu Kernel 5.8.0-26-generic because is unavailable in unsigned version... so I get previous which is available and do compiling.

So for me with Intel Pentium G3258 CPU - Haswell Generation this fix things. Patch is referenced in my previous message.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.