Crash on startup using linux 5.8.0-25

Bug #1901024 reported by Rauno on 2020-10-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
xf86-video-amd
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I installed Ubuntu 20.04 on my new Lenovo ThinkPad L15 and upgraded it to Ubuntu 20.10 for a newer kernel to fix minor compatibility issues with AMD Renoir.
When using the newer kernel it freezes before splash. I did my best to follow instructions to create a crash file but none were ever created.
Booting to recovery mode with 5.8 works, 5.4 kernel works. Booting from USB the (safe graphics) option works but not the default. On that USB I have latest available daily build (Oct 21 2020) of 20.10. I tried a fresh reinstall of Ubuntu 20.10 and still getting stuck.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1901024/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Rauno (rmoisto) on 2020-10-22
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1901024

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Rauno (rmoisto) wrote :

I can't start a web browser in recovery mode so apport-collect is unusable.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Rauno (rmoisto) wrote :

For some reason switching to amd graphics drivers caused the crash. Also for some reason grub boot option pci=noats fixes it.

Hi Rauno,

Thanks for reporting this bug; nice finding on pci=noats.

$ grep -A1 noats ~/git/linux/Documentation/admin-guide/kernel-parameters.txt
  noats [PCIE, Intel-IOMMU, AMD-IOMMU]
    do not use PCIe ATS (and IOMMU device IOTLB).

Wondering if the amd gfx drivers with ats/iommu (ie, w/out pci=noats) causes memory corruption:

The screenshot in #1 shows that initramfs unpacking failed -- say, something corrupted the compressed initramfs image loaded in memory -- and this happened closely to when AMD-Vi failed to access an IOMMU perf count(er? I guess.)

And it seems to be graphics related, not just ats/iommu code alone, which prints 'AMD-Vi' (it's in linux/drivers/iommu/amd/) since recovery mode, with 'nomodeset', works fine.

When you boot in recovery mode, do you see initramfs unpacking failed as well? (please check 'dmesg | grep -i initramfs')

Rauno (rmoisto) wrote :

I don't think the screenshot is relevant. That initramfs error is also shown in recovery mode.
It's pretty obivous that it's an AMD graphics driver issue in the kernel. Possibly I have defective hardware. This really has nothing to do with Ubuntu. As part of debugging I also tried installing Manjaro and that had similar issues.

Aleksandr Panzin (jalexoid) wrote :

@rmoisto - I have the same issue. It's not your system error, it's 5.8.0_25 + AMD driver issue.
5.4 kernel works well.

affects: linux → xf86-video-amd
calonfir (laurent1u) wrote :

Crash on startup same kernel, but with 20.04 lts. I had to reverse to linux kernel 5.4 to boot into system

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers