touchpad motion stops responding sporadically in 20.10 mate beta

Bug #1900168 reported by Jonathan Polak on 2020-10-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

a couple of minutes after boot, the touchpad stops responding (can't move the pointer, but the buttons are still responsive)

Machine: Thinkpad T460s
Kernel: 5.8.0-23-generic #24-Ubuntu
OS: Mate 20.10 beta

The Trackpoint (the nipple in the middle of the keyboard) and external mouse continue to function. The trackpoint however, moves much slower than usual.

EDIT:

Restarting lightdm.service fixes the problem temporarily. However, shortly after logging back in the touchpad stops responding again.
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu50
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jojo 10916 F.... pulseaudio
 /dev/snd/pcmC0D0c: jojo 10916 F...m pulseaudio
 /dev/snd/pcmC0D0p: jojo 10916 F...m pulseaudio
BootLog:

CasperMD5CheckResult: skip
CurrentDesktop: MATE
DistUpgraded: 2020-10-13 22:15:13,346 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: groovy
DistroRelease: Ubuntu 20.10
DistroVariant: ubuntu
HibernationDevice: RESUME=UUID=0310afeb-bdd2-440c-839e-bedbeef8ef14
InstallationDate: Installed on 2016-07-23 (1545 days ago)
InstallationMedia: Ubuntu-MATE 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: LENOVO 20F9004FUS
Package: xserver-xorg-input-synaptics 1.9.1-1ubuntu3
PackageArchitecture: amd64
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-23-generic root=UUID=074ff7b7-c074-4137-8cf7-d46cdd7dd723 ro quiet nosplash
ProcVersionSignature: Ubuntu 5.8.0-23.24-generic 5.8.14
RelatedPackageVersions:
 linux-restricted-modules-5.8.0-23-generic N/A
 linux-backports-modules-5.8.0-23-generic N/A
 linux-firmware 1.190
Tags: groovy ubuntu
Uname: Linux 5.8.0-23-generic x86_64
UpgradeStatus: Upgraded to groovy on 2020-10-14 (2 days ago)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare saned sudo vboxsf vboxusers wireshark
_MarkForUpload: True
dmi.bios.date: 10/30/2019
dmi.bios.release: 1.46
dmi.bios.vendor: LENOVO
dmi.bios.version: N1CET78W (1.46 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20F9004FUS
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40705 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.ec.firmware.release: 1.14
dmi.modalias: dmi:bvnLENOVO:bvrN1CET78W(1.46):bd10/30/2019:br1.46:efr1.14:svnLENOVO:pn20F9004FUS:pvrThinkPadT460s:rvnLENOVO:rn20F9004FUS:rvrSDK0J40705WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T460s
dmi.product.name: 20F9004FUS
dmi.product.sku: LENOVO_MT_20F9_BU_Think_FM_ThinkPad T460s
dmi.product.version: ThinkPad T460s
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.102-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.0-1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.2.0-1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200714-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu50
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jojo 1897 F.... pulseaudio
BootLog:

CasperMD5CheckResult: skip
CurrentDesktop: MATE
DistUpgraded: 2020-10-13 22:15:13,346 DEBUG Running PostInstallScript: './xorg_fix_proprietary.py'
DistroCodename: groovy
DistroRelease: Ubuntu 20.10
DistroVariant: ubuntu
HibernationDevice: RESUME=UUID=0310afeb-bdd2-440c-839e-bedbeef8ef14
InstallationDate: Installed on 2016-07-23 (1547 days ago)
InstallationMedia: Ubuntu-MATE 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: LENOVO 20F9004FUS
Package: xserver-xorg-input-synaptics 1.9.1-1ubuntu3
PackageArchitecture: amd64
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.8.0-23-generic root=UUID=074ff7b7-c074-4137-8cf7-d46cdd7dd723 ro quiet nosplash
ProcVersionSignature: Ubuntu 5.8.0-23.24-generic 5.8.14
PulseList:
 Error: command ['pacmd', 'list'] failed with exit code 1: XDG_RUNTIME_DIR (/run/user/1001) is not owned by us (uid 0), but by uid 1001! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)
 No PulseAudio daemon running, or not running as session daemon.
RelatedPackageVersions:
 linux-restricted-modules-5.8.0-23-generic N/A
 linux-backports-modules-5.8.0-23-generic N/A
 linux-firmware 1.190
Tags: groovy ubuntu
Uname: Linux 5.8.0-23-generic x86_64
UpgradeStatus: Upgraded to groovy on 2020-10-14 (4 days ago)
UserGroups: N/A
_MarkForUpload: True
dmi.bios.date: 10/30/2019
dmi.bios.release: 1.46
dmi.bios.vendor: LENOVO
dmi.bios.version: N1CET78W (1.46 )
dmi.board.asset.tag: Not Available
dmi.board.name: 20F9004FUS
dmi.board.vendor: LENOVO
dmi.board.version: SDK0J40705 WIN
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: None
dmi.ec.firmware.release: 1.14
dmi.modalias: dmi:bvnLENOVO:bvrN1CET78W(1.46):bd10/30/2019:br1.46:efr1.14:svnLENOVO:pn20F9004FUS:pvrThinkPadT460s:rvnLENOVO:rn20F9004FUS:rvrSDK0J40705WIN:cvnLENOVO:ct10:cvrNone:
dmi.product.family: ThinkPad T460s
dmi.product.name: 20F9004FUS
dmi.product.sku: LENOVO_MT_20F9_BU_Think_FM_ThinkPad T460s
dmi.product.version: ThinkPad T460s
dmi.sys.vendor: LENOVO
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.102-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 20.2.0-1
version.libgl1-mesa-glx: libgl1-mesa-glx 20.2.0-1
version.xserver-xorg-core: xserver-xorg-core 2:1.20.9-2ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.6-2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200714-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

Jonathan Polak (jpolak) wrote :
Jonathan Polak (jpolak) on 2020-10-16
description: updated
Norbert (nrbrtx) wrote :

Please run `apport-collect 1900168` to attach logs to the bug-report.

apport information

tags: added: apport-collected groovy ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Confirmed
Sai Vinoba (saivinoba) wrote :

I had similar issue on my HP laptop with elantech trackpad, where trackpad would not be responsive immediately after login. The buttons would still work, external (USB) mouse would also work.

In my case the fix was to remove synaptics driver and let libinput handle trackpad.

    sudo apt remove xserver-xorg-input-synaptics
    sudo apt install xserver-xorg-input-libinput

I also created a symlink for 40-libinput.conf in /etc/X11/xorg.conf.d although it may not be needed (not present in UM 20.04).

    sudo mkdir -p /etc/X11/xorg.conf.d
    sudo ln -s /usr/share/X11/xorg.conf.d/40-libinput.conf /etc/X11/xorg.conf.d/

A reboot was required for changes to take place properly.

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Jonathan Polak (jpolak) wrote :

I confirm that uninstalling the synaptics driver as per https://bugs.launchpad.net/ubuntu-mate/+bug/1900168/comments/32 fixes the issue. It is not necessary to add the symlinks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers