[i915] VGA resolution limited to 1024x768, EDID ignored or missing?

Bug #1899152 reported by SatishVSS on 2020-10-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Defaultly it is set to 1024x768. But my screen resolution is 1440x400.

I tried using terminal to add newmode and saved with the desired resolution. When I aplied the new one, the system gets hanged everytime.

Previuosly I used 14.04 version. Then there was no issue. I added newmode using terminal. And next it was fine.

But now it is not allowing me to set.

Please make this issue clear.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: xorg 1:7.7+19ubuntu14
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
NonfreeKernelModules: lkp_Ubuntu_5_4_0_42_46_generic_70
ApportVersion: 2.20.11-0ubuntu27.4
Architecture: amd64
BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
CasperMD5CheckResult: skip
CompositorRunning: None
CurrentDesktop: ubuntu:GNOME
Date: Fri Oct 9 16:03:45 2020
DistUpgraded: Fresh install
DistroCodename: focal
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 10) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2]
InstallationDate: Installed on 2020-10-02 (6 days ago)
InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
MachineType: OEM OEM
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_IN
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-42-generic root=UUID=948d3ae0-06d2-4522-8970-f6183d8b94fa ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/24/2018
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.chassis.type: 3
dmi.chassis.vendor: OEM
dmi.chassis.version: OEM
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd08/24/2018:svnOEM:pnOEM:pvrOEM:rvn:rn:rvr:cvnOEM:ct3:cvrOEM:
dmi.product.name: OEM
dmi.product.version: OEM
dmi.sys.vendor: OEM
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.101-2
version.libgl1-mesa-dri: libgl1-mesa-dri 20.0.8-0ubuntu1~20.04.1
version.libgl1-mesa-glx: libgl1-mesa-glx N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.20.8-2ubuntu2.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:19.1.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20200226-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.16-1

SatishVSS (sssatishv) wrote :
SatishVSS (sssatishv) on 2020-10-11
Changed in xorg (Ubuntu):
status: New → Invalid
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
summary: - Resolution not set or inappropriate
+ [intel G33] Resolution not set or inappropriate
summary: - [intel G33] Resolution not set or inappropriate
+ [intel G33] Resolution limited to 1024x768

It looks like the system can't get the screen resolution information from the monitor over the VGA connection. This might be a connection problem or it might be a kernel bug.

Please:

1. Run this command:

   grep . /sys/class/drm/*/modes > drmmodes.txt

   and attach the resulting text file here.

2. Try a different VGA cable if you can find one.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Invalid → New
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
  • drmmodes.txt Edit (41 bytes, text/plain; charset="US-ASCII"; name="drmmodes.txt")
Download full text (4.3 KiB)

Please find the attached file which you asked for.

My VGA Cable is working fine. Because I used Ubuntu 14.04 before and later
16.04. Those operating systems abled to display my desired resolution.
But after upgrading to 20.04, the issue rised.

It is so awkward to see the display at lowest resolution even having the
ability to give a better one.

Please show me proper solution.

On Thu, Nov 19, 2020 at 8:31 AM Daniel van Vugt <email address hidden>
wrote:

> It looks like the system can't get the screen resolution information
> from the monitor over the VGA connection. This might be a connection
> problem or it might be a kernel bug.
>
> Please:
>
> 1. Run this command:
>
> grep . /sys/class/drm/*/modes > drmmodes.txt
>
> and attach the resulting text file here.
>
> 2. Try a different VGA cable if you can find one.
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Invalid => New
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: New => Incomplete
>
> ** Also affects: linux (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Changed in: linux (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1899152
>
> Title:
> [intel G33] Resolution limited to 1024x768
>
> Status in linux package in Ubuntu:
> Incomplete
> Status in xserver-xorg-video-intel package in Ubuntu:
> Incomplete
>
> Bug description:
> Defaultly it is set to 1024x768. But my screen resolution is 1440x400.
>
> I tried using terminal to add newmode and saved with the desired
> resolution. When I aplied the new one, the system gets hanged
> everytime.
>
> Previuosly I used 14.04 version. Then there was no issue. I added
> newmode using terminal. And next it was fine.
>
> But now it is not allowing me to set.
>
> Please make this issue clear.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 20.04
> Package: xorg 1:7.7+19ubuntu14
> ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
> Uname: Linux 5.4.0-42-generic x86_64
> NonfreeKernelModules: lkp_Ubuntu_5_4_0_42_46_generic_70
> ApportVersion: 2.20.11-0ubuntu27.4
> Architecture: amd64
> BootLog: Error: [Errno 13] Permission denied: '/var/log/boot.log'
> CasperMD5CheckResult: skip
> CompositorRunning: None
> CurrentDesktop: ubuntu:GNOME
> Date: Fri Oct 9 16:03:45 2020
> DistUpgraded: Fresh install
> DistroCodename: focal
> DistroVariant: ubuntu
> GraphicsCard:
> Intel Corporation 82G33/G31 Express Integrated Graphics Controller
> [8086:29c2] (rev 10) (prog-if 00 [VGA controller])
> Subsystem: Intel Corporation 82G33/G31 Express Integrated Graphics
> Controller [8086:29c2]
> InstallationDate: Installed on 2020-10-02 (6 days ago)
> InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64
> (20200731)
> MachineType: OEM OEM
> ProcEnviron:
> LANGUAGE=en_IN:en
> PATH=(custom, no user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_IN
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-42-generic
> root=UUID=948d3ae0-06d2-4522-8970-f6183d8b94fa ro quiet splash...

Read more...

Thanks. Looks like this is a kernel bug.

Changed in linux (Ubuntu):
status: Incomplete → New
no longer affects: xserver-xorg-video-intel (Ubuntu)
summary: - [intel G33] Resolution limited to 1024x768
+ [i915] VGA resolution limited to 1024x768, EDID ignored or missing?
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1833855, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers