Intel x710 LOMs do not work on Focal

Bug #1893956 reported by Jeff Lane on 2020-09-02
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Jeff Lane
Focal
Medium
Jeff Lane

Bug Description

[IMPACT]
The Intel x710-TM4 is one of the latest 10GbE controllers from intel using the i40e driver. This particular 4 port comes in a 2x2 arrangement: 2x SFP+ and 2x RJ-45. This card is enabled in 5.4 via the inbox version of the i40e driver, and hwinfo does show both sides of the card but the kernel only sees the two SFP+ ports and cannot address or use the two copper ports.

These devices have up to 4 ports, but only two seem to work and this has been seen on at least two different systems using LOMs based on this.

This is currently blocking certification for one of our hardware partners.

[FIX]
This list of Patches enables the latest X710 controller fully:

* 3df5b9a6a9ec i40e: enable X710 support
* d80a476f4a12 i40e: Fix LED blinking flow for X710T*L devices

These are all clean cherry picks from 5.5 into 5.4

My tree with these can be found here:
https://code.launchpad.net/~bladernr/ubuntu/+source/linux/+git/focal/+ref/1893956-update-i40e-intel-lom

[TESTCASE]

i40e should load successfully, all ports on Carlsville x710 LOM should be visible, configurable, and can pass traffic at full speed.

Test kernels have been verified by the vendor reporting the issue that all network ports on the LOM are accessible and pass traffic at expected speeds.

[REGRESSION RISK]
Possible problem could be if the LED patch causes LEDs to not function correctly (or not at all) but the risk for this is pretty low.

CVE References

Jeff Lane (bladernr) on 2020-09-02
Changed in linux (Ubuntu Focal):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Jeff Lane (bladernr)
Jeff Lane (bladernr) on 2020-09-02
description: updated
Jeff Lane (bladernr) on 2020-09-02
Changed in linux (Ubuntu Focal):
status: Confirmed → In Progress
Jeff Lane (bladernr) on 2020-09-03
tags: added: blocks-hwcert-server
Jeff Lane (bladernr) on 2020-09-09
description: updated
description: updated
Jeff Lane (bladernr) on 2020-09-16
description: updated
description: updated
Jeff Lane (bladernr) on 2020-09-16
summary: - Intel NIC LOMs do not work on Focal
+ Intel x710 LOMs do not work on Focal
Jeff Lane (bladernr) on 2020-09-16
description: updated
Jeff Lane (bladernr) on 2020-09-16
description: updated
description: updated
Stefan Bader (smb) wrote :

Setting the devel task to invalid as changes from 5.5 would be included (Groovy is using 5.8).

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Jeff Lane (bladernr) on 2020-09-17
description: updated
Ian (ian-may) on 2020-09-17
Changed in linux (Ubuntu Focal):
status: In Progress → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Ian (ian-may) wrote :

Hi Jeff,

We are working to get verification testing completed, would you be able to confirm this issue is resolved in Focal 5.4.0-49.53?

Thanks,
Ian

Download full text (3.1 KiB)

Thanks Ian. I’ve pinged them again to test the proposed kernel.
Unfortunately I do not have the hardware myself, otherwise I’d just do it.

On Tue, Oct 6, 2020 at 16:50 Ian <email address hidden> wrote:

> Hi Jeff,
>
> We are working to get verification testing completed, would you be able
> to confirm this issue is resolved in Focal 5.4.0-49.53?
>
> Thanks,
> Ian
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1893956
>
> Title:
> Intel x710 LOMs do not work on Focal
>
> Status in linux package in Ubuntu:
> Invalid
> Status in linux source package in Focal:
> Fix Committed
>
> Bug description:
> [IMPACT]
> The Intel x710-TM4 is one of the latest 10GbE controllers from intel
> using the i40e driver. This particular 4 port comes in a 2x2 arrangement:
> 2x SFP+ and 2x RJ-45. This card is enabled in 5.4 via the inbox version of
> the i40e driver, and hwinfo does show both sides of the card but the kernel
> only sees the two SFP+ ports and cannot address or use the two copper ports.
>
> These devices have up to 4 ports, but only two seem to work and this
> has been seen on at least two different systems using LOMs based on
> this.
>
> This is currently blocking certification for one of our hardware
> partners.
>
> [FIX]
> This list of Patches enables the latest X710 controller fully:
>
> * 3df5b9a6a9ec i40e: enable X710 support
> * d80a476f4a12 i40e: Fix LED blinking flow for X710T*L devices
>
> These are all clean cherry picks from 5.5 into 5.4
>
> My tree with these can be found here:
>
> https://code.launchpad.net/~bladernr/ubuntu/+source/linux/+git/focal/+ref/1893956-update-i40e-intel-lom
>
> [TESTCASE]
>
> i40e should load successfully, all ports on Carlsville x710 LOM should
> be visible, configurable, and can pass traffic at full speed.
>
> Test kernels have been verified by the vendor reporting the issue that
> all network ports on the LOM are accessible and pass traffic at
> expected speeds.
>
> [REGRESSION RISK]
> Possible problem could be if the LED patch causes LEDs to not function
> correctly (or not at all) but the risk for this is pretty low.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1893956/+subscriptions
>
> Launchpad-Notification-Type: bug
> Launchpad-Bug: distribution=ubuntu; sourcepackage=linux; component=main;
> status=Invalid; importance=Medium; <email address hidden>;
> Launchpad-Bug: distribution=ubuntu; distroseries=focal;
> sourcepackage=linux; component=main; status=Fix Committed;
> importance=Medium; <email address hidden>;
> Launchpad-Bug-Tags: blocks-hwcert-server verification-needed-focal
> Launchpad-Bug-Information-Type: Public
> Launchpad-Bug-Private: no
> Launchpad-Bug-Security-Vulnerability: no
> Launchpad-Bug-Commenters: bladernr ian-may smb ubuntu-kernel-bot
> Launchpad-Bug-Reporter: Jeff Lane (bladernr)
> Launchpad-Bug-Modifier: Ian (ian-may)
> Launchpad-Message-Rationale: Subscriber
> Launchpad-Message-For: bladernr
>
--
Sent from my iPhone so please forgive any typos, top posting and such....

Read more...

Jeff Lane (bladernr) wrote :

Hi... Verification done. Thanks

tags: added: verification-done-focal
removed: blocks-hwcert-server verification-needed-focal
Launchpad Janitor (janitor) wrote :
Download full text (31.2 KiB)

This bug was fixed in the package linux - 5.4.0-51.56

---------------
linux (5.4.0-51.56) focal; urgency=medium

  * Packaging resync (LP: #1786013)
    - update dkms package versions

linux (5.4.0-50.55) focal; urgency=medium

  * CVE-2020-16119
    - SAUCE: dccp: avoid double free of ccid on child socket

  * CVE-2020-16120
    - Revert "UBUNTU: SAUCE: overlayfs: ensure mounter privileges when reading
      directories"
    - ovl: pass correct flags for opening real directory
    - ovl: switch to mounter creds in readdir
    - ovl: verify permissions in ovl_path_open()
    - ovl: call secutiry hook in ovl_real_ioctl()
    - ovl: check permission to open real file

linux (5.4.0-49.53) focal; urgency=medium

  * focal/linux: 5.4.0-49.53 -proposed tracker (LP: #1896007)

  * Comet Lake PCH-H RAID not support on Ubuntu20.04 (LP: #1892288)
    - ahci: Add Intel Comet Lake PCH-H PCI ID

  * Novalink (mkvterm command failure) (LP: #1892546)
    - tty: hvcs: Don't NULL tty->driver_data until hvcs_cleanup()

  * Oops and hang when starting LVM snapshots on 5.4.0-47 (LP: #1894780)
    - SAUCE: Revert "mm: memcg/slab: fix memory leak at non-root kmem_cache
      destroy"

  * Intel x710 LOMs do not work on Focal (LP: #1893956)
    - i40e: Fix LED blinking flow for X710T*L devices
    - i40e: enable X710 support

  * Add/Backport EPYC-v3 and EPYC-Rome CPU model (LP: #1887490)
    - kvm: svm: Update svm_xsaves_supported

  * Fix non-working NVMe after S3 (LP: #1895718)
    - SAUCE: PCI: Enable ACS quirk on CML root port

  * Focal update: v5.4.65 upstream stable release (LP: #1895881)
    - ipv4: Silence suspicious RCU usage warning
    - ipv6: Fix sysctl max for fib_multipath_hash_policy
    - netlabel: fix problems with mapping removal
    - net: usb: dm9601: Add USB ID of Keenetic Plus DSL
    - sctp: not disable bh in the whole sctp_get_port_local()
    - taprio: Fix using wrong queues in gate mask
    - tipc: fix shutdown() of connectionless socket
    - net: disable netpoll on fresh napis
    - Linux 5.4.65

  * Focal update: v5.4.64 upstream stable release (LP: #1895880)
    - HID: quirks: Always poll three more Lenovo PixArt mice
    - drm/msm/dpu: Fix scale params in plane validation
    - tty: serial: qcom_geni_serial: Drop __init from qcom_geni_console_setup
    - drm/msm: add shutdown support for display platform_driver
    - hwmon: (applesmc) check status earlier.
    - nvmet: Disable keep-alive timer when kato is cleared to 0h
    - drm/msm: enable vblank during atomic commits
    - habanalabs: validate FW file size
    - habanalabs: check correct vmalloc return code
    - drm/msm/a6xx: fix gmu start on newer firmware
    - ceph: don't allow setlease on cephfs
    - drm/omap: fix incorrect lock state
    - cpuidle: Fixup IRQ state
    - nbd: restore default timeout when setting it to zero
    - s390: don't trace preemption in percpu macros
    - drm/amd/display: Reject overlay plane configurations in multi-display
      scenarios
    - drivers: gpu: amd: Initialize amdgpu_dm_backlight_caps object to 0 in
      amdgpu_dm_update_backlight_caps
    - drm/amd/display: Retry AUX write when fail occurs
    - drm/amd/display: Fix memleak in amdg...

Changed in linux (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers