[Dell Inspiron 3793] Screen brightness missing

Bug #1893568 reported by corrado venturini on 2020-08-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

gnome-control-center - power - Screen brightness is missing.
also on top bar Screen brightness control appears but does nothing.
the problem does not happen on same PC, different partition with Ubuntu 20.04

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: gnome-control-center 1:3.37.90-1ubuntu2
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.11-0ubuntu45
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Aug 30 19:47:23 2020
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2020-08-28 (2 days ago)
InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200826)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu45
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: corrado 1277 F.... pulseaudio
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 20.10
InstallationDate: Installed on 2020-08-28 (3 days ago)
InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200826)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 0bda:5520 Realtek Semiconductor Corp. Integrated_Webcam_HD
 Bus 001 Device 002: ID 145f:02a9 Trust Trust Wireless Mouse
 Bus 001 Device 004: ID 0cf3:e009 Qualcomm Atheros Communications
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Inspiron 3793
Package: linux (not installed)
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-42-generic root=UUID=5266d63d-2387-4de3-8bae-6c9f95af7d6e ro quiet splash
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
RelatedPackageVersions:
 linux-restricted-modules-5.4.0-42-generic N/A
 linux-backports-modules-5.4.0-42-generic N/A
 linux-firmware 1.190
Tags: groovy
Uname: Linux 5.4.0-42-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/17/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.5.0
dmi.board.name: 0C1PF2
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.5.0:bd12/17/2019:svnDellInc.:pnInspiron3793:pvr:rvnDellInc.:rn0C1PF2:rvrA00:cvnDellInc.:ct10:cvr:
dmi.product.family: Inspiron
dmi.product.name: Inspiron 3793
dmi.product.sku: 097A
dmi.sys.vendor: Dell Inc.

Daniel van Vugt (vanvugt) wrote :

Please tell us the model of machine this is.

Please also tell us what files, if any, you can find in /sys/class/backlight/

affects: gnome-control-center (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: New → Incomplete

corrado@corrado-n3-gg-0826:~$ ls /sys/class/backlight/
intel_backlight
corrado@corrado-n3-gg-0826:~$ cd intel_backlight
bash: cd: intel_backlight: No such file or directory
corrado@corrado-n3-gg-0826:~$ cd /sys/class/backlight/
corrado@corrado-n3-gg-0826:/sys/class/backlight$ ls
intel_backlight
corrado@corrado-n3-gg-0826:/sys/class/backlight$ cd intel_backlight
corrado@corrado-n3-gg-0826:/sys/class/backlight/intel_backlight$ ls
actual_brightness bl_power brightness device max_brightness power scale subsystem type uevent
corrado@corrado-n3-gg-0826:/sys/class/backlight/intel_backlight$ inxi -SCGx
System: Host: corrado-n3-gg-0826 Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: N/A
           Distro: Ubuntu 20.10 (Groovy Gorilla)
CPU: Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake rev: 5 L2 cache: 6144 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19046
           Speed: 555 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1029 2: 1851 3: 1482 4: 3015 5: 1953 6: 1549 7: 2231
           8: 3061
Graphics: Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
           Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-6:3
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 20.1.5 direct render: Yes
corrado@corrado-n3-gg-0826:/sys/class/backlight/intel_backlight$

thanks, let me know if this info is sufficient

Daniel van Vugt (vanvugt) wrote :

Thanks. It looks like a Dell, but what model of Dell?

Please try running this command and tell us what it returns:

  sudo dmidecode -t1

Yes, is a Dell

corrado@corrado-n3-gg-0826:~$ sudo dmidecode -t1
[sudo] password for corrado:
# dmidecode 3.2
Getting SMBIOS data from sysfs.
SMBIOS 3.1 present.

Handle 0x0100, DMI type 1, 27 bytes
System Information
 Manufacturer: Dell Inc.
 Product Name: Inspiron 3793
 Version: Not Specified
 Serial Number: H08YC33
 UUID: 4c4c4544-0030-3810-8059-c8c04f433333
 Wake-up Type: Power Switch
 SKU Number: 097A
 Family: Inspiron

corrado@corrado-n3-gg-0826:~$ inxi -Fx
System: Host: corrado-n3-gg-0826 Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 9.3.0
           Desktop: N/A Distro: Ubuntu 20.10 (Groovy Gorilla)
Machine: Type: Laptop System: Dell product: Inspiron 3793 v: N/A serial: <superuser/root required>
           Mobo: Dell model: 0C1PF2 v: A00 serial: <superuser/root required> UEFI: Dell v: 1.5.0
           date: 12/17/2019
Battery: ID-1: BAT0 charge: 22.7 Wh condition: 37.1/42.0 Wh (88%) model: SWD-ATL3.618 DELL WJPC403
           status: Discharging
CPU: Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake rev: 5
           L2 cache: 6144 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19046
           Speed: 590 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1786 2: 860 3: 1298 4: 2789
           5: 788 6: 934 7: 2009 8: 2887
Graphics: Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
           Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-6:3
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 20.1.5 direct render: Yes
Audio: Device-1: Intel Smart Sound Audio vendor: Dell driver: snd_hda_intel v: kernel
           bus ID: 00:1f.3
           Sound Server: ALSA v: k5.4.0-42-generic
Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell driver: r8169 v: kernel
           port: 3000 bus ID: 01:00.0
           IF: enp1s0 state: down mac: 98:e7:43:59:19:19
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Dell
           driver: ath10k_pci v: kernel port: 3000 bus ID: 02:00.0
           IF: wlp2s0 state: up mac: d8:12:65:b8:21:b9
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-10:4
Drives: Local Storage: total: 476.94 GiB used: 8.56 GiB (1.8%)
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNS512G NVMe KIOXIA 512GB size: 476.94 GiB
Partition: ID-1: / size: 31.25 GiB used: 8.52 GiB (27.3%) fs: ext4 dev: /dev/nvme0n1p3
Swap: ID-1: swap-1 type: partition size: 8.00 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p2
Sensors: System Temperatures: cpu: 27.8 C mobo: N/A
           Fan Speeds (RPM): cpu: 0
Info: Processes: 248 Uptime: 3m Memory: 7.55 GiB used: 1.28 GiB (16.9%) Init: systemd runlevel: 5
           Compilers: gcc: N/A Packages: 1810 Shell: Bash v: 5.0.17 inxi: 3.1.06
corrado@corrado-n3-gg-0826:~$

summary: - Screen brightness missing
+ [Dell Inspiron 3793] Screen brightness missing
Changed in linux (Ubuntu):
status: Incomplete → New

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1893568

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Running apport-collect i got an error, but apport informations seems ok:

1st lines of the crash i had:

ProblemType: Crash
CurrentDesktop: ubuntu:GNOME
Date: Tue Sep 1 08:31:57 2020
ExecutablePath: /usr/share/apport/dump_acpi_tables.py
ExecutableTimestamp: 1598482622
InterpreterPath: /usr/bin/python3.8
ProcCmdline: /usr/bin/python3 /usr/share/apport/dump_acpi_tables.py
ProcCwd: /home/corrado
ProcEnviron:
 LC_TIME=it_IT.UTF-8
 LC_MONETARY=it_IT.UTF-8
 TERM=xterm-256color
 PATH=(custom, no user)
 LC_ADDRESS=it_IT.UTF-8
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 LC_TELEPHONE=it_IT.UTF-8
 SHELL=/bin/bash
 LC_NAME=it_IT.UTF-8
 LC_MEASUREMENT=it_IT.UTF-8
 LC_IDENTIFICATION=it_IT.UTF-8
 LC_NUMERIC=it_IT.UTF-8
 LC_PAPER=it_IT.UTF-8
 LC_MESSAGES=C

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Problem does not occurs in a new install on same PC from new ISO Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200905)

Daniel van Vugt (vanvugt) wrote :

Please try updating that same system:

  sudo apt update
  sudo apt full-upgrade

If the problem returns then we can reopen this bug. Otherwise we'll consider it fixed.

I expect this was fixed with the introduction of kernel 5.8 recently.

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
Download full text (3.6 KiB)

Problem remains after updates an reboot, also with new kernel 5.8.
let me know if i must rerun apport-collect

corrado@corrado-n3-gg-0826:~$ sudo apt update && sudo apt full-upgrade
[sudo] password for corrado:
Get:1 http://archive.ubuntu.com/ubuntu groovy InRelease [267 kB]
Hit:2 http://archive.ubuntu.com/ubuntu groovy-updates InRelease
Hit:3 http://archive.ubuntu.com/ubuntu groovy-backports InRelease
Hit:4 http://archive.ubuntu.com/ubuntu groovy-security InRelease
Fetched 267 kB in 1s (241 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
  libilmbase24
Use 'sudo apt autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
corrado@corrado-n3-gg-0826:~$ inxi -Fx
System: Host: corrado-n3-gg-0826 Kernel: 5.8.0-18-generic x86_64 bits: 64
           compiler: N/A Desktop: N/A Distro: Ubuntu 20.10 (Groovy Gorilla)
Machine: Type: Laptop System: Dell product: Inspiron 3793 v: N/A
           serial: <superuser/root required>
           Mobo: Dell model: 0C1PF2 v: A00 serial: <superuser/root required> UEFI: Dell
           v: 1.5.0 date: 12/17/2019
Battery: ID-1: BAT0 charge: 26.2 Wh condition: 37.1/42.0 Wh (88%)
           model: SWD-ATL3.618 DELL WJPC403 status: Discharging
CPU: Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP
           arch: Ice Lake rev: 5 L2 cache: 6144 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
           bogomips: 19046
           Speed: 645 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1848 2: 3604
           3: 2377 4: 3310 5: 3605 6: 1589 7: 3589 8: 3567
Graphics: Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
           bus ID: 00:02.0
           Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
           bus ID: 1-6:3
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 20.1.5
           direct render: Yes
Audio: Device-1: Intel Smart Sound Audio vendor: Dell driver: snd_hda_intel
           v: kernel bus ID: 00:1f.3
           Sound Server: ALSA v: k5.8.0-18-generic
Network: Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Dell
           driver: r8169 v: kernel port: 3000 bus ID: 01:00.0
           IF: enp1s0 state: down mac: 98:e7:43:59:19:19
           Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
           vendor: Dell driver: ath10k_pci v: kernel port: 3000 bus ID: 02:00.0
           IF: wlp2s0 state: up mac: d8:12:65:b8:21:b9
           Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-10:4
Drives: Local Storage: total: 476.94 GiB used: 12.74 GiB (2.7%)
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG40ZNS512G NVMe KIOXIA 512GB
           size: 476.94 GiB...

Read more...

Changed in linux (Ubuntu):
status: Fix Released → New

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

I have the same problem also ob a different partition of same PC with Groovy installed from Ubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200714)

mao@corrado-n7-gg-0714:~$ inxi -SCMx
System: Host: corrado-n7-gg-0714 Kernel: 5.8.0-18-generic x86_64 bits: 64 compiler: N/A Desktop: N/A
           Distro: Ubuntu 20.10 (Groovy Gorilla)
Machine: Type: Laptop System: Dell product: Inspiron 3793 v: N/A serial: <superuser/root required>
           Mobo: Dell model: 0C1PF2 v: A00 serial: <superuser/root required> UEFI: Dell v: 1.5.0
           date: 12/17/2019
CPU: Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP arch: Ice Lake rev: 5
           L2 cache: 6144 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19046
           Speed: 1834 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 2946 2: 708 3: 2539 4: 1143
           5: 3355 6: 2893 7: 1421 8: 1683
mao@corrado-n7-gg-0714:~$

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers