MGA G200e doesn't work under GDM Wayland

Bug #1886140 reported by jeremyszu
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

[Description]
The drm_vram_helper crash when launching display manager with MGA G200e.

[Steps to reproduce]
0. Connect to a monitor via VGA
1. Install focal desktop image (5.4.0-21-generic)
2. Power on system and boot to multi-user.target
3. systemctl isolate graphical.target

[Expect result]
System launch GDM without problems

[Actual result]
System hang and monitor keep purple screen

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: linux-image-5.4.0-40-generic 5.4.0-40.44
ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
Uname: Linux 5.4.0-40-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
CasperMD5CheckResult: skip
Date: Fri Jul 3 13:27:53 2020
InstallationDate: Installed on 2020-07-03 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
MachineType: Lenovo ThinkSystem ST250 -[7Y45CTO1WW]-
ProcFB: 0 mgag200drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-40-generic root=UUID=68fd62d3-1204-4f51-a3b4-b35919882e7f ro systemd.unit=multi-user.target quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-5.4.0-40-generic N/A
 linux-backports-modules-5.4.0-40-generic N/A
 linux-firmware 1.187
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/24/2020
dmi.bios.vendor: Lenovo
dmi.bios.version: -[ISE116D-2.10]-
dmi.board.asset.tag: none
dmi.board.name: -[7Y45CTO1WW]-
dmi.board.vendor: Lenovo
dmi.board.version: none
dmi.chassis.asset.tag: none
dmi.chassis.type: 7
dmi.chassis.vendor: Lenovo
dmi.chassis.version: none
dmi.modalias: dmi:bvnLenovo:bvr-[ISE116D-2.10]-:bd04/24/2020:svnLenovo:pnThinkSystemST250-[7Y45CTO1WW]-:pvr03:rvnLenovo:rn-[7Y45CTO1WW]-:rvrnone:cvnLenovo:ct7:cvrnone:
dmi.product.family: ThinkSystem
dmi.product.name: ThinkSystem ST250 -[7Y45CTO1WW]-
dmi.product.sku: 7Y45CTO1WW
dmi.product.version: 03
dmi.sys.vendor: Lenovo

Revision history for this message
jeremyszu (os369510) wrote :
jeremyszu (os369510)
summary: - drm_vram_helper crash when launching DM with MGA G200e
+ drm_vram_helper crash when launching graphical.target with MGA G200e
Revision history for this message
jeremyszu (os369510) wrote : Re: drm_vram_helper crash when launching graphical.target with MGA G200e

BTW, it's certified in xenial[1].

I tried bionic desktop and it works good.

[1] https://certification.ubuntu.com/hardware/201811-26640

Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :
summary: - drm_vram_helper crash when launching graphical.target with MGA G200e
+ MGA G200e doesn't work under GDM Wayland
Revision history for this message
jeremyszu (os369510) wrote :
Download full text (4.9 KiB)

@Kai-Heng,

Thank you for your help.
I'd tried your test kernel but got the error:

...
 七 06 13:17:53 u-03 kernel: [drm] Initialized mgag200 1.0.0 20110418 for 0000:02:00.0 on minor 0
 七 06 13:17:53 u-03 kernel: fbcon: mgag200drmfb (fb0) is primary device
 七 06 13:17:53 u-03 kernel: Console: switching to colour frame buffer device 210x65
 七 06 13:17:53 u-03 kernel: mgag200 0000:02:00.0: fb0: mgag200drmfb frame buffer device
...
 七 06 13:17:54 u-03 kernel: ------------[ cut here ]------------
 七 06 13:17:54 u-03 kernel: WARNING: CPU: 5 PID: 158 at /home/khfeng/Sources/linux-lp1886140-mgag200/drivers/gpu/drm/drm_atomic_helper.c:2284 drm_atomic_helper_commit_hw_done+0x112/0x130 [drm_kms_helper]
 七 06 13:17:54 u-03 kernel: Modules linked in: fjes(-) ipmi_ssif intel_rapl_msr intel_rapl_common x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel kvm crct10dif_pclmul mgag200 ghash_clmulni_intel drm_kms_helper aesni_intel crypto_simd cec cryptd rc_core glue_helper i2c_algo_bit cdc_ether fb_sys_fops intel_cstate syscopyarea usbnet mei_me sysfillrect input_leds wmi_bmof mii sysimgblt intel_rapl_perf 8250_dw mei intel_pch_thermal ie31200_edac ipmi_si acpi_tad ipmi_devintf ipmi_msghandler mac_hid acpi_power_meter acpi_pad sch_fq_codel parport_pc ppdev lp parport drm ip_tables x_tables autofs4 uas usb_storage hid_generic usbhid hid crc32_pclmul ahci intel_lpss_pci tg3 intel_lpss i2c_i801 libahci idma64 virt_dma wmi pinctrl_cannonlake video pinctrl_intel
 七 06 13:17:54 u-03 kernel: CPU: 5 PID: 158 Comm: kworker/5:1 Not tainted 5.6.0-1019-oem #19lp1884288
 七 06 13:17:54 u-03 kernel: Hardware name: Lenovo ThinkSystem ST250 -[7Y45CTO1WW]-/-[7Y45CTO1WW]-, BIOS -[ISE116D-2.10]- 04/24/2020
 七 06 13:17:54 u-03 kernel: Workqueue: events console_callback
 七 06 13:17:54 u-03 kernel: RIP: 0010:drm_atomic_helper_commit_hw_done+0x112/0x130 [drm_kms_helper]
 七 06 13:17:54 u-03 kernel: Code: 5b 41 5c 41 5d 41 5e 41 5f 5d c3 e8 18 07 81 ff eb 87 be 01 00 00 00 e8 3c 91 eb ef eb 94 be 02 00 00 00 e8 30 91 eb ef eb 88 <0f> 0b eb 95 be 03 00 00 00 e8 20 91 eb ef e9 5c ff ff ff 90 66 2e
 七 06 13:17:54 u-03 kernel: RSP: 0018:ffffaa7780473a98 EFLAGS: 00010286
 七 06 13:17:54 u-03 kernel: RAX: 0000000000000006 RBX: ffff90f51a6cccc0 RCX: ffff90f527804800
 七 06 13:17:54 u-03 kernel: RDX: ffff90f527a1fd00 RSI: ffff90f51a6cc6c0 RDI: ffff90f51a6cccc8
 七 06 13:17:54 u-03 kernel: RBP: ffffaa7780473ac0 R08: 00000000000000b0 R09: 000000000000000a
 七 06 13:17:54 u-03 kernel: R10: 00000000000000b0 R11: 00000000000331c0 R12: 0000000000000000
 七 06 13:17:54 u-03 kernel: R13: ffff90f526fccc00 R14: ffff90f520ff4380 R15: ffff90f524d35600
 七 06 13:17:54 u-03 kernel: FS: 0000000000000000(0000) GS:ffff90f52eb40000(0000) knlGS:0000000000000000
 七 06 13:17:54 u-03 kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
 七 06 13:17:54 u-03 kernel: CR2: 000000c42036af68 CR3: 0000000a5500a003 CR4: 00000000003606e0
 七 06 13:17:54 u-03 kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
 七 06 13:17:54 u-03 kernel: DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
 七 06 13:17:54 u-03 kernel: Call Trace:
 七 06 13:17:54 u-03 kernel: drm_...

Read more...

Revision history for this message
Kai-Heng Feng (kaihengfeng) wrote :

This means we also need to backport DRM bits to 5.6, which is not really feasible.

5.8 backport:
https://people.canonical.com/~khfeng/lp1886140-5.8/

Revision history for this message
jeremyszu (os369510) wrote :

The kernel from comment#6 works for me, thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.8.0-16.17

---------------
linux (5.8.0-16.17) groovy; urgency=medium

  * groovy/linux: 5.8.0-16.17 -proposed tracker (LP: #1891233)

  * Miscellaneous Ubuntu changes
    - hio -- Update to use bio_{start,end}_io_acct with 5.8+
    - Enable hio driver
    - [Packaging] Temporarily disable building doc package contents

linux (5.8.0-15.16) groovy; urgency=medium

  * groovy/linux: 5.8.0-15.16 -proposed tracker (LP: #1891177)

  * Miscellaneous Ubuntu changes
    - SAUCE: Documentation: import error c_funcptr_sig_re, c_sig_re (sphinx-
      doc/sphinx@0f49e30c)

linux (5.8.0-14.15) groovy; urgency=medium

  * groovy/linux: 5.8.0-14.15 -proposed tracker (LP: #1891085)

  * Packaging resync (LP: #1786013)
    - [Packaging] update helper scripts

  * msg_zerocopy.sh in net from ubuntu_kernel_selftests failed (LP: #1812620)
    - selftests/net: relax cpu affinity requirement in msg_zerocopy test

  * Fix missing HDMI/DP Audio on an HP Desktop (LP: #1890441)
    - ALSA: hda/hdmi: Add quirk to force connectivity

  * Add initial audio support for Lenovo ThinkStation P620 (LP: #1890317)
    - ALSA: usb-audio: Add support for Lenovo ThinkStation P620

  * Fix IOMMU error on AMD Radeon Pro W5700 (LP: #1890306)
    - PCI: Mark AMD Navi10 GPU rev 0x00 ATS as broken

  * Enlarge hisi_sec2 capability (LP: #1890222)
    - crypto: hisilicon - update SEC driver module parameter

  * Miscellaneous Ubuntu changes
    - [Config] Re-enable signing for ppc64el

 -- Seth Forshee <email address hidden> Tue, 11 Aug 2020 15:32:58 -0500

Changed in linux (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers