Suspend to RAM fails on sony vaio vgn sz483n

Bug #188455 reported by S V N Vishwanathan on 2008-02-02
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned
linux-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: linux-source

I am running the Alpha-4 release of 8.10 (the same behavior was observed in 7.10 and Alpha-3 release of 8.10) on my sony vaio vgn sz483n laptop. It has a selection switch to toggle between speed and stamina mode.

Suspend to RAM works like a charm when I select the stamina mode. But when I select the speed switch (which uses the nvidia graphics card) suspend to RAM does not work. The machine suspends properly and the power light becomes orange as expected. When I press any key it also looks like it resumes but the LCD screen remains blank.

I am running the open source "nv" drivers. I have tried various things including passing agp=off to the boot options and passing various quirk flags to the pm-suspend script. None of them worked unfortunately :(

I am attaching outputs of various commands.

Please let me know if you need any more information or if you need me to try out something.

S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :
S V N Vishwanathan (vishketan) wrote :

Update: After installing to the hard disk, using the workarounds suggested in https://help.ubuntu.com/community/NvidiaLaptopBinaryDriverSuspend hibernate works with Ubuntu 7.10

To get suspend to RAM to work I needed to compile the 2.6.24 kernel and install it. Once this is done suspend to RAM works but the wifi drivers and the alsa drivers don't work :(

I suspect once Hardy 8.04 is out (with the latest 2.6.24 kernel) this problem will be fixed. Therefore this bug can be closed.

S V N Vishwanathan (vishketan) wrote :

Suspend works on 8.04 alpha 5 with the following tweaks:

After installing restricted nvidia drivers

1) add NvAGP 1 option to xorg.conf as suggested here https://wiki.ubuntu.com/NvidiaLaptopBinaryDriverSuspend

2) create a file /etc/pm/config.d/unload_modules
and write into it
SUSPEND_MODULES="uvcvideo"
then chmod +x unload_modules

But there is still one minor outstanding issue. If I do the following

login
suspend (a few times)
logout

the screen becomes completely garbled.

Hi,

Thanks for testing and the updates. I believe the uvcvideo module Suspend issue is being addressed here: https://bugs.launchpad.net/ubuntu/+bug/147757. If you don't mind, care to keep testing the latest Hardy Alpha releases as they come out and giving quick updates here and see if that last issue ever gets resolved. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-acpi
importance: Undecided → Medium
status: New → Triaged
S V N Vishwanathan (vishketan) wrote :

Hi!

I will test once the next alpha is out and report.

thanks

S V N Vishwanathan (vishketan) wrote :

Hi Leann,

I tested with the latest Beta with all the latest updates. The problem with uvcvideo seems to have gone but there is still a problem with suspend and resume. The problematic modules now are uhci_hcd and ehci_hcd which prevent suspend/resume. Let me know if you need any further information.

vishy

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Hi vishy,

Just curious if you've been able to test Intrepid and if you still have suspend issues? Also, I'm going to close the linux-meta task since the linux task is adequate for this bug. Thanks.

Changed in linux:
status: Triaged → Incomplete
Changed in linux-meta:
status: New → Invalid

Hi leann

I don't have any suspend issues even with Hardy if I suspend some modules in my pm_suspend configuration. It worked very reliably. I am yet to update to Intrepid and check. The bug can be safely closed.

See https://wiki.kubuntu.org/LaptopTestingTeam/SonyVaioVGN-SZ483N for details.

vishy

Thanks Vishy, I'll go ahead and close this.

Changed in linux:
status: Incomplete → Fix Released
Curtis Hovey (sinzui) on 2012-04-09
Changed in linux (Ubuntu):
assignee: Registry Administrators (registry) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers