CPU stuck for 22s

Bug #1883012 reported by Stefano on 2020-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-440 (Ubuntu)
Undecided
Unassigned

Bug Description

I get regularly system freezes, so that nothing works anymore. The only thing I can do, is a hard reset.
These are the last kernel logs:

Jun 10 21:34:47 stefano-linux anacron[6995]: Anacron 2.3 started on 2020-06-10
Jun 10 21:34:47 stefano-linux anacron[6995]: Normal exit (0 jobs run)
Jun 10 21:35:41 stefano-linux rtkit-daemon[1169]: Supervising 12 threads of 8 processes of 2 users.
Jun 10 21:35:41 stefano-linux rtkit-daemon[1169]: Supervising 12 threads of 8 processes of 2 users.
Jun 10 21:39:03 stefano-linux gnome-shell[2281]: ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
Jun 10 21:39:16 stefano-linux gnome-shell[2281]: ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
Jun 10 21:42:43 stefano-linux gnome-shell[2281]: ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
Jun 10 21:42:57 stefano-linux gnome-shell[2281]: ###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
Jun 10 21:47:41 stefano-linux kernel: watchdog: BUG: soft lockup - CPU#1 stuck for 22s! [JS Helper:2153]
Jun 10 21:47:41 stefano-linux kernel: Modules linked in: snd_usb_audio snd_usbmidi_lib gspca_vc032x uvcvideo gspca_main videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common videodev mc snd_hda_codec_hdmi edac_mce_amd kvm_amd kvm nvidia_uvm(O) nvidia_drm(PO) nvidia_modeset(>
Jun 10 21:47:41 stefano-linux kernel: CPU: 1 PID: 2153 Comm: JS Helper Tainted: P O 5.4.0-37-generic #41-Ubuntu
Jun 10 21:47:41 stefano-linux kernel: Hardware name: System manufacturer System Product Name/PRIME B350-PLUS, BIOS 5407 12/31/2019
Jun 10 21:47:41 stefano-linux kernel: RIP: 0010:smp_call_function_many+0x203/0x270
Jun 10 21:47:41 stefano-linux kernel: Code: 73 08 e8 90 0e 96 00 3b 05 5e d4 6f 01 89 c7 0f 83 9b fe ff ff 48 63 c7 48 8b 0b 48 03 0c c5 80 59 04 9e 8b 41 18 a8 01 74 0a <f3> 90 8b 51 18 83 e2 01 75 f6 eb c8 89 cf 48 c7 c2 60 ae 44 9e 4c
Jun 10 21:47:41 stefano-linux kernel: RSP: 0018:ffff98bc02edbb58 EFLAGS: 00000202 ORIG_RAX: ffffffffffffff13
Jun 10 21:47:41 stefano-linux kernel: RAX: 0000000000000003 RBX: ffff8890ce86bc80 RCX: ffffb8bbfe817680
Jun 10 21:47:41 stefano-linux kernel: RDX: 0000000000000001 RSI: 0000000000000000 RDI: 0000000000000008
Jun 10 21:47:41 stefano-linux kernel: RBP: ffff98bc02edbb98 R08: ffff8890bfedc788 R09: ffff8890bfedc018
Jun 10 21:47:41 stefano-linux kernel: R10: ffff8890bfedc788 R11: 0000000000000000 R12: ffffffff9cc88c80
Jun 10 21:47:41 stefano-linux kernel: R13: ffff8890ce86a640 R14: 0000000000000001 R15: 0000000000000020
Jun 10 21:47:41 stefano-linux kernel: FS: 00007f3c91505700(0000) GS:ffff8890ce840000(0000) knlGS:0000000000000000
Jun 10 21:47:41 stefano-linux kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jun 10 21:47:41 stefano-linux kernel: CR2: 00007fdb7324afe0 CR3: 0000000396ff0000 CR4: 00000000003406e0
Jun 10 21:47:41 stefano-linux kernel: Call Trace:
Jun 10 21:47:41 stefano-linux kernel: native_flush_tlb_others+0x55/0x170
Jun 10 21:47:41 stefano-linux kernel: flush_tlb_mm_range+0xb4/0xe0
Jun 10 21:47:41 stefano-linux kernel: tlb_flush_mmu+0xb0/0x140
Jun 10 21:47:41 stefano-linux kernel: tlb_finish_mmu+0x42/0x80
Jun 10 21:47:41 stefano-linux kernel: unmap_region+0xf9/0x130
Jun 10 21:47:41 stefano-linux kernel: __do_munmap+0x291/0x4c0
Jun 10 21:47:41 stefano-linux kernel: mmap_region+0x240/0x670
Jun 10 21:47:41 stefano-linux kernel: do_mmap+0x3b4/0x5c0
Jun 10 21:47:41 stefano-linux kernel: vm_mmap_pgoff+0xcb/0x120
Jun 10 21:47:41 stefano-linux kernel: ksys_mmap_pgoff+0x5b/0x2a0
Jun 10 21:47:41 stefano-linux kernel: ? free_cpumask_var+0x9/0x10
Jun 10 21:47:41 stefano-linux kernel: __x64_sys_mmap+0x33/0x40
Jun 10 21:47:41 stefano-linux kernel: do_syscall_64+0x57/0x190
Jun 10 21:47:41 stefano-linux kernel: entry_SYSCALL_64_after_hwframe+0x44/0xa9
Jun 10 21:47:41 stefano-linux kernel: RIP: 0033:0x7f3ca311f70d
Jun 10 21:47:41 stefano-linux kernel: Code: 00 c3 66 2e 0f 1f 84 00 00 00 00 00 90 f3 0f 1e fa 48 89 f8 48 89 f7 48 89 d6 48 89 ca 4d 89 c2 4d 89 c8 4c 8b 4c 24 08 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 53 f7 0c 00 f7 d8 64 89 01 48
Jun 10 21:47:41 stefano-linux kernel: RSP: 002b:00007f3c91504b08 EFLAGS: 00000246 ORIG_RAX: 0000000000000009
Jun 10 21:47:41 stefano-linux kernel: RAX: ffffffffffffffda RBX: 0000000000000000 RCX: 00007f3ca311f70d
Jun 10 21:47:41 stefano-linux kernel: RDX: 0000000000000000 RSI: 0000000000600000 RDI: 00007f3c31d00000
Jun 10 21:47:41 stefano-linux kernel: RBP: 0000000000600000 R08: 00000000ffffffff R09: 0000000000000000
Jun 10 21:47:41 stefano-linux kernel: R10: 0000000000000032 R11: 0000000000000246 R12: 00007f3c31d00000
Jun 10 21:47:41 stefano-linux kernel: R13: 00007f3ca2e07b68 R14: 0000000000600000 R15: 0000000000600000
-- Reboot --
---
ProblemType: Bug
ApportVersion: 2.20.11-0ubuntu27.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: stefano 1552 F.... pulseaudio
 /dev/snd/controlC1: stefano 1552 F.... pulseaudio
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 20.04
InstallationDate: Installed on 2020-06-08 (2 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
IwConfig:
 lo no wireless extensions.

 enp4s0 no wireless extensions.
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia_modeset nvidia
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-37-generic root=UUID=b152ae93-9830-4b82-a98e-de7275ba97c6 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 5.4.0-37.41-generic 5.4.41
RelatedPackageVersions:
 linux-restricted-modules-5.4.0-37-generic N/A
 linux-backports-modules-5.4.0-37-generic N/A
 linux-firmware 1.187
RfKill:

Tags: focal
Uname: Linux 5.4.0-37-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 12/31/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 5407
dmi.board.asset.tag: Default string
dmi.board.name: PRIME B350-PLUS
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr5407:bd12/31/2019:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnPRIMEB350-PLUS:rvrRevX.0x:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1883012/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1883012

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: focal

apport information

tags: added: apport-collected
description: updated
Stefano (stefano-d) wrote : CRDA.txt

apport information

apport information

Stefano (stefano-d) wrote : Lspci.txt

apport information

apport information

Stefano (stefano-d) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Stefano (stefano-d) wrote :

Freeze occurred at 20:47, but the kernel log reached only until 20:34:15

Stefano (stefano-d) wrote :
Kai-Heng Feng (kaihengfeng) wrote :

Oh I have the exact same setup.

Please set "Typical Current Idle" in the BIOS and see if it helps.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Stefano (stefano-d) wrote :

@Kai-Heng Feng: I did this and for weeks I have no problems anymore. But I have to add, that I had no problems with Ubuntu 18.04 or Windows 10. So it seems to be related with newer kernel versions.

Stefano (stefano-d) wrote :

I changed the UEFI settings as suggested and I don't get freezes anymore.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Stefano (stefano-d) wrote :

So, what does the status "Invalid" means? As I said, I didn't get this problem with Ubuntu 18.04 and Windows 10.

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Stefano (stefano-d) wrote :

The freeze happened again, despite the UEFI setting "Typical Current Idle".
It happened after display energy saving after the wakeup.

Kai-Heng Feng (kaihengfeng) wrote :

Nvidia is not working after sleep:
Jul 31 22:52:56 stefano-ubuntu kernel: Call Trace:
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv001064kms+0xc7/0x400 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv000680kms+0x1e/0x80 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv002269kms+0x112/0x130 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv000481kms+0xd1/0xe1 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv000018kms+0x231/0x6fb [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv021585rm+0x9/0x50 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv021615rm+0x28/0xe0 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv021585rm+0x9/0x50 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv021617rm+0x32/0x120 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? os_release_spinlock+0x1a/0x20 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv008468rm+0x460/0x8c0 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv008550rm+0x53/0xb0 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv035507rm+0x13/0x30 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? up+0x37/0x70
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv030941rm+0x23/0x40 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? os_acquire_spinlock+0x12/0x20 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? os_release_spinlock+0x1a/0x20 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv036916rm+0xac/0x170 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv002628kms+0x1dae/0x1f70 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? kmalloc_order_trace+0x24/0xa0
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv000491kms+0x50/0x50 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv000620kms+0x31/0xe0 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? _nv000491kms+0x50/0x50 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? nvKmsIoctl+0x96/0x1d0 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? nvkms_ioctl_common+0x42/0x80 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? nvkms_ioctl+0xc4/0x100 [nvidia_modeset]
Jul 31 22:52:56 stefano-ubuntu kernel: ? nvidia_frontend_unlocked_ioctl+0x3b/0x50 [nvidia]
Jul 31 22:52:56 stefano-ubuntu kernel: ? do_vfs_ioctl+0x407/0x670
Jul 31 22:52:56 stefano-ubuntu kernel: ? do_user_addr_fault+0x216/0x450
Jul 31 22:52:56 stefano-ubuntu kernel: ? ksys_ioctl+0x67/0x90
Jul 31 22:52:56 stefano-ubuntu kernel: ? __x64_sys_ioctl+0x1a/0x20
Jul 31 22:52:56 stefano-ubuntu kernel: ? do_syscall_64+0x57/0x190
Jul 31 22:52:56 stefano-ubuntu kernel: ? entry_SYSCALL_64_after_hwframe+0x44/0xa9

So it's no longer the original issue.

Kai-Heng Feng (kaihengfeng) wrote :

[ 3.265218] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 440.64 Fri Feb 21 01:17:26 UTC 2020
[ 3.274456] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 440.64 Fri Feb 21 00:43:19 UTC 2020

The version in use is 440, maybe try 450 from the ppa:
https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers