Touchpad not detected in 'Lenovo V15-IIL model 82C5' after installing Ubuntu 20.04

Bug #1881322 reported by Federico Dadam on 2020-05-29
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 20.04 is installed in a brand new Lenovo V15-IIL alongside Windows 10. According to lenovo's support page, the driver for windows is Synaptics 19.5.10.149_Elan 22.4.18.1. In windows the touchpad works fine.

This model has two options in BIOS regarding Fn Keys, a "Smart Fn key" that toogles the Fn key on/off each time you press it and a "Foolproof Fn Key" that maps the Fn key to Ctrl when you press a combinations of keys that does not have a Fn assigned. When I enable the "foolproof fn key" in the BIOS, the Fn + F1...F12 and the sound driver stop working (i dont have sound, i can't change the volume and the volume icon in the GUI does not show). Fn+F6 (to enable/disable touchpad) can't enable it.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: linux-image-5.4.0-33-generic 5.4.0-33.37
ProcVersionSignature: Ubuntu 5.4.0-33.37-generic 5.4.34
Uname: Linux 5.4.0-33-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: fdadam 1434 F.... pulseaudio
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Fri May 29 13:08:24 2020
InstallationDate: Installed on 2020-05-28 (1 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 04f2:b624 Chicony Electronics Co., Ltd Integrated Camera
 Bus 001 Device 002: ID 0458:0186 KYE Systems Corp. (Mouse Systems) Genius DX-120 Mouse
 Bus 001 Device 004: ID 8087:0aaa Intel Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: LENOVO 82C5
ProcFB: 0 i915drmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-33-generic root=UUID=fd0c8ed1-6032-467c-9902-3094e6740be8 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-5.4.0-33-generic N/A
 linux-backports-modules-5.4.0-33-generic N/A
 linux-firmware 1.187
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/04/2020
dmi.bios.vendor: LENOVO
dmi.bios.version: DKCN26WW
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: LNVNB161216
dmi.board.vendor: LENOVO
dmi.board.version: NO DPK
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo V15-IIL
dmi.modalias: dmi:bvnLENOVO:bvrDKCN26WW:bd03/04/2020:svnLENOVO:pn82C5:pvrLenovoV15-IIL:rvnLENOVO:rnLNVNB161216:rvrNODPK:cvnLENOVO:ct10:cvrLenovoV15-IIL:
dmi.product.family: V15-IIL
dmi.product.name: 82C5
dmi.product.sku: LENOVO_MT_82C5_BU_idea_FM_V15-IIL
dmi.product.version: Lenovo V15-IIL
dmi.sys.vendor: LENOVO

Federico Dadam (ftdarg02) wrote :
affects: ubuntu → linux (Ubuntu)

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Christian vA (christian-va) wrote :

Just to let you know, I got the touchpad on my Lenovo V15-IIL to work with these boot parameters: i8042.nopnp=1 pci=nocrs

(Latest Bios dkcn29ww, Ubuntu Kernel 5.4.)

Hope this helps others, until the touchpad model gets recognized with the default parameters. I got this info from https://askubuntu.com/a/1247264 where someone did this with his S145-15IIL.

Federico Dadam (ftdarg02) wrote :

It worked! I added a few parameters to grub before but the did not worked.

For future reference to others:

- Access the grub configuration file by typing in a terminal: sudo nano /etc/default/grub
- Find the line "GRUB_CMDLINE_LINUX_DEFAULT" and append i8042.nopnp=1 pci=nocrs
- Save the file and do in the terminal update

Federico Dadam (ftdarg02) wrote :

It worked! I added a few parameters to grub before but the did not worked.

For future reference to others:

- Access the grub configuration file by typing in a terminal: sudo nano /etc/default/grub
- Find the line "GRUB_CMDLINE_LINUX_DEFAULT" and append i8042.nopnp=1 pci=nocrs
- Save the file and update grub with sudo update-grub
- restart

You-Sheng Yang (vicamo) on 2020-06-18
tags: added: hwe-touchpad
You-Sheng Yang (vicamo) on 2020-06-18
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
You-Sheng Yang (vicamo) wrote :

@Federico, @Christian, is "pci=nocrs" really necessary for you? Could you try removing that from the parameters and see if touchpad is still probed?

And, could you have a try https://launchpad.net/~vicamo/+archive/ubuntu/ppa-1881322 ? And please remove additional parameters while trying. The package is trying to add "i8042.nopnp=1" automatically based on DMI board info. The ppa is still building and may take hours to complete.

Christian vA (christian-va) wrote :

Hi You-Cheng,
thanks for your support.
I have removed pci=nocrs, but the touchpad did not work after reboot.

Federico Dadam (ftdarg02) wrote :

You-Cheng, i also tried removing pci=nocrs and rebooting and it did not work either.

I would like to try https://launchpad.net/~vicamo/+archive/ubuntu/ppa-1881322, should I delete all the grub parameters that i added?

To add further information:

- With the parameters I currently have, and with Mouse Click Emulation set in "Area" (in Tweaks), the right mouse button and middle mouse button does not work (In xev i can see that all are mapped to button 1) but the gestures as two finger scrolling work fine.
- With Click Emulation set in "Fingers", xev shows button 1, button 2 and button 3 with one, two and three fingers, respectively.
- The Option "Disable Touchpad while Typing" does not work with any of the previous configurations.

Also, I think this is unrelated:

- Sometimes when I boot ubuntu, the sound does not work, even the icon in the sound settings (top right corner) does not show, and the volume with the Fn keys does not change.
- When you try to open an app (e.g. Firefox), a folder or a terminal, it needs around a minute to work for the first time, then you can open anything normally.
- When I try to shutdown or restart, it shows a recurrent message "[ 56.603594] snd_hda_intel 0000:00:1f.3: No response from codec, resetting bus: last cmd=0x202f8100"
- The initial number rises (e.g. the second message is [ 57.607631]) and the hexadecimal number also changes.
- I have to force the shutdown. It usually requires one restart to fix, but sometimes i get in this situation two times in a row.

Hi, In my case it was solved after adding both parameters, "i8042.nopnp=1 pci=nocrs" I tried adding "i8042.nopnp" alone and it didn't work.

verion GmbH (sales-ixsoft) wrote :

"i8042.nopnp=1 pci=nocrs" does not cure the problem, it only allows the touchpad to be recognized as mouse pointer.
In *buntu, under "mouse and touchpads" it is shown as a mouse and no hint of a touchpad.
So only right and left click plus cursor movement will work, nothing else.

There are some strange kernel panics in the log file that might be related to this problem, please see attachment. (panics will occur with 5.4, 5.6 and 5.7.7)

You-Sheng Yang (vicamo) wrote :

@Federico, please help attach your acpi dump info:

  $ sudo apt install acpica-tools
  $ sudo acpidump -o acpi.dump

And attach that `acpi.dump` file.

sunny (sharma765) wrote :

Dear Team ,
I have a Lenovo laptop v15 IIL and i have installed 20.04 and touchpad driver is not working , Team please help on same

Thanks And Regards
Sunny Sharma
email id -<email address hidden>
ph no -+91 8920890908

Sarfaraz Nawaz (sir-nawaz959) wrote :

I'm facing the same problem. I just finished installing 20.04, and not only wireless (which is a more common issue), even my touchpad does not work. In fact, it has not been detected as I followed this:

https://wiki.ubuntu.com/DebuggingTouchpadDetection

and `cat /proc/bus/input/devices` does not list anything containing `touchpad`.

Hope there is a workaround for this.

agm97 (albertogomezmarin) wrote :

i8042.nopnp=1 pci=nocrs these are mine flags for being able to use the touchpad but after suspend the touchpad is gone again.

and This is my dump file( IT's not ubuntu, it's manjaro but I'm sure that it serves to you too) I'm using kernel 5.10.5-1-MANJARO in testing branch. It occurs to me from the start of using this pc, if no flags are in the grub there is no touchpad.

Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
Runar Ingebrigtsen (ringe) wrote :

This workes for me on a Lenovo V15-II

Edit `/etc/default/grub` and change the line "GRUB_CMDLINE_LINUX_DEFAULT" adding "i8042.nopnp=1" within the quotes.

Run `sudo update-grub`

Reboot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers