Flickering screen after waking up from Suspend

Bug #1874588 reported by Pavel Golikov on 2020-04-24

This bug report will be marked for expiration in 30 days if no further activity occurs. (find out why)

26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Just did a fresh install of Ubuntu 20.04 LTS and everything was fine, display worked perfect. Then I put the machine in Suspend mode (by clicking on GUI button), left for 5 minutes, came back, woke up the machine (by clicking a key on the keyboard), and upon waking up, the display started flickering heavily.

Relevant Specs (Sorry if I missed anything):

AMD® Ryzen 9 3900x 12-core processor × 24
AMD® Radeon rx 5700 xt
GNOME version 3.36.1
Windowing System X11
I am running 3 monitors: Samsung with resolution 3840x2160 and 2 LG monitors with resolution 1920x1080, all at 60Hz

Most of the flickering is happening on Samsung, although once in a while, other monitors flicker a little bit as well.

Things to note: When I switch Samsung to lower resolution, the flickering goes away. When I come back to 3840x2160, it comes back. When I switch to lower resolution, suspend and come back, everything is fine.

If I reboot the machine, the display is fine until I suspend and wake up again (if I am in higher resolution).

I tried changing the refresh rate of Samsung to 30.00 and 29.97 (the only two available when I turn off FreeSync), and the issue still persists. Turning FreeSync on and off does nothing.

Thank you,

Pavel.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: linux-image-5.4.0-26-generic 5.4.0-26.30
ProcVersionSignature: Ubuntu 5.4.0-26.30-generic 5.4.30
Uname: Linux 5.4.0-26-generic x86_64
ApportVersion: 2.20.11-0ubuntu27
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: pavel 1870 F.... pulseaudio
 /dev/snd/controlC0: pavel 1870 F.... pulseaudio
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Thu Apr 23 21:14:00 2020
InstallationDate: Installed on 2020-04-23 (0 days ago)
InstallationMedia: Ubuntu 20.04 LTS "Focal Fossa" - Release amd64 (20200423)
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcFB: 0 amdgpudrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-26-generic root=UUID=02f6301e-c22b-462d-a4e5-71a78b7eb203 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-5.4.0-26-generic N/A
 linux-backports-modules-5.4.0-26-generic N/A
 linux-firmware 1.187
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/19/2019
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1405
dmi.board.asset.tag: Default string
dmi.board.name: TUF GAMING X570-PLUS (WI-FI)
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Default string
dmi.chassis.type: 3
dmi.chassis.vendor: Default string
dmi.chassis.version: Default string
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1405:bd11/19/2019:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnTUFGAMINGX570-PLUS(WI-FI):rvrRevX.0x:cvnDefaultstring:ct3:cvrDefaultstring:
dmi.product.family: To be filled by O.E.M.
dmi.product.name: System Product Name
dmi.product.sku: SKU
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Pavel Golikov (pavel1986) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Ian Cameron (orithan) wrote :

I've experienced a similar issue on boot, with a Ryzen 7 3800x and a 5700xt on GNOME 3.36.2.

It may be related to a new error message when booting:

amdgpu: [powerplay] failed to send message: NumOfDisplays (64) $param:0x00000003 response

But, contrarily, my flickering issue can be corrected by readjusting the resolution from 1440p to 1080 and back again.

WXYZ (wxyzer) wrote :

I had the same issue with Ryzen 5 3600x and Radeon 5600xt. For a different mouse flickering issue when using xrandr, I had to set following xrandr after I set correct resolution and panning.

xrandr --output DisplayPort-2 --scale 0.9999x0.9999

DisplayPort-2 is my primary display. With the above setting my mouse flickering went away.

Surprisingly this also fixed the screen flickering issue after wake up from suspend.

WXYZ (wxyzer) wrote :

I was wrong in my previous comment. I had to recompile the kernel and move to a more recent one than 5.4.x that's shipped with 20.04. Tested this on a fresh 20.04 installation.

Kai-Heng Feng (kaihengfeng) wrote :

Pavel, are you still seeing the same issue after recent kernel updates?

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Reid (mrwowsers) wrote :

Hello,
I've been noticing what sounds like the same issue as the original post. This is brand new install of Ubuntu 20.04 after running all updates and restarting. A clean boot show has no display problems but after I suspend my system I get a lot of tearing/flashing. If I drop the rate on the larger monitor from 144Hz to 59.95Hz the problem goes away. I have also tried the other supported rates of 120.00 and 99.95 which still have tearing.

If I try the same process but with just my larger screen enabled, the resume doesn't have the flickering.

This does not seem to be happening in Fedora 32 in the same system. Since that runs 5.6 and 3.36 on Wayland maybe the issue is in the kernel. I am mostly a user so I can't really draw better conclusions.

I can provide a video and logs as needed.

My setup:
AMD® Ryzen 5 2600x six-core processor × 12
AMD® Radeon rx 5600 xt
GNOME version 3.36.3
Kernel: 5.4.0-40-generic #44-Ubuntu SMP Tue Jun 23 00:01:04 UTC 2020
Windowing System X11 (also happens when using Wayland)
2 monitors:
  Samsung 32" with resolution 3840x2160 @ 144.00 Hz
  Asus 24" 1920x1080 at 60Hz

Pavel Golikov (pavel1986) wrote :

My apologies. I wasn't checking this often enough. I upgraded the kernel top 5.16 and the issue went away.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers