a fake headset key event will be triggered when plugging the headset on Lenovo x1c7

Bug #1872583 reported by Hui Wang
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Hui Wang
Focal
High
Hui Wang
linux-oem-5.6 (Ubuntu)
High
Unassigned
Focal
High
Unassigned

Bug Description

[Impact]
When users plug a headset into the audio jack on Lenovo x1c7, the
audio driver can't stay in the rt_suspend state anymore

[Fix]
don't let the driver trigger the fake key event

[Test Case]
boot the kenrel, enable the dyndbg on the codec driver,
plug/unplug the headset, check the runime pm status in the dmesg

[Regression Risk]
Low, I have tested this patch Lenovo machines, they all worked well.

Hui Wang (hui.wang)
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in linux-oem (Ubuntu Focal):
importance: Undecided → High
Hui Wang (hui.wang)
description: updated
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1872583

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Timo Aaltonen (tjaalton)
affects: linux-oem (Ubuntu Focal) → linux-oem-5.6 (Ubuntu Focal)
Timo Aaltonen (tjaalton)
Changed in linux-oem-5.6 (Ubuntu Focal):
status: New → Fix Committed
Changed in linux (Ubuntu Focal):
status: Incomplete → Fix Committed
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

came via stable tree

Changed in linux-oem-5.6 (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in linux-oem-5.6 (Ubuntu):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers