SigmaTel STAC9228 8.04 Broken

Bug #186940 reported by Termina on 2008-01-29
12
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I have a SigmaTel STAC9228 sound card on my Dell Vostro 1400 (Laptop). Besides the mic never working on 7.10, the sound worked.

It required this in /etc/modprobe.d/alsa-base: options snd-hda-intel probe_mask=1 model=3stack

This no longer works with 8.04; I've double checked the /etc/modprobe.d/alsa-base file, and I've tried using the alsa-base.dpkg-dist file as well.

Termina (termina) wrote :

lspci

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)\

/proc/asound/card0/codec#0

Codec: SigmaTel STAC9228
Address: 0
Vendor Id: 0x83847616
Subsystem Id: 0x10280227
Revision Id: 0x100201
.....

flowbot (flowbot) wrote :
Download full text (6.2 KiB)

Same problem for me on Inspiron 1420 ... tried some of the suggestions in [url=https://bugs.launchpad.net/ubuntu/hardy/+source/linux/+bug/95940]this[/url] thread, but to no avail. Here is output of pulseaudio -vv:

shayne@shayne-laptop:~$ pulseaudio -vv
I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Master".
I: alsa-util.c: Using mixer control "PCM".
I: sink.c: Created sink 0 "alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_alsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_8086_284b_sound_card_0_alsa_capture_0" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Lo...

Read more...

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in linux which is the Launchpad package for the kernel in Hardy Heron.

Hardy lum 2.6.24-7.11 now contains ALSA 1.0.16. Please update and report
 back your results. Thanks!

Changed in linux:
status: New → Incomplete
Termina (termina) wrote :

alsactl -v still shows 1.0.15; I've installed backports for 2.6.24 and don't see any newer kernel version.

Could you provide a link or something?

Sound still does not work as of today, with all recent updates and several different /etc/modprobe.d/alsa-base configurations.

This is a very popular soundcard model for newer Dells, I'm surprised there hasn't been a solution yet. :(

Pete Goodall (pgoodall) wrote :

As of today, 25 Feb 2008, sound is still not working.

$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

$ alsactl -v
alsactl version 1.0.15

Don't know how to get this from the command line, but the sound applet in GNOME tells me it is a SigmaTel STAC9228. I'm using a Dell m1330, which is supposed to be certified for Gutsy. I'm running Hardy, so I'm hoping this will be fixed for release.

Please let me know if you need additional information.

Pete Goodall (pgoodall) wrote :

Sorry, should have seen this before:

$ cat /proc/asound/card0/codec#0 | head
Codec: SigmaTel STAC9228
Address: 0
Vendor Id: 0x83847616
Subsystem Id: 0x10280209
Revision Id: 0x100201

Just wanted to add that to be thorough.

Hi All,

I just tested the latest Hardy Alpha 5 release (http://cdimage.ubuntu.com/releases/hardy/alpha-5/) and sound is working. You just have to make sure you have all sound levels unmuted and turned up. For some reason ALSA version 1.0.16 mutes certain volume controls by default so you need to unmute them. I'm on a Dell Inspiron 1420:

00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 02)

Codec: SigmaTel STAC9228
Address: 0
Vendor Id: 0x83847616
Subsystem Id: 0x102801f3
Revision Id: 0x100201

Termina (termina) wrote :

I can confirm this. Newest 8.04 iso works (sound) and it resolved the majority of issues with my laptop. The fan is even working (7.10 made it turn off/on over and over again non-stop).

Thanks! :D

Dell Vostro 1400

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)

Termina (termina) wrote :

2.6.24-11-386 breaks sound again.

Termina (termina) wrote :

2.6.24-11-generic works, however. I had to manually install it.

Hi Termina,

Just curious if there is a specific reason you are wanting to use the -386 flavor rather than the -generic flavor? The difference between the -386 and -generic kernel flavors are basically different kernel config options being flipped on/off. For example, the -386 flavor disables SMP support while the -generic flavor enables it. So if there aren't any major reasons for using the -386 flavor over the -generic one, I'd suggest to just keep using -generic. Thanks.

Termina (termina) wrote :

Hardy picked that kernel for me; I had to manually install -generic with apt-get for some reason. I have a Intel Centrino Duo 2ghz CPU, so I'm betting not using -generic was hindering performance a bit.

After a reinstall (thank you libc), all is good. :) I have not had -386 installed by default since then.

namatarr (namatarr) wrote :

After installing Hardy, I too can confirm problems with the STAC9228 sound card. I do have sound, however it is very soft even with all volume controls set to 100.

Termina (termina) wrote :

namatarr,

Did you use the graphical way, or did you use alsamixer? You might want to try alsamixer, since it will show all playback options. I had similar issues before going into alsamixer. :)

Jack (ubuntu-chrisjs) wrote :

namatarr - Turning up "Front" and "Master" in alsamixer seem to at least help make it louder, even though it's still quiet in my opinion. The methods at https://wiki.ubuntu.com/Gutsy_Intel_HD_Audio_Controller didn't seem to work except for Method G, which also helped, though still quiet the first 3/4 of the slider. Method K would apparently work if Dell had a package for the new kernel.

Hi Termina,

I think the -386 kernel flavor being installed on your machine was related to bug https://bugs.edge.launchpad.net/ubuntu/+source/virtualbox-ose-modules/+bug/188579 . It seems sound is working for you now though. I do recall another bug report being open regarding sound not working with the -386 flavor, I just can't seem to find the exact bug number at the moment to refer you to. Regardless I'll go ahead and mark this report "Fix Released". Thanks.

Changed in linux:
status: Incomplete → Fix Released
Shaikailash (steve-doc-brown) wrote :

My internal microphone has NEVER worked on any 8.04, since the beta 4. Now the last kernel (yesterday) is 2.6.24-14-generic.
I have a Dell XPS M1530 :( it's very ugly.

Termina (termina) wrote :

sudo alsamixer -V all

Make sure the red 'Capture' is not muted and turned up all the way.

Make sure 'Digital' is turned up all the way, and that the other digital is set to Digital (not analog).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers