[Hardy Feature Request] Add EDD support

Bug #186686 reported by Jose De la Rosa on 2008-01-28
6
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Wishlist
Tim Gardner
partman-auto (Ubuntu)
Undecided
Unassigned
udev (Ubuntu)
Medium
Ben Collins

Bug Description

Hardy Feature Request to add EDD (BIOS Enhanced Disk Driver) support in Server and Desktop OS.

http://linux.dell.com/projects.shtml#edd

Changed in dell:
importance: Undecided → High
status: New → Confirmed
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Wishlist
status: New → Triaged

The EDD feature will appear in the -10 kernel (Alpha 6). The default behavior for server is CONFIG_EDD_OFF=n (EDD is enabled), Every other flavour is CONFIG_EDD_OFF=y (EDD is disabled) for backward compatibility.

Changed in dell:
status: Confirmed → In Progress
Changed in linux:
assignee: ubuntu-kernel-team → timg-tpi
status: Triaged → Fix Released
Mario Limonciello (superm1) wrote :

ubuntu-hardy.git b88bbb0c71a195b96d3d8a0cf3087888b6d89610
ubuntu-hardy.git c6802c6b1a38000d3b3a0103b869a0eb00117892

Changed in dell:
status: In Progress → Fix Committed
Mario Limonciello (superm1) wrote :

This has been implemented in kernel 2.6.24-10+. See http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-hardy.git;a=commit;h=b88bbb0c71a195b96d3d8a0cf3087888b6d89610 for more information.

Changed in dell:
status: Fix Committed → Fix Released
Mario Limonciello (superm1) wrote :

Well this is implemented at a kernel level, but the udev rules don't work.

Changed in dell:
status: Fix Released → Triaged

What udev rules don't work?

Changed in udev:
status: New → Incomplete
Changed in udev:
importance: Undecided → Wishlist

Scott,

As it stands, there is support in the kernel for EDD when you pass "edd=on". When EDD is enabled, you can manually run /lib/udev/edd_id /dev/sda and get the correct response. The symlinks that are supposed to be populated in /dev/disk/by-id for EDD are not generated however.

Mario Limonciello
Dell | Linux Engineering
<email address hidden>

________________________________

From: <email address hidden> on behalf of Scott James Remnant
Sent: Wed 4/2/2008 6:29 AM
To: <email address hidden>
Subject: [Bug 186686] Re: [Hardy Feature Request] Add EDD support

What udev rules don't work?

** Changed in: udev (Ubuntu)
       Status: New => Incomplete

--
[Hardy Feature Request] Add EDD support
https://bugs.launchpad.net/bugs/186686
You received this bug notification because you are a member of The Dell
Team, which is a direct subscriber.

Ben Collins (ben-collins) wrote :

Udev persistent-storage-edd rules need to come after the persistent-storage rules, else certain env vars are missing. Fixes is in the process of being uploaded.

Changed in udev:
assignee: nobody → ben-collins
importance: Wishlist → Medium
milestone: none → ubuntu-8.04
status: Incomplete → In Progress
Ben Collins (ben-collins) wrote :

Uploaded.

Changed in udev:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udev - 117-4ubuntu2

---------------
udev (117-4ubuntu2) hardy; urgency=low

  * The persistent-storage-edd rules need to be numerically
    persistent-storage+1 (as they are in the original source). Changed from 65
    to 66. LP: #186686

 -- Ben Collins <email address hidden> Wed, 02 Apr 2008 11:28:22 -0400

Changed in udev:
status: Fix Committed → Fix Released
Changed in dell:
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 73ubuntu7

---------------
partman-auto (73ubuntu7) hardy; urgency=low

  [ Mario Limonciello ]
  * biggest_free/choices:
    - Use mapdevfs to produce a valid partman disk (LP: #186686).

 -- Colin Watson <email address hidden> Mon, 07 Apr 2008 17:23:55 +0100

Changed in partman-auto:
status: New → Fix Released
Changed in somerville:
importance: Undecided → High
status: New → Fix Released
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1306060

no longer affects: somerville
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers