The voice recording function cannot work while connecting a headset on a Dell machine

Bug #1866581 reported by Hui Wang on 2020-03-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Status tracked in Focal
Bionic
Undecided
Unassigned
Eoan
Undecided
Unassigned
Focal
High
Hui Wang
linux-oem-osp1 (Ubuntu)
Status tracked in Focal
Bionic
Undecided
Unassigned
Eoan
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]
The headset mic can't record any sound on this machine.

[Fix]
The headset-mic is set to ctia mode by hardware. we need to apply
an existing quirk.

[Test Case]
boot the system, plug the headset, it could record the sound via
headset mic.

[Regression Risk]
Low, this patch is specific to 2 dell machines.

Hui Wang (hui.wang) on 2020-03-09
Changed in linux-raspi2 (Ubuntu):
importance: Undecided → High
tags: added: originate-from-1857953 somerville
Hui Wang (hui.wang) on 2020-03-09
affects: linux-raspi2 (Ubuntu) → linux (Ubuntu)
description: updated

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1866581

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Hui Wang (hui.wang) on 2020-03-10
Changed in linux-oem-osp1 (Ubuntu Eoan):
status: New → Invalid
Changed in linux-oem-osp1 (Ubuntu Focal):
status: New → Invalid
Changed in linux (Ubuntu Bionic):
status: New → Fix Committed
Changed in linux (Ubuntu Eoan):
status: New → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-eoan' to 'verification-done-eoan'. If the problem still exists, change the tag 'verification-needed-eoan' to 'verification-failed-eoan'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-eoan
Timo Aaltonen (tjaalton) on 2020-03-18
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: New → Fix Committed
Hui Wang (hui.wang) on 2020-03-26
tags: added: verification-done-bionic verification-done-eoan
removed: verification-needed-bionic verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux-oem-osp1 - 5.0.0-1046.51

---------------
linux-oem-osp1 (5.0.0-1046.51) bionic; urgency=medium

  * bionic/linux-oem-osp1: 5.0.0-1046.51 -proposed tracker (LP: #1869295)

  * The voice recording function cannot work while connecting a headset on a
    Dell machine (LP: #1866581)
    - SAUCE: ALSA: hda/realtek - Add Headset Mic supported

 -- Timo Aaltonen <email address hidden> Fri, 27 Mar 2020 07:31:46 +0200

Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers