Dell XPS 13 9300 Intel 1650S wifi [34f0:1651] fails to load firmware

Bug #1865962 reported by AceLan Kao on 2020-03-04
94
This bug affects 22 people
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
linux (Ubuntu)
Undecided
AceLan Kao
Focal
Undecided
AceLan Kao

Bug Description

[Impact]
It dumps some debug messages while loading iwlwifi firmware every time after booted up and finally got below errors
   [ 5.632845] iwlwifi 0000:00:14.3: Failed to start RT ucode: -110
   [ 5.632849] iwlwifi 0000:00:14.3: Firmware not running - cannot dump error
   [ 5.645491] iwlwifi 0000:00:14.3: Failed to run INIT ucode: -110

[Fix]
It looks like it fails to load the firmware since mainline v5.4 kernel, and got fixed at v5.6-rc1. After bisect the kernel, the first bad commit is
   b3bd6416fc77 iwlwifi: assume the driver_data is a trans_cfg, but allow full cfg

To avoid conflicts, we have to backport the following commits from mainline kernel
   b81b7bd02eda iwlwifi: remove some outdated iwl22000 configurations
   c042f0c77f3d iwlwifi: allocate more receive buffers for HE devices
   5661925a9b38 iwlwifi: pcie: rx: use rxq queue_size instead of constant
   bfc3e9fdbfb8 iwlwifi: 22000: fix some indentation
   3681021fc6af iwlwifi: remove IWL_DEVICE_22560/IWL_DEVICE_FAMILY_22560

[Test]
Verified on Dell XPS 9300 with Killer AX1650i wifi card and XPS 13 2-1 platform, wifi keeps working after reboot 10 times.

[Regression Potential]
Medium, the code changes a lot, although the test results are all positive, it's still hard to evaluate the regression potential.

CVE References

AceLan Kao (acelankao) on 2020-03-04
tags: added: oem-priority originate-from-1865829 ouagadougou
Changed in linux (Ubuntu Focal):
status: New → In Progress
assignee: nobody → AceLan Kao (acelankao)
AceLan Kao (acelankao) on 2020-03-04
description: updated
AceLan Kao (acelankao) wrote :

There are some public bug reports on bugzilla, but none of them look similar to ours.

https://bugzilla.kernel.org/show_bug.cgi?id=205749
It claims the fix lands on v5.4.16 and v5.5, and this patch already has been included in our focal kernel. It doesn't work for us.

https://bugzilla.kernel.org/show_bug.cgi?id=206329
This one is still open, and doesn't get fixed at v5.6-rc3, so not the same as ours.

https://bugzilla.kernel.org/show_bug.cgi?id=206719
The error message pretty similar to ours and fails at v5.4.22, but no one follow up

https://bugzilla.kernel.org/show_bug.cgi?id=206661
Another regression after v5.6-rc1, no fix until v5.6-rc4, affects our linux-5.6 oem kernel.

https://bugzilla.kernel.org/show_bug.cgi?id=206607
Similar errors, no follow up

https://bugzilla.kernel.org/show_bug.cgi?id=206395
Similar errors, but doesn't verify it with latest v5.6 mainline kernel.

This is our test results
5.3.0 - Good
5.3.18 - Good
5.4-rc1 - NG
5.4-rc4 - NG
5.4-rc8 - NG
5.4.0 - NG
5.4.16 - NG
5.4.24 - NG
5.5.0 - NG
5.5.8 - NG
5.6-rc1 - Good

AceLan Kao (acelankao) wrote :

Submit a public to address our issue.
https://bugzilla.kernel.org/show_bug.cgi?id=206793

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal

I can confirm I have a working wifi when booting with kernel 5.4.0-18-generic from focal-proposed.

Launchpad Janitor (janitor) wrote :
Download full text (81.5 KiB)

This bug was fixed in the package linux - 5.4.0-18.22

---------------
linux (5.4.0-18.22) focal; urgency=medium

  * focal/linux: 5.4.0-18.22 -proposed tracker (LP: #1866488)

  * Packaging resync (LP: #1786013)
    - [Packaging] resync getabis
    - [Packaging] update helper scripts

  * Add sysfs attribute to show remapped NVMe (LP: #1863621)
    - SAUCE: ata: ahci: Add sysfs attribute to show remapped NVMe device count

  * [20.04 FEAT] Compression improvements in Linux kernel (LP: #1830208)
    - lib/zlib: add s390 hardware support for kernel zlib_deflate
    - s390/boot: rename HEAP_SIZE due to name collision
    - lib/zlib: add s390 hardware support for kernel zlib_inflate
    - s390/boot: add dfltcc= kernel command line parameter
    - lib/zlib: add zlib_deflate_dfltcc_enabled() function
    - btrfs: use larger zlib buffer for s390 hardware compression
    - [Config] Introducing s390x specific kernel config option CONFIG_ZLIB_DFLTCC

  * [UBUNTU 20.04] s390x/pci: increase CONFIG_PCI_NR_FUNCTIONS to 512 in kernel
    config (LP: #1866056)
    - [Config] Increase CONFIG_PCI_NR_FUNCTIONS from 64 to 512 starting with focal
      on s390x

  * CONFIG_IP_MROUTE_MULTIPLE_TABLES is not set (LP: #1865332)
    - [Config] CONFIG_IP_MROUTE_MULTIPLE_TABLES=y

  * Dell XPS 13 9300 Intel 1650S wifi [34f0:1651] fails to load firmware
    (LP: #1865962)
    - iwlwifi: remove IWL_DEVICE_22560/IWL_DEVICE_FAMILY_22560
    - iwlwifi: 22000: fix some indentation
    - iwlwifi: pcie: rx: use rxq queue_size instead of constant
    - iwlwifi: allocate more receive buffers for HE devices
    - iwlwifi: remove some outdated iwl22000 configurations
    - iwlwifi: assume the driver_data is a trans_cfg, but allow full cfg

  * [FOCAL][REGRESSION] Intel Gen 9 brightness cannot be controlled
    (LP: #1861521)
    - Revert "USUNTU: SAUCE: drm/i915: Force DPCD backlight mode on Dell Precision
      4K sku"
    - Revert "UBUNTU: SAUCE: drm/i915: Force DPCD backlight mode on X1 Extreme 2nd
      Gen 4K AMOLED panel"
    - SAUCE: drm/dp: Introduce EDID-based quirks
    - SAUCE: drm/i915: Force DPCD backlight mode on X1 Extreme 2nd Gen 4K AMOLED
      panel
    - SAUCE: drm/i915: Force DPCD backlight mode for some Dell CML 2020 panels

  * [20.04 FEAT] Enable proper kprobes on ftrace support (LP: #1865858)
    - s390/ftrace: save traced function caller
    - s390: support KPROBES_ON_FTRACE

  * alsa/sof: load different firmware on different platforms (LP: #1857409)
    - ASoC: SOF: Intel: hda: use fallback for firmware name
    - ASoC: Intel: acpi-match: split CNL tables in three
    - ASoC: SOF: Intel: Fix CFL and CML FW nocodec binary names.

  * [UBUNTU 20.04] Enable CONFIG_NET_SWITCHDEV in kernel config for s390x
    starting with focal (LP: #1865452)
    - [Config] Enable CONFIG_NET_SWITCHDEV in kernel config for s390x starting
      with focal

  * Focal update: v5.4.24 upstream stable release (LP: #1866333)
    - io_uring: grab ->fs as part of async offload
    - EDAC: skx_common: downgrade message importance on missing PCI device
    - net: dsa: b53: Ensure the default VID is untagged
    - net: fib_rules: Correctly set table field when table number exceeds 8 bit...

Changed in linux (Ubuntu Focal):
status: In Progress → Fix Released
Changed in hwe-next:
status: New → Fix Released

Not sure if this is the right place, but I've had the no wifi problem on my Asus Eee PC (Intel Atom) for both revisions since 5.3.0-28 generic (IOW, that's the last one that works properly, but there have been 2 new revisions installed since in my Peppermint 10 distro). I'm getting worried that the last working version will rotate out of use in this problem is not fixed soon.

AceLan Kao (acelankao) on 2020-04-06
tags: added: verification-done-focal
removed: verification-needed-focal
Johon Doee (jodoee11) wrote :

Thanks for working on that bug but I have to say that this is ridiculous. A kernel update gets pushed with a mayor regression that breaks Wifi and it takes over one month to fix that. The fix for this issue didnt even land for 19.10 so far. This is just bad.

Robert E. Griffith (bobjunga) wrote :

For anyone googling, I can confirm that my Thinkpad X1 Yoga Gen4 with intel AC 9560 wifi card has no wifi with 5.3.0-29+ but does work with 5.4.0-17

Thinkpad X1 Yoga Gen4 with intel AC 9560 wifi
* 5.3.0-28: wifi works
* 5.3.0-40,43,45,46: wifi does not work
* 5.4.0-17: wifi works

--BobG

Tim Tierney (timtierney) wrote :

Just diagnosed my fathers brand new System 76 laptop. Same issue. Just got GRUB to boot 5.3.0-28 by default to get him up and running again.

Sometimes it's hard to be a Linux fan. Telling him "oh yeah, just wait until 20.04" is unacceptable quality for Ubuntu.

AceLan Kao (acelankao) wrote :

This regression was introduced by stable update. That means all 5.3/5.4 kernels are affected(including all linux distributions that comes with 5.3/5.4 kernel).

There are 2 ways to fix this issue
1. Find the bad commit in stable update and revert it
2. Find the fixed commit from v5.6 and backport it

I was using the second method to fix this issue for v5.4 and not knowing this happens on v5.3, too.
Backport those commits to v5.4 is fine, since v5.4 is not released yet and can accept big wifi changes. But those commits doesn't fit SRU rules, so that's why v5.3 doesn't get fixed.(Upstream should come out a stable update to fix this issue, since this impacts all distributions)

v5.4 kernel is stable enough, please consider to upgrade to v5.4 if possible. Or stay at 18.04(v4.15) with backport-iwlwifi-dkms package.

leonbottou (leon-bottou) wrote :

Bug 1864188 is marked as a duplicate of this one.

I am not sure this is correct so I added my comment into 1864188.

To increase chances that somebody sees it, the comment says that, on my system, the iwlwifi driver shipped with the standard bionic kernel 5.3.0-46 seems to be loading the wrong firmware blob. It loads "iwlwifi-Qu-b0-jf-b0-48.ucode" which crashes quickly, as seen in dmesg. I believe it should load "iwlwifi-QuZ-a0-jf-b0-48.ucode". I now use a driver that does so and all is working fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.