[EGL] enable intel_idle for Eagle Stream

Bug #1864764 reported by quanxian on 2020-02-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Description:
Enable Intel_idle for eagle stream.

Target Kernel: 5.6
Target Release: 20.10

Commit Ids:

bc94638886ab21f8247d3f7f39573d3feb7d8284("ACPI: processor: Export function to claim _CST control")

987c785319b99e32602f7f86cfae3cf9b81e402b("ACPI: processor: Introduce acpi_processor_evaluate_cst()")

aa659a3fca79abd9a3ca3ddc535db631b01c9a02("ACPI: processor: Clean up acpi_processor_evaluate_cst()")

239ed06d0eefc4ee351af69bd64742ada56c4bdb("ACPI: processor: Make ACPI_PROCESSOR_CSTATE depend on ACPI_PROCESSOR")

77fb4e0a559a960eb36d0b2c50c781c5492577eb("ACPI: processor: Export acpi_processor_evaluate_cst()")

9f3d6daf61e5156139cd05643f7f1c2a9b7b49b0("intel_idle: Refactor intel_idle_cpuidle_driver_init()")

18734958e9bfbc055805d110a38dc76307eba742("intel_idle: Use ACPI _CST for processor models without C-state tables")

75a80267410e38ab76c4ceb39753f96d72113781("cpuidle: Allow idle states to be disabled by default")

bff8e60a86f4960133f90ad9add9adeb082b8154("intel_idle: Allow ACPI _CST to be used for selected known processors")

4ec32d9e8e5b6d6eb491eeee3938665d8a2388fa("intel_idle: Add module parameter to prevent ACPI _CST from being used")

e6d4f08a677654385869ba0c39d7c9ceec47e5c5("intel_idle: Use ACPI _CST on server systems")

a3299182216397a0b943d2549d1997f4eba2bdd2("Documentation: admin-guide: PM: Add intel_idle document")

quanxian (quanxian-wang) wrote :

Egl is not public, keep private.

quanxian (quanxian-wang) wrote :

v5.6-rc1
bc94638886ab21f8247d3f7f39573d3feb7d8284("ACPI: processor: Export function to claim _CST control")

987c785319b99e32602f7f86cfae3cf9b81e402b("ACPI: processor: Introduce acpi_processor_evaluate_cst()")

aa659a3fca79abd9a3ca3ddc535db631b01c9a02("ACPI: processor: Clean up acpi_processor_evaluate_cst()")

239ed06d0eefc4ee351af69bd64742ada56c4bdb("ACPI: processor: Make ACPI_PROCESSOR_CSTATE depend on ACPI_PROCESSOR")

77fb4e0a559a960eb36d0b2c50c781c5492577eb("ACPI: processor: Export acpi_processor_evaluate_cst()")

9f3d6daf61e5156139cd05643f7f1c2a9b7b49b0("intel_idle: Refactor intel_idle_cpuidle_driver_init()")

18734958e9bfbc055805d110a38dc76307eba742("intel_idle: Use ACPI _CST for processor models without C-state tables")

75a80267410e38ab76c4ceb39753f96d72113781("cpuidle: Allow idle states to be disabled by default")

bff8e60a86f4960133f90ad9add9adeb082b8154("intel_idle: Allow ACPI _CST to be used for selected known processors")

4ec32d9e8e5b6d6eb491eeee3938665d8a2388fa("intel_idle: Add module parameter to prevent ACPI _CST from being used")

e6d4f08a677654385869ba0c39d7c9ceec47e5c5("intel_idle: Use ACPI _CST on server systems")

a3299182216397a0b943d2549d1997f4eba2bdd2("Documentation: admin-guide: PM: Add intel_idle document")

Changed in intel:
status: New → Fix Committed
quanxian (quanxian-wang) on 2020-05-13
description: updated
tags: added: intel-kernel-20.10
removed: intel-kernel-20.04
quanxian (quanxian-wang) on 2020-06-23
information type: Private → Public

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1864764

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: groovy
quanxian (quanxian-wang) on 2020-11-16
Changed in intel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers