ftrace test in ubuntu_kernel_selftests will timeout randomly

Bug #1864172 reported by Po-Hsu Lin on 2020-02-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Po-Hsu Lin
linux (Ubuntu)
Status tracked in Focal
Bionic
Undecided
Po-Hsu Lin
Disco
Undecided
Po-Hsu Lin
Eoan
Undecided
Po-Hsu Lin
Focal
Undecided
Po-Hsu Lin

Bug Description

== SRU Justification ==
A new timeout feature was added to kselftests in commit 852c8cbf
(selftests/kselftest/runner.sh: Add 45 second timeout per test)

However the ftrace test will take much longer than 45 seconds to run,
thus you will see it failed with:
   not ok 1 selftests: ftrace: ftracetest # TIMEOUT

== Fix ==
* 9fab89cc (tracing/selftests: Turn off timeout setting)

This patch will turn off the timeout setting for the ftrace test.
It can be cherry-picked into B/D/E/F, we don't run this test in X so it
can be skipped.

Note that we don't have 852c8cbf in B/D, but I think it's still OK to
fix them as the change is really small, and if they got that patch in
the future we don't need to look back on this.

== Test ==
Patch tested directly on KVM nodes. It works as expected.

== Regression Potential ==
Low, trivial change limited to testing tools.

== Original Bug Report ==
Issue found on Eoan

this test will timeout quite randomly before the test can complete:

1st attempt:
 # [23] ftrace - function trace on module [PASS]
 # [24] ftrace - function profiling#
 not ok 1 selftests: ftrace: ftracetest # TIMEOUT

2nd attemp:
# [31] Kprobe dynamic event - adding and removing [PASS]
# [32] Kprobe dynamic event - busy event check#
not ok 1 selftests: ftrace: ftracetest # TIMEOUT

3rd attempt:
# [35] Kprobe event string type argument [PASS]
# [36] Kprobe event symbol argument#
not ok 1 selftests: ftrace: ftracetest # TIMEOUT

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: linux-image-5.3.0-40-generic 5.3.0-40.32
ProcVersionSignature: User Name 5.3.0-40.32-generic 5.3.18
Uname: Linux 5.3.0-40-generic x86_64
AlsaDevices:
 total 0
 crw-rw---- 1 root audio 116, 1 Feb 21 09:05 seq
 crw-rw---- 1 root audio 116, 33 Feb 21 09:05 timer
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.11-0ubuntu8.2
Architecture: amd64
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
Date: Fri Feb 21 09:09:06 2020
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: QEMU Standard PC (i440FX + PIIX, 1996)
PciMultimedia:

ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcFB: 0 cirrusdrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.3.0-40-generic root=UUID=29438a95-0e7a-484b-a1fb-527f0e3d2e06 ro console=tty1 console=ttyS0
RelatedPackageVersions:
 linux-restricted-modules-5.3.0-40-generic N/A
 linux-backports-modules-5.3.0-40-generic N/A
 linux-firmware 1.183.4
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/01/2014
dmi.bios.vendor: SeaBIOS
dmi.bios.version: 1.10.2-1ubuntu1
dmi.chassis.type: 1
dmi.chassis.vendor: QEMU
dmi.chassis.version: pc-i440fx-bionic
dmi.modalias: dmi:bvnSeaBIOS:bvr1.10.2-1ubuntu1:bd04/01/2014:svnQEMU:pnStandardPC(i440FX+PIIX,1996):pvrpc-i440fx-bionic:cvnQEMU:ct1:cvrpc-i440fx-bionic:
dmi.product.name: Standard PC (i440FX + PIIX, 1996)
dmi.product.version: pc-i440fx-bionic
dmi.sys.vendor: QEMU

CVE References

Po-Hsu Lin (cypressyew) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Po-Hsu Lin (cypressyew) wrote :

Issue found on Focal ARM64:
# [26] ftrace - test reading of set_ftrace_filter [PASS]
# [27] ftrace - test for function traceon/off triggers
not ok 1 selftests: ftrace: ftracetest # TIMEOUT

summary: - ftrace test in ubuntu_kernel_selftests will timeout on E
+ ftrace test in ubuntu_kernel_selftests will timeout randomly
Changed in linux (Ubuntu Focal):
status: Confirmed → In Progress
Changed in linux (Ubuntu Eoan):
status: New → In Progress
Changed in ubuntu-kernel-tests:
status: New → In Progress
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Eoan):
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Focal):
assignee: nobody → Po-Hsu Lin (cypressyew)
Po-Hsu Lin (cypressyew) wrote :

We don't have this test in Xenial.

tags: added: focal ubuntu-kernel-selftests
tags: added: sru-20200217
Po-Hsu Lin (cypressyew) wrote :
description: updated
description: updated
no longer affects: ubuntu-kernel-tests
Changed in linux (Ubuntu Bionic):
status: New → In Progress
Changed in linux (Ubuntu Disco):
status: New → In Progress
Changed in ubuntu-kernel-tests:
status: New → In Progress
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Bionic):
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Disco):
assignee: nobody → Po-Hsu Lin (cypressyew)
Sean Feole (sfeole) on 2020-02-26
tags: added: aws azure
tags: added: 5.3
Po-Hsu Lin (cypressyew) on 2020-03-04
tags: added: kqa-blocker
Sean Feole (sfeole) wrote :

After reviewing the bug, i'm removing the kqa-blocker tag, as this appears to be a bug in the test itself and not a critical failure.

tags: removed: kqa-blocker
Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Eoan):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Disco):
status: In Progress → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Launchpad Janitor (janitor) wrote :
Download full text (81.5 KiB)

This bug was fixed in the package linux - 5.4.0-18.22

---------------
linux (5.4.0-18.22) focal; urgency=medium

  * focal/linux: 5.4.0-18.22 -proposed tracker (LP: #1866488)

  * Packaging resync (LP: #1786013)
    - [Packaging] resync getabis
    - [Packaging] update helper scripts

  * Add sysfs attribute to show remapped NVMe (LP: #1863621)
    - SAUCE: ata: ahci: Add sysfs attribute to show remapped NVMe device count

  * [20.04 FEAT] Compression improvements in Linux kernel (LP: #1830208)
    - lib/zlib: add s390 hardware support for kernel zlib_deflate
    - s390/boot: rename HEAP_SIZE due to name collision
    - lib/zlib: add s390 hardware support for kernel zlib_inflate
    - s390/boot: add dfltcc= kernel command line parameter
    - lib/zlib: add zlib_deflate_dfltcc_enabled() function
    - btrfs: use larger zlib buffer for s390 hardware compression
    - [Config] Introducing s390x specific kernel config option CONFIG_ZLIB_DFLTCC

  * [UBUNTU 20.04] s390x/pci: increase CONFIG_PCI_NR_FUNCTIONS to 512 in kernel
    config (LP: #1866056)
    - [Config] Increase CONFIG_PCI_NR_FUNCTIONS from 64 to 512 starting with focal
      on s390x

  * CONFIG_IP_MROUTE_MULTIPLE_TABLES is not set (LP: #1865332)
    - [Config] CONFIG_IP_MROUTE_MULTIPLE_TABLES=y

  * Dell XPS 13 9300 Intel 1650S wifi [34f0:1651] fails to load firmware
    (LP: #1865962)
    - iwlwifi: remove IWL_DEVICE_22560/IWL_DEVICE_FAMILY_22560
    - iwlwifi: 22000: fix some indentation
    - iwlwifi: pcie: rx: use rxq queue_size instead of constant
    - iwlwifi: allocate more receive buffers for HE devices
    - iwlwifi: remove some outdated iwl22000 configurations
    - iwlwifi: assume the driver_data is a trans_cfg, but allow full cfg

  * [FOCAL][REGRESSION] Intel Gen 9 brightness cannot be controlled
    (LP: #1861521)
    - Revert "USUNTU: SAUCE: drm/i915: Force DPCD backlight mode on Dell Precision
      4K sku"
    - Revert "UBUNTU: SAUCE: drm/i915: Force DPCD backlight mode on X1 Extreme 2nd
      Gen 4K AMOLED panel"
    - SAUCE: drm/dp: Introduce EDID-based quirks
    - SAUCE: drm/i915: Force DPCD backlight mode on X1 Extreme 2nd Gen 4K AMOLED
      panel
    - SAUCE: drm/i915: Force DPCD backlight mode for some Dell CML 2020 panels

  * [20.04 FEAT] Enable proper kprobes on ftrace support (LP: #1865858)
    - s390/ftrace: save traced function caller
    - s390: support KPROBES_ON_FTRACE

  * alsa/sof: load different firmware on different platforms (LP: #1857409)
    - ASoC: SOF: Intel: hda: use fallback for firmware name
    - ASoC: Intel: acpi-match: split CNL tables in three
    - ASoC: SOF: Intel: Fix CFL and CML FW nocodec binary names.

  * [UBUNTU 20.04] Enable CONFIG_NET_SWITCHDEV in kernel config for s390x
    starting with focal (LP: #1865452)
    - [Config] Enable CONFIG_NET_SWITCHDEV in kernel config for s390x starting
      with focal

  * Focal update: v5.4.24 upstream stable release (LP: #1866333)
    - io_uring: grab ->fs as part of async offload
    - EDAC: skx_common: downgrade message importance on missing PCI device
    - net: dsa: b53: Ensure the default VID is untagged
    - net: fib_rules: Correctly set table field when table number exceeds 8 bit...

Changed in linux (Ubuntu Focal):
status: In Progress → Fix Released

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-eoan' to 'verification-done-eoan'. If the problem still exists, change the tag 'verification-needed-eoan' to 'verification-failed-eoan'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-eoan
Po-Hsu Lin (cypressyew) wrote :

Passed with 4.15.0-94.95, ftrace test can finish now.
18:01:29 DEBUG| [stdout] # of passed: 46
18:01:29 DEBUG| [stdout] # of failed: 0
18:01:29 DEBUG| [stdout] # of unresolved: 0
18:01:29 DEBUG| [stdout] # of untested: 2
18:01:29 DEBUG| [stdout] # of unsupported: 2
18:01:29 DEBUG| [stdout] # of xfailed: 0
18:01:29 DEBUG| [stdout] # of undefined(test bug): 0
18:01:29 DEBUG| [stdout] ok 1..1 selftests: ftracetest [PASS]

tags: added: verification-done-bionic
removed: verification-needed-bionic
Po-Hsu Lin (cypressyew) wrote :

Passed with Eoan 5.3.0-43.36, ftrace test can finish now.

18:01:29 DEBUG| [stdout] # of passed: 46
18:01:29 DEBUG| [stdout] # of failed: 0
18:01:29 DEBUG| [stdout] # of unresolved: 0
18:01:29 DEBUG| [stdout] # of untested: 2
18:01:29 DEBUG| [stdout] # of unsupported: 2
18:01:29 DEBUG| [stdout] # of xfailed: 0
18:01:29 DEBUG| [stdout] # of undefined(test bug): 0
18:01:29 DEBUG| [stdout] ok 1..1 selftests: ftracetest [PASS]

tags: added: verification-donw-eoan
removed: verification-needed-eoan
tags: added: verification-don-eoan
removed: verification-donw-eoan
tags: added: verification-done-eoan
removed: verification-don-eoan
tags: added: verification-done-focal
removed: verification-needed-focal
Po-Hsu Lin (cypressyew) wrote :

Passed with Focal 5.4.0-20.24, ftrace test can finish now.
03/26 00:22:54 DEBUG| utils:0153| [stdout] # # of passed: 82
03/26 00:22:54 DEBUG| utils:0153| [stdout] # # of failed: 1
03/26 00:22:54 DEBUG| utils:0153| [stdout] # # of unresolved: 1
03/26 00:22:54 DEBUG| utils:0153| [stdout] # # of untested: 2
03/26 00:22:54 DEBUG| utils:0153| [stdout] # # of unsupported: 1
03/26 00:22:54 DEBUG| utils:0153| [stdout] # # of xfailed: 1
03/26 00:22:54 DEBUG| utils:0153| [stdout] # # of undefined(test bug): 0
03/26 00:22:54 DEBUG| utils:0153| [stdout] not ok 1 selftests: ftrace: ftracetest # exit=1

Changed in ubuntu-kernel-tests:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers