Problem with the touchpad in kernel 5.3 *

Bug #1863321 reported by Artificial Reminisce on 2020-02-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

In kernel version 5.3 *, the touchpad does not work properly. On the login screen it works, but after logging in, only the left half of the touchpad works. Both click buttons work.
I know that I am on Linux Mint, but I am new to Linux and I do not know if I should resort to you, or if the bug also affects you, etc. I reported the bug to both OS.
Thanks for read.

-----> INXI COMMAND

~$ inxi -Fxxrzc0
System:
  Host: Kernel: 5.0.0-37-generic x86_64 bits: 64 compiler: gcc
  v: 7.4.0 Desktop: Xfce 4.14.1 tk: Gtk 3.22.30 wm: xfwm4 dm: LightDM
  Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: Intel product: Intel powered classmate PC
  v: Clamshell serial: <filter> Chassis: type: 9 v: 0.1 serial: <filter>
  Mobo: Intel model: Intel powered classmate PC v: Clamshell
  serial: <filter> UEFI: Phoenix v: MPBYT10A.88F.0039.2016.0622.1403
  date: 06/22/2016
Battery:
  ID-1: BAT1 charge: 22.8 Wh condition: 30.0/36.6 Wh (82%) volts: 10.8/11.1
  model: ECS CMPC serial: <filter> status: Discharging
CPU:
  Topology: Dual Core model: Intel Celeron N2808 bits: 64 type: MCP
  arch: Silvermont rev: 8 L2 cache: 1024 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 6330
  Speed: 1583 MHz min/max: 500/1583 MHz Core speeds (MHz): 1: 1583 2: 1583
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
  vendor: Elite Systems driver: i915 v: kernel bus ID: 00:02.0
  chip ID: 8086:0f31
  Display: x11 server: X.Org 1.20.5 driver: modesetting unloaded: fbdev,vesa
  resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel Bay Trail v: 4.2 Mesa 19.2.8
  compat-v: 3.0 direct render: Yes
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
  vendor: Elite Systems driver: snd_hda_intel v: kernel bus ID: 00:1b.0
  chip ID: 8086:0f04
  Sound Server: ALSA v: k5.0.0-37-generic
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
  driver: rtl8723be v: kernel port: 2000 bus ID: 01:00.0 chip ID: 10ec:b723
  IF: wlp1s0 state: up mac: <filter>
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Elite Systems
  driver: r8169 v: kernel port: 1000 bus ID: 02:00.0 chip ID: 10ec:8136
  IF: enp2s0 state: down mac: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 28.83 GiB (6.2%)
  ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-22VHAT0
  size: 465.76 GiB speed: 3.0 Gb/s serial: <filter>
Partition:
  ID-1: / size: 48.97 GiB used: 28.80 GiB (58.8%) fs: ext4 dev: /dev/sda1
  ID-2: swap-1 size: 4.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda7
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Repos:
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/megasync.list
  1: deb https://mega.nz/linux/MEGAsync/xUbuntu_18.04/ ./
  Active apt repos in: /etc/apt/sources.list.d/mikhailnov-pulseeffects-bionic.list
  1: deb http://ppa.launchpad.net/mikhailnov/pulseeffects/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
  1: deb http://mirrors.evowise.com/linuxmint/packages tricia main upstream import backport
  2: deb http://ubuntu.unc.edu.ar/ubuntu bionic main restricted universe multiverse
  3: deb http://ubuntu.unc.edu.ar/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://ubuntu.unc.edu.ar/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
  Processes: 163 Uptime: 27m Memory: 3.73 GiB used: 1.30 GiB (35.0%)
  Init: systemd v: 237 runlevel: 5 Compilers: gcc: 7.4.0 alt: 7 Shell: bash
  v: 4.4.20 running in: xfce4-terminal inxi: 3.0.32

-----> XINPUT COMMAND

~$ xinput -list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ETPS/2 Elantech Touchpad id=14 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ cmpc_keys id=8 [slave keyboard (3)]
    ↳ Video Bus id=9 [slave keyboard (3)]
    ↳ Power Button id=10 [slave keyboard (3)]
    ↳ Sleep Button id=11 [slave keyboard (3)]
    ↳ USB 2.0 Camera: USB 2.0 Camera id=12 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1863321

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: disco
Launchpad Janitor (janitor) wrote :

[Expired for linux (Ubuntu) because there has been no activity for 60 days.]

Changed in linux (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers