[UBUNTU 20.04] Fix a potential data corruption issue for thin provisioned devices

Bug #1862749 reported by bugproxy
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Frank Heimes
linux (Ubuntu)
Fix Released
Undecided
Frank Heimes

Bug Description

This pro-active fix is requested to provide the code for disablement of Thin Provisioning within Ubuntu 20.04, like within Ubuntu 19.10 or providing the final solution from upstream.

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-183845 severity-high targetmilestone-inin2004
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in ubuntu-z-systems:
importance: Undecided → High
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Changed in linux (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → nobody
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

In eoan we shipped:

57d53162face UBUNTU: SAUCE: Revert "s390/dasd: Add discard support for ESE volumes"

And as it is a SAUCE patch, we continue to ship it, as we don't implicitely drop them:

964ce509e2de Revert "s390/dasd: Add discard support for ESE volumes"

Currently if you grep for DASD_FEATURE_DISCARD:
$ git grep DASD_FEATURE_DISCARD
arch/s390/include/uapi/asm/dasd.h:#define DASD_FEATURE_DISCARD 0x080
drivers/s390/block/dasd_fba.c: dasd_set_feature(cdev, DASD_FEATURE_DISCARD, 1);

It is only enabled for the FBA devices.

Since the original request to disable DISCARD for ESE volumes, we have not re-enabled them.

So what is the purporse of this request? Do you want us to disable it for FBA volumes too?

We will not re-enable DISCARD for ESE volumes, until you say it's good again.

Revision history for this message
Frank Heimes (fheimes) wrote :

The purpose of this request is to track the thin provisioning situation for Focal.
Commit 964ce509e2de removed the support partially and with LP 1860535 it's completely out (still in proposed / Fix Committed).

IBM is working on a fix for thin provisioning and wants to bring it upstream.
Once it's upstream and still in time for 20.04, the kernel team may consider to pick it for focal,
but in case it will not be available in time for focal, we should remove it completely from focal (as done with LP 1860535 for Eoan).

This ticket is to track this issue and to not forget about it.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Ok, I see that either https://lists.ubuntu.com/archives/kernel-team/2020-January/107107.html needs to land in unstable & focal kernel trees, or better thing-provisioning support.

bugproxy (bugproxy)
tags: added: severity-critical
removed: severity-high
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2020-02-17 09:29 EDT-------
Target for getting the backport:
Fix will be provided for kernel 5.6. Target for providing the patch will be 2020-02-29...

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-03-16 04:56 EDT-------
First information regadring git-commit

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/s390/block?h=v5.6-rc6&id=5e6bdd37c5526ef01326df5dabb93011ee89237e

Revision history for this message
Frank Heimes (fheimes) wrote : Re: [UBUNTU 20.04] Thin Provisioning support (disablement or final solution)

The commit does not only landed in 'linux-next', but also in 'linux'
and it cherry-picks cleanly - many thx.
I'll start to work in the patch submission to the kernel team ...

Changed in ubuntu-z-systems:
status: Incomplete → In Progress
status: In Progress → Triaged
Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in ubuntu-z-systems:
assignee: Skipper Bug Screeners (skipper-screen-team) → Frank Heimes (fheimes)
Changed in linux (Ubuntu):
assignee: nobody → Frank Heimes (fheimes)
Frank Heimes (fheimes)
summary: - [UBUNTU 20.04] Thin Provisioning support (disablement or final solution)
+ [UBUNTU 20.04] Fix a potential data corruption issue for thin
+ provisioned devices
Revision history for this message
Frank Heimes (fheimes) wrote :

Patch request submitted:
https://lists.ubuntu.com/archives/kernel-team/2020-March/thread.html#108286
changing status to 'In Progress'.

Changed in linux (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-z-systems:
status: Triaged → In Progress
Revision history for this message
Frank Heimes (fheimes) wrote :

The upstream stable patch set v5.4.26 was now applied that implicitly includes this patch.
Hence changing the status to Fix Committed.

Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Revision history for this message
Frank Heimes (fheimes) wrote :

Landed in focal master:
96225dde40a6 s390/dasd: fix data corruption for thin provisioned devices
and also in the current kernel.
Hence updating ticket to Fix Released.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2020-04-06 03:30 EDT-------
IBm Bugzill status-> closed, Fix Released with focal

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-07-27 10:40 EDT-------
Verified that the fix is included in Ubuntu 20.04 and working as intended.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers