[Ubuntu - 18.04] OSA-7 25 GBit Support in Ubuntu 18.04

Bug #1860972 reported by bugproxy on 2020-01-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Undecided
Unassigned
linux (Ubuntu)
Undecided
Skipper Bug Screeners

Bug Description

Following git-commt is requested to be integrated within Ubuntu 18.04.

commit 54e049c227d9968ff6a7d80aae5fec27b54d39da
Author: Julian Wiedmann <email address hidden>
Date: Fri Nov 2 19:04:13 2018 +0100
s390/qeth: report 25Gbit link speed
This adds the various identifiers for 25Gbit cards, and wires them up
into sysfs and ethtool.

Available with kernel 4.20 , therefore available with all distros in service , except 18.04, where this feature need a backport to kernel 4.15.

After checking the code, it should apply seamlessly.

bugproxy (bugproxy) on 2020-01-27
tags: added: architecture-s39064 bugnameltc-183465 severity-high targetmilestone-inin1804
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Frank Heimes (fheimes) wrote :

Looking up this git commit in bionic master tells me that it is already in:
$ git log --oneline --grep "s390/qeth: report 25Gbit link speed"
9344fbf s390/qeth: report 25Gbit link speed

And it's in since Ubuntu kernel 4.15.0-48.51 (and newer):
$ git tag --contains 9344fbf
Ubuntu-4.15.0-48.51

So it's in since quite some time, since we are today at 4.15.0.74:
 linux-generic | 4.15.0.20.23 | bionic | s390x
 linux-generic | 4.15.0.74.76 | bionic-security | s390x
 linux-generic | 4.15.0.74.76 | bionic-updates | s390x
 linux-generic | 4.15.0.76.78 | bionic-proposed | s390x

According to the git log it was picked up by bionic's 18.04 kernel with LP 1814892
https://bugs.launchpad.net/bugs/1814892

Hence closing this ticket as Fix Released.

Changed in linux (Ubuntu):
status: New → Fix Released
Changed in ubuntu-z-systems:
status: New → Fix Released
Frank Heimes (fheimes) wrote :

... and also marking it as duplicate of LP 1814892

------- Comment From <email address hidden> 2020-01-27 07:44 EDT-------
IBM Bugzilla status -> closed, Already fix released ...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers