Ricoh R5C843 card reader doesn't work on vaio thinkpad

Bug #186087 reported by Jan Ask on 2008-01-26
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Unassigned

Bug Description

Tested on Vaio VGN TZ 50 B

When inserting a SD card, it is not recognized. 'lspci | grep Ricoh' results in:
09:04.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 11)

Please let me know what to do to supply more information

Thank you for taking the time to report this bug and helping to make Ubuntu better. The Hardy Heron Alpha series was recently released and contains an updated version of the kernel. You can download and try the new Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. General information regarding the release can also be found here: http://www.ubuntu.com/testing/ . Thanks.

This bug is still present under the newest release of Hardy, tested
this morning.

Please let me know if you need more details

On Feb 6, 2008 7:16 AM, Leann Ogasawara <email address hidden> wrote:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. The Hardy Heron Alpha series was recently released and
> contains an updated version of the kernel. You can download and try the
> new Hardy Heron Alpha release from
> http://cdimage.ubuntu.com/releases/hardy/ . You should be able to then
> test the new kernel via the LiveCD. If you can, please verify if this
> bug still exists or not and report back your results. General
> information regarding the release can also be found here:
> http://www.ubuntu.com/testing/ . Thanks.
>
> ** Changed in: linux (Ubuntu)
> Sourcepackagename: None => linux
> Status: New => Incomplete
>
>
> --
> Ricoh R5C843 card reader doesn't work on vaio thinkpad
> https://bugs.launchpad.net/bugs/186087
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
305-0821 Ibaraki-ken
Tsukuba-shi, Kasuga 2 Choume 3-5-103
Japan

(+81) 090 7437 6242
<email address hidden>

Per the kernel team's bug policy, can you please attach the following information. Please be sure to attach each file as a separate attachment.

* uname -a > uname-a.log
* cat /proc/version_signature > version.log
* dmesg > dmesg.log
* sudo lspci -vvnn > lspci-vvnn.log

For more information regarding the kernel team bug policy, please refer to https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks again and we appreciate your help and feedback.

Jan Ask (janaskhoej-gmail) wrote :

dmesg.log

Jan Ask (janaskhoej-gmail) wrote :

lspci-vvnn.log

Jan Ask (janaskhoej-gmail) wrote :

uname-a.log

Jan Ask (janaskhoej-gmail) wrote :

version.log

Hi Jan,

Care to just reconfirm against the latest Hardy Alpha 6 that this is still an issue and reattach an updated dmesg output for the kernel team. Thanks.

Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Incomplete → Triaged
Jan Ask (janaskhoej-gmail) wrote :

This is still a problem with the latest Hardy Alpha 6. I have attached dmesg as requested. Thanks.

Stéphane Graber (stgraber) wrote :

I can confirm the same problem with all the new HP business laptop I tried.
On my 8510p :
stgraber@castiana:~$ lspci -nnn | grep Ricoh
02:06.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev b9)
02:06.1 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev b9)
02:06.2 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832] (rev 03)
02:06.3 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 20)
02:06.4 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 10)

stgraber@castiana:~$ dmesg | grep mmc
[ 14.904490] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[ 22.230039] ricoh-mmc: Ricoh MMC Controller disabling driver
[ 22.230041] ricoh-mmc: Copyright(c) Philip Langdale
[ 22.483171] ricoh-mmc: Ricoh MMC controller found at 0000:02:06.4 [1180:0843] (rev 10)
[ 22.483190] ricoh-mmc: Controller is now disabled.
[ 22.484200] mmc0: SDHCI at 0xe4103000 irq 19 DMA

That's on 2.6.24-12-generic on amd64 with SD/MMC reader is enabled in the BIOS.
Please ask if you need more details.

Stéphane

EinKinder (julien-tremblay) wrote :

It works for me (Hardy Beta on Dell Inspiron 6400/e1505) with both SD and MMC

However, it disappears after a standby-resume cycle, as per Bug #205823

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

Stéphane Graber (stgraber) wrote :

Intrepid's kernel fixed the issue here.
2.6.26 worked only at boot time, now with 2.6.27 it always worked.
Marking the report fix released, if someone still has the issue, feel free to reopen.

Changed in linux:
status: Triaged → Fix Released
Cleber Santz (clebersantz) wrote :

I have the same issue on HP DV 6130

Linux 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i686 GNU/Linux

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers