Fix misleading error message: Configuring the VNIC characteristics failed

Bug #1860523 reported by bugproxy on 2020-01-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
High
Canonical Kernel Team
linux (Ubuntu)
Status tracked in Focal
Bionic
Undecided
Unassigned
Eoan
Undecided
Unassigned
Focal
Undecided
Skipper Bug Screeners

Bug Description

SRU Justification:
------------------

[Impact]

* For devices that don't support the 'INVISIBLE' characteristic (ie. OSA), the resulting IO failure raises the noisy error message "Configuring the VNIC characteristics failed"

* The INVISIBLE characteristic unconditionally gets switched off, which is reverted with this patch.

* For Internal Queued Direct communication (IQD) 'INVISIBLE' is off by default.

* Hence the INVISIBLE characteristic case is unnecessary.

[Fix]

* 68c57bfd52836e31bff33e5e1fc64029749d2c35 68c57bf "s390/qeth: fix false reporting of VNIC CHAR config failure"

* Upstream accepted with v5.5-rc5, but backport for 4.19-stable and 5.4-stable here: https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git

[Test Case]

* Configure an IBM z15 for LinuxONE III machine with at least one OSA adapter.

* Check dmsg for message "Configuring the VNIC characteristics failed" while setting an OSA device online.

[Regression Potential]

* The regression potential is low, since the patch is limited to a single line

* again limited to the s390x architecture and once again limited to the qeth network driver

* and on z15 hardware only.

[Other Info]

* This bug was identified at IBM while testing and is now rolled out to several different kernels.

* Once the patch got applied to the Ubuntu kernel(s) and a verification is required,

* this needs to be done by IBM, since Canonical doesn't have the needed machine generation.

__________

The patch titled s390/qeth: fix false reporting of VNIC CHAR config failure
has been added to the 4.19-stable tree which can be found at: http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary

The filename of the patch is: s390-qeth-fix-false-reporting-of-vnic-char-config-failure.patch and it can be found in the queue-4.19 subdirectory.

Same for the the 5.4-stable tree which can be found at: http://www.kernel.org/git/?p=linux/kernel/git/stable/stable-queue.git;a=summary

The filename of the patch is: s390-qeth-fix-vnicc_is_in_use-if-rx_bcast-not-set.patch and it can be found in the queue-5.4 subdirectory.

s390/qeth: fix false reporting of VNIC CHAR config failure
commit 68c57bfd52836e31bff33e5e1fc64029749d2c35 upstream.

Request: Please provide that fix also for Ubuntu 18.04 .

Many thanks in advance

bugproxy (bugproxy) on 2020-01-22
tags: added: architecture-s39064 bugnameltc-183400 severity-high targetmilestone-inin1804
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Changed in ubuntu-z-systems:
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)
Frank Heimes (fheimes) on 2020-01-22
Changed in ubuntu-z-systems:
importance: Undecided → High
Frank Heimes (fheimes) wrote :

./stable-queue-4.19.97/releases/4.19.97/s390-qeth-fix-false-reporting-of-vnic-char-config-failure.patch
./stable-queue-4.19.97/queue-5.4/s390-qeth-fix-false-reporting-of-vnic-char-config-failure.patch

Frank Heimes (fheimes) wrote :

This needs to be SRUed to bionic (4.15), eoan (5.3) and also patched to focal (5.4).

Frank Heimes (fheimes) on 2020-01-22
summary: - [UBUNTU-18.04] Fix for "Configuring the VNIC characteristics failed"
+ [UBUNTU] Fix the misleading error message: Configuring the VNIC
+ characteristics failed
Frank Heimes (fheimes) on 2020-01-27
summary: - [UBUNTU] Fix the misleading error message: Configuring the VNIC
+ [UBUNTU] Fix misleading error message: Configuring the VNIC
characteristics failed
summary: - [UBUNTU] Fix misleading error message: Configuring the VNIC
- characteristics failed
+ Fix misleading error message: Configuring the VNIC characteristics
+ failed
Frank Heimes (fheimes) wrote :

Kernel SRU request submitted:
https://lists.ubuntu.com/archives/kernel-team/2020-January/thread.html#107097
changing status to 'In Progress'

description: updated
Changed in linux (Ubuntu Focal):
status: New → In Progress
Changed in linux (Ubuntu Eoan):
status: New → In Progress
Changed in linux (Ubuntu Bionic):
status: New → In Progress
Changed in ubuntu-z-systems:
status: New → In Progress
Changed in linux (Ubuntu Bionic):
status: In Progress → Triaged
Changed in linux (Ubuntu Eoan):
status: In Progress → Triaged
Changed in linux (Ubuntu Focal):
status: In Progress → Triaged
Changed in linux (Ubuntu Bionic):
status: Triaged → Fix Committed
Changed in linux (Ubuntu Eoan):
status: Triaged → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-eoan' to 'verification-done-eoan'. If the problem still exists, change the tag 'verification-needed-eoan' to 'verification-failed-eoan'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-eoan

------- Comment From <email address hidden> 2020-02-04 08:42 EDT-------
Verified upstream by IBM.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-02-04 09:09 EDT-------
updating IBM response for verification.
-> Verified upfront by IBM

Frank Heimes (fheimes) wrote :

Adjusting tags according to previous comments.

tags: added: verification-done-bionic verification-done-eoan
removed: verification-needed-bionic verification-needed-eoan
Frank Heimes (fheimes) wrote :

The commit "s390/qeth: fix false reporting of VNIC CHAR config failure"
is in focal master-next and tagged with:
Ubuntu-5.4-5.4.0-13.16
Ubuntu-5.4-5.4.0-14.17
We have currently the following kernels in focal:
 linux-generic | 5.4.0.12.15 | focal | s390x
 linux-generic | 5.4.0.13.16 | focal-proposed | s390x

Hence the above patch is not yet in 5.4.0.12.15 that's currently in the release pocket, but already in proposed. Hence changing the focal status here to Fix Committed.

Changed in linux (Ubuntu Focal):
status: Triaged → Fix Committed
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (78.1 KiB)

This bug was fixed in the package linux - 5.3.0-40.32

---------------
linux (5.3.0-40.32) eoan; urgency=medium

  * eoan/linux: 5.3.0-40.32 -proposed tracker (LP: #1861214)

  * No sof soundcard for 'ASoC: CODEC DAI intel-hdmi-hifi1 not registered' after
    modprobe sof (LP: #1860248)
    - ASoC: SOF: Intel: fix HDA codec driver probe with multiple controllers

  * ocfs2-tools is causing kernel panics in Ubuntu Focal (Ubuntu-5.4.0-9.12)
    (LP: #1852122)
    - ocfs2: fix the crash due to call ocfs2_get_dlm_debug once less

  * QAT drivers for C3XXX and C62X not included as modules (LP: #1845959)
    - [Config] CRYPTO_DEV_QAT_C3XXX=m, CRYPTO_DEV_QAT_C62X=m and
      CRYPTO_DEV_QAT_DH895xCC=m

  * Eoan update: upstream stable patchset 2020-01-24 (LP: #1860816)
    - scsi: lpfc: Fix discovery failures when target device connectivity bounces
    - scsi: mpt3sas: Fix clear pending bit in ioctl status
    - scsi: lpfc: Fix locking on mailbox command completion
    - Input: atmel_mxt_ts - disable IRQ across suspend
    - f2fs: fix to update time in lazytime mode
    - iommu: rockchip: Free domain on .domain_free
    - iommu/tegra-smmu: Fix page tables in > 4 GiB memory
    - dmaengine: xilinx_dma: Clear desc_pendingcount in xilinx_dma_reset
    - scsi: target: compare full CHAP_A Algorithm strings
    - scsi: lpfc: Fix SLI3 hba in loop mode not discovering devices
    - scsi: csiostor: Don't enable IRQs too early
    - scsi: hisi_sas: Replace in_softirq() check in hisi_sas_task_exec()
    - powerpc/pseries: Mark accumulate_stolen_time() as notrace
    - powerpc/pseries: Don't fail hash page table insert for bolted mapping
    - powerpc/tools: Don't quote $objdump in scripts
    - dma-debug: add a schedule point in debug_dma_dump_mappings()
    - leds: lm3692x: Handle failure to probe the regulator
    - clocksource/drivers/asm9260: Add a check for of_clk_get
    - clocksource/drivers/timer-of: Use unique device name instead of timer
    - powerpc/security/book3s64: Report L1TF status in sysfs
    - powerpc/book3s64/hash: Add cond_resched to avoid soft lockup warning
    - ext4: update direct I/O read lock pattern for IOCB_NOWAIT
    - ext4: iomap that extends beyond EOF should be marked dirty
    - jbd2: Fix statistics for the number of logged blocks
    - scsi: tracing: Fix handling of TRANSFER LENGTH == 0 for READ(6) and WRITE(6)
    - scsi: lpfc: Fix duplicate unreg_rpi error in port offline flow
    - f2fs: fix to update dir's i_pino during cross_rename
    - clk: qcom: Allow constant ratio freq tables for rcg
    - clk: clk-gpio: propagate rate change to parent
    - irqchip/irq-bcm7038-l1: Enable parent IRQ if necessary
    - irqchip: ingenic: Error out if IRQ domain creation failed
    - fs/quota: handle overflows of sysctl fs.quota.* and report as unsigned long
    - scsi: lpfc: fix: Coverity: lpfc_cmpl_els_rsp(): Null pointer dereferences
    - PCI: rpaphp: Fix up pointer to first drc-info entry
    - scsi: ufs: fix potential bug which ends in system hang
    - powerpc/pseries/cmm: Implement release() function for sysfs device
    - PCI: rpaphp: Don't rely on firmware feature to imply drc-info support
    - PCI: rpaphp: Annotate and corr...

Changed in linux (Ubuntu Eoan):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (79.8 KiB)

This bug was fixed in the package linux - 4.15.0-88.88

---------------
linux (4.15.0-88.88) bionic; urgency=medium

  * bionic/linux: 4.15.0-88.88 -proposed tracker (LP: #1862824)

  * Segmentation fault (kernel oops) with memory-hotplug in
    ubuntu_kernel_selftests on Bionic kernel (LP: #1862312)
    - Revert "mm/memory_hotplug: fix online/offline_pages called w.o.
      mem_hotplug_lock"
    - mm/memory_hotplug: fix online/offline_pages called w.o. mem_hotplug_lock

linux (4.15.0-87.87) bionic; urgency=medium

  * bionic/linux: 4.15.0-87.87 -proposed tracker (LP: #1861165)

  * Bionic update: upstream stable patchset 2020-01-22 (LP: #1860602)
    - scsi: lpfc: Fix discovery failures when target device connectivity bounces
    - scsi: mpt3sas: Fix clear pending bit in ioctl status
    - scsi: lpfc: Fix locking on mailbox command completion
    - Input: atmel_mxt_ts - disable IRQ across suspend
    - iommu/tegra-smmu: Fix page tables in > 4 GiB memory
    - scsi: target: compare full CHAP_A Algorithm strings
    - scsi: lpfc: Fix SLI3 hba in loop mode not discovering devices
    - scsi: csiostor: Don't enable IRQs too early
    - powerpc/pseries: Mark accumulate_stolen_time() as notrace
    - powerpc/pseries: Don't fail hash page table insert for bolted mapping
    - powerpc/tools: Don't quote $objdump in scripts
    - dma-debug: add a schedule point in debug_dma_dump_mappings()
    - clocksource/drivers/asm9260: Add a check for of_clk_get
    - powerpc/security/book3s64: Report L1TF status in sysfs
    - powerpc/book3s64/hash: Add cond_resched to avoid soft lockup warning
    - ext4: update direct I/O read lock pattern for IOCB_NOWAIT
    - jbd2: Fix statistics for the number of logged blocks
    - scsi: tracing: Fix handling of TRANSFER LENGTH == 0 for READ(6) and WRITE(6)
    - scsi: lpfc: Fix duplicate unreg_rpi error in port offline flow
    - f2fs: fix to update dir's i_pino during cross_rename
    - clk: qcom: Allow constant ratio freq tables for rcg
    - irqchip/irq-bcm7038-l1: Enable parent IRQ if necessary
    - irqchip: ingenic: Error out if IRQ domain creation failed
    - fs/quota: handle overflows of sysctl fs.quota.* and report as unsigned long
    - scsi: lpfc: fix: Coverity: lpfc_cmpl_els_rsp(): Null pointer dereferences
    - scsi: ufs: fix potential bug which ends in system hang
    - powerpc/pseries/cmm: Implement release() function for sysfs device
    - powerpc/security: Fix wrong message when RFI Flush is disable
    - scsi: atari_scsi: sun3_scsi: Set sg_tablesize to 1 instead of SG_NONE
    - clk: pxa: fix one of the pxa RTC clocks
    - bcache: at least try to shrink 1 node in bch_mca_scan()
    - HID: logitech-hidpp: Silence intermittent get_battery_capacity errors
    - libnvdimm/btt: fix variable 'rc' set but not used
    - HID: Improve Windows Precision Touchpad detection.
    - scsi: pm80xx: Fix for SATA device discovery
    - scsi: ufs: Fix error handing during hibern8 enter
    - scsi: scsi_debug: num_tgts must be >= 0
    - scsi: NCR5380: Add disconnect_mask module parameter
    - scsi: iscsi: Don't send data to unbound connection
    - scsi: target: iscsi: Wait for all commands to finish before freeing a
...

Changed in linux (Ubuntu Bionic):
status: Fix Committed → Fix Released
Frank Heimes (fheimes) wrote :

On the kernel teams mailing list this was 'NACK'ed for focal, but only because it has already been applied from 5.4 stable.
I just double checked and the commit is in focal master (since Ubuntu-5.4-5.4.0-13.16 and there is currently 5.4.0.14.17 in focals release pocket).
Hence I change the focal entry to Fix Released and with that the project entry, too.

Changed in linux (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-02-17 10:13 EDT-------
IBM bugzilla status -> closed, Fix Released by all requested distros

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers