Eoan update: 5.3.14 upstream stable release

Bug #1854861 reported by Connor Kuehl on 2019-12-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Eoan
Medium
Connor Kuehl

Bug Description

SRU Justification

    Impact:
       The upstream process for stable tree updates is quite similar
       in scope to the Ubuntu SRU process, e.g., each patch has to
       demonstrably fix a bug, and each patch is vetted by upstream
       by originating either directly from a mainline/stable Linux tree or
       a minimally backported form of that patch. The following upstream
       stable patches should be included in the Ubuntu kernel:

* mlxsw: spectrum_router: Fix determining underlay for a GRE tunnel
* net/mlx4_en: fix mlx4 ethtool -N insertion
* net/mlx4_en: Fix wrong limitation for number of TX rings
* net: rtnetlink: prevent underflows in do_setvfinfo()
* net/sched: act_pedit: fix WARN() in the traffic path
* net: sched: ensure opts_len <= IP_TUNNEL_OPTS_MAX in act_tunnel_key
* sfc: Only cancel the PPS workqueue if it exists
* net/mlxfw: Verify FSM error code translation doesn't exceed array size
* net/mlx5e: Fix set vf link state error flow
* net/mlx5: Fix auto group size calculation
* net/tls: enable sk_msg redirect to tls socket egress
* ipv6/route: return if there is no fib_nh_gw_family
* taprio: don't reject same mqprio settings
* net/ipv4: fix sysctl max for fib_multipath_hash_policy
* net/mlx5e: Fix error flow cleanup in mlx5e_tc_tun_create_header_ipv4/6
* net/mlx5e: Do not use non-EXT link modes in EXT mode
* net/mlx5: Update the list of the PCI supported devices
* vhost/vsock: split packets to send using multiple buffers
* gpio: max77620: Fixup debounce delays
* gpio: bd70528: Use correct unit for debounce times
* tools: gpio: Correctly add make dependencies for gpio_utils
* fork: fix pidfd_poll()'s return type
* nbd:fix memory leak in nbd_get_socket()
* virtio_console: allocate inbufs in add_port() only if it is needed
* virtio_ring: fix return code on DMA mapping fails
* virtio_balloon: fix shrinker count
* Revert "fs: ocfs2: fix possible null-pointer dereferences in ocfs2_xa_prepare_entry()"
* mm/memory_hotplug: don't access uninitialized memmaps in shrink_zone_span()
* mm/ksm.c: don't WARN if page is still mapped in remove_stable_node()
* drm/amdgpu: disable gfxoff when using register read interface
* drm/amdgpu: disable gfxoff on original raven
* drm/amd/powerplay: issue no PPSMC_MSG_GetCurrPkgPwr on unsupported ASICs
* drm/i915: Don't oops in dumb_create ioctl if we have no crtcs
* drm/i915/pmu: "Frequency" is reported as accumulated cycles
* drm/i915/userptr: Try to acquire the page lock around set_page_dirty()
* Bluetooth: Fix invalid-free in bcsp_close()
* ath10k: restore QCA9880-AR1A (v1) detection
* ath10k: Fix HOST capability QMI incompatibility
* ath10k: Fix a NULL-ptr-deref bug in ath10k_usb_alloc_urb_from_pipe
* ath9k_hw: fix uninitialized variable data
* Revert "Bluetooth: hci_ll: set operational frequency earlier"
* Revert "dm crypt: use WQ_HIGHPRI for the IO and crypt workqueues"
* md/raid10: prevent access of uninitialized resync_pages offset
* mdio_bus: Fix init if CONFIG_RESET_CONTROLLER=n
* ARM: 8904/1: skip nomap memblocks while finding the lowmem/highmem boundary
* x86/insn: Fix awk regexp warnings
* x86/speculation: Fix incorrect MDS/TAA mitigation status
* x86/speculation: Fix redundant MDS mitigation message
* nbd: prevent memory leak
* gve: fix dma sync bug where not all pages synced
* x86/stackframe/32: Repair 32-bit Xen PV
* x86/xen/32: Make xen_iret_crit_fixup() independent of frame layout
* x86/xen/32: Simplify ring check in xen_iret_crit_fixup()
* x86/doublefault/32: Fix stack canaries in the double fault handler
* x86/pti/32: Size initial_page_table correctly
* x86/cpu_entry_area: Add guard page for entry stack on 32bit
* x86/entry/32: Fix IRET exception
* x86/entry/32: Use %ss segment where required
* x86/entry/32: Move FIXUP_FRAME after pushing %fs in SAVE_ALL
* x86/entry/32: Unwind the ESPFIX stack earlier on exception entry
* x86/entry/32: Fix NMI vs ESPFIX
* selftests/x86/mov_ss_trap: Fix the SYSENTER test
* selftests/x86/sigreturn/32: Invalidate DS and ES when abusing the kernel
* x86/pti/32: Calculate the various PTI cpu_entry_area sizes correctly, make the CPU_ENTRY_AREA_PAGES assert precise
* x86/entry/32: Fix FIXUP_ESPFIX_STACK with user CR3
* futex: Prevent robust futex exit race
* ALSA: usb-audio: Fix NULL dereference at parsing BADD
* nfc: port100: handle command failure cleanly
* media: vivid: Set vid_cap_streaming and vid_out_streaming to true
* media: vivid: Fix wrong locking that causes race conditions on streaming stop
* media: usbvision: Fix invalid accesses after device disconnect
* media: usbvision: Fix races among open, close, and disconnect
* cpufreq: Add NULL checks to show() and store() methods of cpufreq
* media: uvcvideo: Fix error path in control parsing failure
* media: b2c2-flexcop-usb: add sanity checking
* media: cxusb: detect cxusb_ctrl_msg error in query
* media: imon: invalid dereference in imon_touch_event
* media: mceusb: fix out of bounds read in MCE receiver buffer
* mm/slub.c: init_on_free=1 should wipe freelist ptr for bulk allocations
* USBIP: add config dependency for SGL_ALLOC
* usbip: tools: fix fd leakage in the function of read_attr_usbip_status
* usbip: Fix uninitialized symbol 'nents' in stub_recv_cmd_submit()
* usb-serial: cp201x: support Mark-10 digital force gauge
* USB: chaoskey: fix error case of a timeout
* appledisplay: fix error handling in the scheduled work
* USB: serial: mos7840: add USB ID to support Moxa UPort 2210
* USB: serial: mos7720: fix remote wakeup
* USB: serial: mos7840: fix remote wakeup
* USB: serial: option: add support for DW5821e with eSIM support
* USB: serial: option: add support for Foxconn T77W968 LTE modules
* staging: comedi: usbduxfast: usbduxfast_ai_cmdtest rounding error
* Linux 5.3.14
* UBUNTU: upstream stable to v5.3.14

       5.3.14 upstream stable release
       from git://git.kernel.org/

Connor Kuehl (connork) on 2019-12-02
Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: kernel-stable-tracking-bug
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu Eoan):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Connor Kuehl (connork)
Connor Kuehl (connork) on 2019-12-04
description: updated
Connor Kuehl (connork) wrote :

Note the following patches were skipped since they were already applied:

* powerpc/64s: support nospectre_v2 cmdline option
* powerpc/book3s64: Fix link stack flush on context switch
* KVM: PPC: Book3S HV: Flush link stack on guest exit to host kernel

Changed in linux (Ubuntu Eoan):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (78.1 KiB)

This bug was fixed in the package linux - 5.3.0-40.32

---------------
linux (5.3.0-40.32) eoan; urgency=medium

  * eoan/linux: 5.3.0-40.32 -proposed tracker (LP: #1861214)

  * No sof soundcard for 'ASoC: CODEC DAI intel-hdmi-hifi1 not registered' after
    modprobe sof (LP: #1860248)
    - ASoC: SOF: Intel: fix HDA codec driver probe with multiple controllers

  * ocfs2-tools is causing kernel panics in Ubuntu Focal (Ubuntu-5.4.0-9.12)
    (LP: #1852122)
    - ocfs2: fix the crash due to call ocfs2_get_dlm_debug once less

  * QAT drivers for C3XXX and C62X not included as modules (LP: #1845959)
    - [Config] CRYPTO_DEV_QAT_C3XXX=m, CRYPTO_DEV_QAT_C62X=m and
      CRYPTO_DEV_QAT_DH895xCC=m

  * Eoan update: upstream stable patchset 2020-01-24 (LP: #1860816)
    - scsi: lpfc: Fix discovery failures when target device connectivity bounces
    - scsi: mpt3sas: Fix clear pending bit in ioctl status
    - scsi: lpfc: Fix locking on mailbox command completion
    - Input: atmel_mxt_ts - disable IRQ across suspend
    - f2fs: fix to update time in lazytime mode
    - iommu: rockchip: Free domain on .domain_free
    - iommu/tegra-smmu: Fix page tables in > 4 GiB memory
    - dmaengine: xilinx_dma: Clear desc_pendingcount in xilinx_dma_reset
    - scsi: target: compare full CHAP_A Algorithm strings
    - scsi: lpfc: Fix SLI3 hba in loop mode not discovering devices
    - scsi: csiostor: Don't enable IRQs too early
    - scsi: hisi_sas: Replace in_softirq() check in hisi_sas_task_exec()
    - powerpc/pseries: Mark accumulate_stolen_time() as notrace
    - powerpc/pseries: Don't fail hash page table insert for bolted mapping
    - powerpc/tools: Don't quote $objdump in scripts
    - dma-debug: add a schedule point in debug_dma_dump_mappings()
    - leds: lm3692x: Handle failure to probe the regulator
    - clocksource/drivers/asm9260: Add a check for of_clk_get
    - clocksource/drivers/timer-of: Use unique device name instead of timer
    - powerpc/security/book3s64: Report L1TF status in sysfs
    - powerpc/book3s64/hash: Add cond_resched to avoid soft lockup warning
    - ext4: update direct I/O read lock pattern for IOCB_NOWAIT
    - ext4: iomap that extends beyond EOF should be marked dirty
    - jbd2: Fix statistics for the number of logged blocks
    - scsi: tracing: Fix handling of TRANSFER LENGTH == 0 for READ(6) and WRITE(6)
    - scsi: lpfc: Fix duplicate unreg_rpi error in port offline flow
    - f2fs: fix to update dir's i_pino during cross_rename
    - clk: qcom: Allow constant ratio freq tables for rcg
    - clk: clk-gpio: propagate rate change to parent
    - irqchip/irq-bcm7038-l1: Enable parent IRQ if necessary
    - irqchip: ingenic: Error out if IRQ domain creation failed
    - fs/quota: handle overflows of sysctl fs.quota.* and report as unsigned long
    - scsi: lpfc: fix: Coverity: lpfc_cmpl_els_rsp(): Null pointer dereferences
    - PCI: rpaphp: Fix up pointer to first drc-info entry
    - scsi: ufs: fix potential bug which ends in system hang
    - powerpc/pseries/cmm: Implement release() function for sysfs device
    - PCI: rpaphp: Don't rely on firmware feature to imply drc-info support
    - PCI: rpaphp: Annotate and corr...

Changed in linux (Ubuntu Eoan):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers