[21.10 FEAT] SMC: Statistics Support (kernel)

Bug #1853290 reported by bugproxy
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
Medium
Skipper Bug Screeners
linux (Ubuntu)
Fix Released
Undecided
Canonical Kernel Team

Bug Description

Add statistics for traffic run across RoCE (RDMA) and ISM devices. Most like requires a new tool in smc-tools that queries the stats from the smc module via netlink.

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-179233 severity-high targetmilestone-inin2004
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Revision history for this message
Frank Heimes (fheimes) wrote :

What is the planned target kernel this is going to become upstream accepted?
Changing to Incomplete for now.

Changed in ubuntu-z-systems:
status: New → Incomplete
Changed in linux (Ubuntu):
status: New → Incomplete
Changed in ubuntu-z-systems:
importance: Undecided → Medium
assignee: nobody → Frank Heimes (frank-heimes)
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2019-11-22 08:03 EDT-------
Planned Target : kernel 5.4

Revision history for this message
Frank Heimes (fheimes) wrote : Re: [20.04 FEAT] SMC: Statistics Support

Since kernel 5.4 landed in focal proposed n between:
linux-generic | 5.4.0.8.9 | focal-proposed | s390x
status gets updated to Fix Committed.

Changed in linux (Ubuntu):
status: Incomplete → Fix Committed
Changed in ubuntu-z-systems:
status: Incomplete → Fix Committed
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2019-12-16 08:48 EDT-------
Sorry for the fault here:
New Target: kernel >= 5.6

Therefore , please reset to "Incomplete"

Revision history for this message
Frank Heimes (fheimes) wrote : Re: [20.04 FEAT] SMC: Statistics Support

Changed back to Incomplete according to comment #4.

Changed in ubuntu-z-systems:
status: Fix Committed → Incomplete
Changed in linux (Ubuntu):
status: Fix Committed → Incomplete
summary: - [20.04 FEAT] SMC: Statistics Support
+ [20.10 FEAT] SMC: Statistics Support
bugproxy (bugproxy)
tags: added: targetmilestone-inin2010
removed: targetmilestone-inin2004
Revision history for this message
Frank Heimes (fheimes) wrote : Re: [20.10 FEAT] SMC: Statistics Support

Did this landed in 5.8 or does it need to be moved to 21.04 now?

summary: - [20.10 FEAT] SMC: Statistics Support
+ [21.04 FEAT] SMC: Statistics Support
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2020-09-04 03:46 EDT-------
Feature will not make it in time for 20.10, moved to 21.04

tags: added: targetmilestone-inin2104
removed: targetmilestone-inin2010
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
assignee: Frank Heimes (fheimes) → Skipper Bug Screeners (skipper-screen-team)
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-12-09 07:39 EDT-------
Will be made available with kernel 5.11

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-12-09 07:53 EDT-------
Wrong info, currently still in work

summary: - [21.04 FEAT] SMC: Statistics Support
+ [21.10 FEAT] SMC: Statistics Support
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-02-01 08:07 EDT-------
Feature will not make it for 21.04, moved to 21.10

tags: added: targetmilestone-inin2110
removed: targetmilestone-inin2104
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-08-04 12:22 EDT-------
This feature is part of the linux kernel 5.14. In order to enable the feature for a 5.13 kernel, please apply the following patches from kernel upstream.

e0e4b8fa533858532f1b9ea9c6a4660d09beb37a
8c40602b4be17571dfd75102f4f1e690311c5210
f0dd7bf5e33066e554442c509ef6351728b95b51
194730a9beb52d2b030ea45e12d94868d4a0e6fd
1a1100d53f12451d50bc5ebbc941517760912ab8
17081633e22d83be928a779fd7acd04b247dec90

Frank Heimes (fheimes)
Changed in linux (Ubuntu):
status: Incomplete → New
Changed in ubuntu-z-systems:
status: Incomplete → Triaged
Changed in linux (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Frank Heimes (fheimes)
Frank Heimes (fheimes)
Changed in linux (Ubuntu):
status: New → Triaged
Revision history for this message
Frank Heimes (fheimes) wrote : Re: [21.10 FEAT] SMC: Statistics Support

A patched impish kernel 5.13 is being build here for further testing:
https://launchpad.net/~fheimes/+archive/ubuntu/lp1853290

Revision history for this message
Frank Heimes (fheimes) wrote :

Patch request submitted:
https://lists.ubuntu.com/archives/kernel-team/2021-August/thread.html#123188
changing status to 'In Progress'.

Changed in linux (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-z-systems:
status: Triaged → In Progress
Changed in linux (Ubuntu):
assignee: Frank Heimes (fheimes) → Canonical Kernel Team (canonical-kernel-team)
Frank Heimes (fheimes)
information type: Private → Public
Frank Heimes (fheimes)
summary: - [21.10 FEAT] SMC: Statistics Support
+ [21.10 FEAT] SMC: Statistics Support (kernel)
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Frank Heimes (fheimes)
Changed in linux (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Revision history for this message
Andy Whitcroft (apw) wrote :

Though this is not at all clear, this focal verification request is for focal:linux-oem-5.13.

Revision history for this message
Frank Heimes (fheimes) wrote :

Ok, since there is no linux-oem-5.13 for s390x, I'm setting the tags to "verification done on focal", to unblock this ticket. (Thx for the clarification apw.)

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package linux - 5.13.0-16.16

---------------
linux (5.13.0-16.16) impish; urgency=medium

  * impish/linux: 5.13.0-16.16 -proposed tracker (LP: #1942611)

  * Miscellaneous Ubuntu changes
    - [Config] update toolchain in configs

  * Miscellaneous upstream changes
    - Revert "UBUNTU: [Config] Enable CONFIG_UBSAN_BOUNDS"

 -- Andrea Righi <email address hidden> Fri, 03 Sep 2021 16:21:14 +0200

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2021-09-17 05:13 EDT-------
Fix landed in impish / 21.10, hence closing the bug.
Changing IBM BZ status: ->CLOSED

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers