[21.04 FEAT] Log DASD EDIF capability - kernel

Bug #1853275 reported by bugproxy
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Frank Heimes
linux (Ubuntu)
Fix Released
High
Skipper Bug Screeners

Bug Description

A Linux on Z user can find out if a DASD volume is being accessed using authenticated or encrypted links, both in the running system, but also based on kernel logs.

Target: kernel >= kernel 5.5

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-177149 severity-high targetmilestone-inin2004
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Revision history for this message
Frank Heimes (fheimes) wrote :

As of today he target kernel that is planned for Focal is kernel 5.4.
So please provide the patches/commit-IDs as soon as available for potential SRU.
Changing status to Incomplete for now.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in ubuntu-z-systems:
status: New → Incomplete
importance: Undecided → Medium
assignee: nobody → Frank Heimes (frank-heimes)
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2019-11-22 08:03 EDT-------
Planned Target : kernel 5.5

summary: - [20.04 FEAT] Log DASD EDIF capability - kernel
+ [20.10 FEAT] Log DASD EDIF capability - kernel
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-02-03 10:40 EDT-------
Feature will not make it in time for Ubuntu 20.04 -> moved to 20.10

tags: added: targetmilestone-inin2010
removed: targetmilestone-inin2004
summary: - [20.10 FEAT] Log DASD EDIF capability - kernel
+ [21.04 FEAT] Log DASD EDIF capability - kernel
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2020-08-03 08:39 EDT-------
Moved to 21.04, will not make it in time fro 20.10

tags: added: targetmilestone-inin2104
removed: targetmilestone-inin2010
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-02-19 03:57 EDT-------
Feature implemented within kernel 5.11.

Revision history for this message
Frank Heimes (fheimes) wrote :

Thx for the info.
Since 5.11 is the target kernel for hirsute I'm updating the status to Confirmed.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in ubuntu-z-systems:
status: Incomplete → Confirmed
Frank Heimes (fheimes)
Changed in linux (Ubuntu):
importance: Undecided → High
Changed in ubuntu-z-systems:
importance: Medium → High
Revision history for this message
Frank Heimes (fheimes) wrote :

Since kernel 5.11 landed in hirsute-proposed:
linux-generic | 5.11.0.11.12 | hirsute-proposed | s390x
I'm updating the status to Fix Committed.

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-z-systems:
status: Confirmed → Fix Committed
Revision history for this message
Frank Heimes (fheimes) wrote :

Since kernel 5.11 has landed in hirsute, I'm updating this ticket to Fix Released.

Changed in linux (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2021-03-24 02:36 EDT-------
IBM Bugzilla->closed, Fix Released with hursuite

Frank Heimes (fheimes)
information type: Private → Public
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers