Cannot install any release on HP Omen 17-cb0013nm

Bug #1852636 reported by Vedran Rafaelic on 2019-11-14
262
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

I tried all sorts of combinations to install 18.04.3, 19.10, 20.04 on my new laptop https://support.hp.com/us-en/product/omen-by-hp-17-cb0000-laptop-pc/26122176/document/c06411586.

baseboard: HP 8603 45.38
I tried updating BIOS: from AMI F.15 to AMI F.16 (9/5/2019 - latest).

I tried acpi=off, nomodeset, modprobe.blacklist=nouveau
none of which helped.

Graphics: Nvidia RTX 2080
Processor: i9 9880H
wifi: Intel® Wi-Fi 6 AX 200 (2x2) and Bluetooth® 5 Combo
storage: SSD

The link with the details of my try with 20.04 latest daily build (created 2019-11-14 08:09): https://askubuntu.com/questions/1188788/cannot-install-ubuntu-20-04-on-omen-by-hp-17-cb0013nm/1188791
---
ProblemType: Bug
ApportVersion: 2.20.9-0ubuntu7.7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 1768 F.... pulseaudio
CasperVersion: 1.394
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 18.04
IwConfig:
 enp60s0 no wireless extensions.

 lo no wireless extensions.
LiveMediaBuild: Ubuntu 18.04.3 LTS "Bionic Beaver" - Release amd64 (20190805)
MachineType: HP OMEN by HP Laptop 17-cb0xxx
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/username.seed boot=casper only-ubiquity quiet splash nomodeset acpi=off modprobe.blacklist=nouveau ---
ProcVersionSignature: Ubuntu 5.0.0-23.24~18.04.1-generic 5.0.15
RelatedPackageVersions:
 linux-restricted-modules-5.0.0-23-generic N/A
 linux-backports-modules-5.0.0-23-generic N/A
 linux-firmware 1.173.9
RfKill:
 0: hci0: Bluetooth
  Soft blocked: no
  Hard blocked: no
Tags: bionic
Uname: Linux 5.0.0-23-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 09/05/2019
dmi.bios.vendor: AMI
dmi.bios.version: F.16
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 8603
dmi.board.vendor: HP
dmi.board.version: 45.38
dmi.chassis.type: 10
dmi.chassis.vendor: HP
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAMI:bvrF.16:bd09/05/2019:svnHP:pnOMENbyHPLaptop17-cb0xxx:pvr:rvnHP:rn8603:rvr45.38:cvnHP:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV HP OMEN
dmi.product.name: OMEN by HP Laptop 17-cb0xxx
dmi.product.sku: 7NG00EA#BED
dmi.sys.vendor: HP

Vedran Rafaelic (croraf) on 2019-11-14
tags: added: 20.04
Paul White (paulw2u) on 2019-11-14
affects: ubuntu → ubiquity (Ubuntu)
tags: added: bionic eoan focal
removed: 20.04
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures.

At a minimum, we need:
1. The specific steps or actions you took that caused you to encounter the problem.
2. The behavior you expected.
3. The behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Vedran Rafaelic (croraf) wrote :

Can you open the last link i provided. From AskUbuntu. You have more screenshots and details about the issue there.

affects: ubiquity (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1852636

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Kai-Heng Feng (kaihengfeng) wrote :

Does "modprobe.blacklist=intel-lpss-pci" help?

Vedran Rafaelic (croraf) wrote :

I tried now "quiet splash nomodeset modprobe.blacklist=intel-lpss-pci". No help. Still a lot of ACPI error, and ACPI BIOS error.

Ending with

Vedran Rafaelic (croraf) on 2019-11-15
description: updated

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Vedran Rafaelic (croraf) wrote :

I managed to install 18.04.3 released with "nomodeset acpi=off modprobe.blacklist=nouveau", got some errors at the end, but now I did the apport-collect

Vedran Rafaelic (croraf) wrote :

looks like the install failed and it booted live, anyhow I managed to collect some logs

Paul White (paulw2u) wrote :

As per post #3, logs collected and status changed to "Confirmed".

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Vedran Rafaelic (croraf) on 2019-11-16
information type: Public → Public Security
Vedran Rafaelic (croraf) wrote :

We should perhaps only focus on the following:

Why Ubuntu 18.04.3 can be "Try out without installing" with "nomodeset acpi=off modprobe.blacklist=nouveau", but cannot be installed.

Vedran Rafaelic (croraf) wrote :

I managed to start 18.04.3 workstation "Try out without installing" with:

"nomodeset acpi=off" options

Vedran Rafaelic (croraf) wrote :

I managed to boot the "Try out 19.10" with parameters "nomodeset" and "pci=nommconf". Some ACPI errors at the begging of the boot as in the attachement:

Vedran Rafaelic (croraf) wrote :

I also managed to install with these same "nomodeset pci=nommconf" but it is pretty unstable.

As I saw "systemd[1170]: Failed to start GNOME Shell on Wayland" in "journalctl -b", I uncommented "WaylandEnable=false" in "/etc/gdm3/custom.conf". I was having black screen on boot, being able to enter CTRL+ALT+F3 though.

Here is the "journalctl -b" with "WaylandEnable=false"

Vedran Rafaelic (croraf) wrote :

I got like 175 ERRORs in the previous journalctl. I did sudo apt update and upgrade reducing to 110 errors. I installed propriatery Nvidia 435 drivers from "Software & Updates" and then booted with only "pci=nommconf" giving this journalctl:

Kai-Heng Feng (kaihengfeng) wrote :

Does "blacklist=nouveau modprobe.blacklist=nouveau" help?

Vedran Rafaelic (croraf) wrote :

I CAN work normally with my PC as per comment 25 with:
- "pci=nommconf"
- Nvidia drivers installed
- and with "WaylandEnable=false" in /etc/gdm3/custom

Just like 40-50 lines with ACPI error are present as per attached journalctl.

Which setup exactly do you want me to try, and what do you expect to happen?

To post a comment you must log in.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers