Activity log for bug #1851677

Date Who What changed Old value New value Message
2019-11-07 16:17:27 Seth Forshee bug added bug
2019-11-07 16:27:26 Seth Forshee description As reported by Jann Horn on bug 1850994, unprivileged overlayfs mounting fails in disco/eoan due to SB_I_NOSUID and SB_I_USERNS_VISIBLE. overlayfs sets SB_I_NOSUID for unprivileged mounts, which causes mount_too_revealing() to bail out as it sees SB_I_USERNS_VISIBLE as being set. Xenial has a differing conflict of s_iflags, which does not prevent unprivileged overlayfs mounts, but it should still be fixed. As reported by Jann Horn on bug 1850994, unprivileged overlayfs mounting fails in disco/eoan due to SB_I_NOSUID and SB_I_USERNS_VISIBLE. overlayfs sets SB_I_NOSUID for unprivileged mounts, which causes mount_too_revealing() to bail out as it sees SB_I_USERNS_VISIBLE as being set.
2019-11-07 16:38:39 Seth Forshee nominated for series Ubuntu Eoan
2019-11-07 16:38:39 Seth Forshee bug task added linux (Ubuntu Eoan)
2019-11-07 16:38:39 Seth Forshee nominated for series Ubuntu Disco
2019-11-07 16:38:39 Seth Forshee bug task added linux (Ubuntu Disco)
2019-11-07 16:48:48 Seth Forshee description As reported by Jann Horn on bug 1850994, unprivileged overlayfs mounting fails in disco/eoan due to SB_I_NOSUID and SB_I_USERNS_VISIBLE. overlayfs sets SB_I_NOSUID for unprivileged mounts, which causes mount_too_revealing() to bail out as it sees SB_I_USERNS_VISIBLE as being set. As reported by Jann Horn on bug 1850994, unprivileged overlayfs mounting can fail in disco/eoan due to SB_I_NOSUID and SB_I_USERNS_VISIBLE. overlayfs sets SB_I_NOSUID for unprivileged mounts, which causes mount_too_revealing() to see SB_I_USERNS_VISIBLE as being set. This leads to performing additional, unnecessary checks which may fail.
2019-11-07 16:50:24 Seth Forshee attachment added test.sh https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1851677/+attachment/5303526/+files/test.sh
2019-11-07 16:50:45 Seth Forshee linux (Ubuntu Disco): importance Undecided Medium
2019-11-07 16:50:45 Seth Forshee linux (Ubuntu Disco): status New In Progress
2019-11-07 16:50:45 Seth Forshee linux (Ubuntu Disco): assignee Seth Forshee (sforshee)
2019-11-07 16:51:02 Seth Forshee linux (Ubuntu Eoan): importance Undecided Medium
2019-11-07 16:51:02 Seth Forshee linux (Ubuntu Eoan): status New In Progress
2019-11-07 16:51:02 Seth Forshee linux (Ubuntu Eoan): assignee Seth Forshee (sforshee)
2019-11-07 17:15:04 Jann Horn (corp account) bug added subscriber Jann Horn (corp account)
2019-11-07 17:19:05 Seth Forshee description As reported by Jann Horn on bug 1850994, unprivileged overlayfs mounting can fail in disco/eoan due to SB_I_NOSUID and SB_I_USERNS_VISIBLE. overlayfs sets SB_I_NOSUID for unprivileged mounts, which causes mount_too_revealing() to see SB_I_USERNS_VISIBLE as being set. This leads to performing additional, unnecessary checks which may fail. SRU Justification Impact: SB_I_NOSUID was added by a sauce patch, and over time it has come to occpy the same bit in s_iflags as SB_I_USERNS_VISIBLE without being noticed. overlayfs will set SB_I_NOSUID when any lower mount is nosuid. When this happens for a user namespace mount, mount_too_revealing() will perform additional, unnecessary checks which may block mounting when it should be allowed. Fix: Relocate SB_I_NOSUID to the top of s_iflags to remove the conflict and to make future conflicts less likely. Test Case: Attached. Regression Potential: These flags are internal to the kernel, so moving SB_I_NOSUID is safe. It's possible that the overlapping flags caused other unintended behaviors, and if so these will also change and could result in user-visible changes. However, any such behaviors would also be incorrect. --- As reported by Jann Horn on bug 1850994, unprivileged overlayfs mounting can fail in disco/eoan due to SB_I_NOSUID and SB_I_USERNS_VISIBLE. overlayfs sets SB_I_NOSUID in some cases, which causes mount_too_revealing() to see SB_I_USERNS_VISIBLE as being set. This leads to performing additional, unnecessary checks which may fail.
2019-11-07 17:40:18 Seth Forshee linux (Ubuntu): status In Progress Fix Committed
2019-11-08 06:47:06 Khaled El Mously linux (Ubuntu Disco): status In Progress Fix Committed
2019-11-08 06:47:09 Khaled El Mously linux (Ubuntu Eoan): status In Progress Fix Committed
2019-11-14 18:31:31 Ubuntu Kernel Bot tags verification-needed-eoan
2019-11-14 18:46:46 Ubuntu Kernel Bot tags verification-needed-eoan verification-needed-disco verification-needed-eoan
2019-11-29 14:10:56 Kleber Sacilotto de Souza tags verification-needed-disco verification-needed-eoan verification-done-disco verification-done-eoan
2019-12-02 12:43:50 Launchpad Janitor linux (Ubuntu Disco): status Fix Committed Fix Released
2019-12-02 12:43:50 Launchpad Janitor cve linked 2019-15794
2019-12-02 12:51:47 Launchpad Janitor linux (Ubuntu Eoan): status Fix Committed Fix Released
2019-12-06 15:57:44 Launchpad Janitor linux (Ubuntu): status Fix Committed Fix Released