audio devices disappear, some programs freeze intermittently

Bug #1851647 reported by jnns on 2019-11-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Sometimes I notices that audio is suddenly interrupted and that all my audio devices are gone from the gnome-settings dialog.
When I run `aplay -L` it just hangs without output.

After that event occured, all right-clicks (or interactions that bring up a context menu) in Firefox and Thunderbird and Chrome make the respective programs unresponsive. Interestingly, all programs that run at that time will be unresponsive from that moment onwards for at least a minute. That means a right-click in Firefox will also effect Thunderbird and vice-versa. During that phase of unresponsiveness, there are other programs (i.e. SublimeText) which strangely are uneffected by this. The frozen programs will eventually turn responsive for a short amount of time but subsequent interactions will always make them freeze again.

I can't say that any specific event leads up to this. This happens randomly from time to time but at least once or twice a week. I'm always running Thunderbird, Firefox, Sublime Text, Sublime Merge, gnome-terminal.

I'm using Ubuntu 5.3.0-21.22-generic 5.3.7 on Ubuntu 19.10.
As far as I remember, this issue is not specific to the 5.3.x kernels and also appeared before.
The device is a Thinkpad X1 Carbon 6th Gen.

I'm not sure which package causes this and my searches in the bugtracker didn't turn up issues that seem related, so I'm also unsure about what additional information to supply. Maybe one of you can guide me and I will gladly help with out with more information.

jnns (jnns) wrote :
jnns (jnns) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
tags: added: eoan
jnns (jnns) wrote :

It happened again; my system is now in a state where every context menu invocation and showing the file-open dialog in Firefox makes Firefox stall for a minute or so.

Chrome works fine which means that context-menus can be invoked. Although when I make Firefox hang Chrome is also hanging for that duration.

Audio devices have disappeared as well.

Kai-Heng Feng (kaihengfeng) wrote :

Seems like it's an Apple device instead of Carbon X1.
Please also try latest mainline kernel.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers