aufs-tools 4.14 FTBFS because of wrong SAUCE driver in the kernel

Bug #1851447 reported by Steve Langasek on 2019-11-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned

Bug Description

The latest aufs-tools package synced from Debian fails to build in Ubuntu (but not in Debian) because the Ubuntu kernel package has aufs sauce patches and they are not at a compatible version.

[...]
   dh_auto_install
        install -d /<<BUILDDIR>>/aufs-tools-4.14\+20190211/debian/aufs-tools
        make -j4 install DESTDIR=/<<BUILDDIR>>/aufs-tools-4.14\+20190211/debian/aufs-tools AM_UPDATE_INFO_DIR=no "INSTALL=install --strip-program=true"
make[1]: Entering directory '/<<BUILDDIR>>/aufs-tools-4.14+20190211'
cc -g -O2 -fdebug-prefix-map=/<<BUILDDIR>>/aufs-tools-4.14+20190211=. -fstack-protector-strong -Wformat -Werror=format-security -O -Wall -Wdate-time -D_FORTIFY_SOURCE=2 -D_GNU_SOURCE -I./libau -DAUFHSM_CMD=\"/usr/bin/aufhsm\" -DMOUNT_CMD=\"/bin/mount\" -DUMOUNT_CMD=\"/bin/umount\" -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now ver.c -o ver
./ver
Wrong version!
aufs-util for aufs4.14 20190211, but aufs is 4.x-rcN-20190805.
See README in detail and try git branch -a.
make[1]: *** [Makefile:120: ver_test] Error 255
rm ver
[...]

  (https://launchpad.net/ubuntu/+source/aufs-tools/1:4.14+20190211-1/+build/17953990)

Please either update the aufs patches in the kernel tree, or else drop them.

(My understanding is that we probably don't want to drop them because docker may use aufs as a backend; and while this is deprecated, there is currently no upgrade story for users currently using it.)

Steve Langasek (vorlon) on 2019-11-06
affects: aufs-tools (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
importance: Undecided → High

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1851447

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) on 2019-11-06
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Steve Langasek (vorlon) on 2019-11-06
summary: - aufs-tools 4.9 FTBFS because of wrong SAUCE driver in the kernel
+ aufs-tools 4.14 FTBFS because of wrong SAUCE driver in the kernel
Seth Forshee (sforshee) wrote :

The problem is rather the opposite; the aufs in the kernel is newer than the synced aufs-tools. And I just recently found out that aufs for 5.x kernels is hosted in a different git repository, which explains why we haven't been seeing any tags for 5.x kernels (and thus the version is still 4.x-rcN).

For focal then we likely need to update aufs-tools from https://github.com/sfjro/aufs5-standalone
and update aufs-tools every time we update the kernel support. However, if the tools and kernel support really are version locked as this build error implies, that seems to pose a problem for hwe kernels.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers